High EGT's, lack of power, black smoke, poor mpg

2004LB7

Well-known member
Dec 15, 2010
3,268
187
63
Norcal
Some of my first tunes for my LMM had aggressive vane position and it was slow to build boost and smoked excessively. Rebuilt the vane table and it works wonderfully now.
 

Dozerboy

Well-known member
Jun 23, 2009
4,406
73
48
TX of course
At WOT? How many RPMs? Even with a bad vane position sensor I was still able to make 20 psi back when I was relatively stock. At WOT 3k rpms.
 

domeniccurulla

New member
Jun 1, 2020
18
0
1
2
At WOT? How many RPMs? Even with a bad vane position sensor I was still able to make 20 psi back when I was relatively stock. At WOT 3k rpms.
I'm not sure what WOT is but 7lbs of boost is the highest I see even balls to the wall. I will get an exact rom later when I go to work
 

LBZ

Super Moderator
Staff member
Jul 1, 2007
9,588
17
38
42
B.C.
I’d double check your boost numbers with a different sensor or with a standalone gauge.
 

Dozerboy

Well-known member
Jun 23, 2009
4,406
73
48
TX of course
WOT= wide open throttle

I agree with LBZ. Something ain’t right I didnt think you can make that little boost at WOT and 3000+ rpms
 

domeniccurulla

New member
Jun 1, 2020
18
0
1
2
Had a mechanic check the boost & was the same. He did find that the pipe from the egr delete popped out &there is a small leak on the back of the turbo
 

ikeG

Oughta Know Better
Apr 19, 2011
2,235
27
48
Western PA
www.griffithautosales.com
It is not giving me any codes right now because somehow my truck lost juice (stereo was wiped too). I remember the code said vane positioning sensor. If we need the actual code I will have to drive it for a while which is ok cuz my metro is down for a couple days
This tells me it's the common stuck vane problem.

Sent from my SM-G960U using Tapatalk
 
  • Like
Reactions: Bdsankey

Users Who Are Viewing This Thread (Users: 0, Guests: 1)