Early 2015 ambient issues *wiring gurus this would be interesting for you*

CrazyM

New member
Nov 28, 2011
5
0
1
Have a early 2015, Non AVF 3500hd with factory DPN mirrors

the IPC and BCM updated to the newest calibrations.
My mirro although being early build has the ambient sensor in the mirror and front of truck. So front sensor is for hvac, radio temp info and the mirror sensor is for ecm/powertrain requirements.
Noticed my ecm is always reading -40 but the hmi temp is bang on.

Diagnosing mirror sensor originally Found no power and no ground at the sensor wires(definitely odd it had neither)

Front sensor like stated, 100%. Reference voltage and ground on the wiring.

acquired diagram and traced back to ecm and was going to test continuity in the wires but found my ecm connectors do not even have pins in the appropriate locations. (See diagram) connector x2 pin 24 and connector x3 pin 26 do not exist in my ecm harness.

Anyone come across this? Very interesting. CTS3 shows ambient at -40 and using mdi with GDS2 also shows under the ecm module as -40. So it’s definitely not using the front sensor but strange no wiring.
 

Attachments

2004LB7

Well-known member
Dec 15, 2010
3,449
241
63
Norcal
what sensor is returning the -40*?

have you looked over the wires for the IAT sensor?
 

CrazyM

New member
Nov 28, 2011
5
0
1
what sensor is returning the -40*?

have you looked over the wires for the IAT sensor?
Yes. I mentioned in that post front sensor wiring is good. Reference voltage and ground and displays 100% correct on the hmi.
Mirror sensor is the issue. And yes checked that wiring that’s why I said it doesn’t even exist in the pin locations of the ecm connectors.
 

JoshH

Daggum farm truck
Staff member
Vendor/Sponsor
Feb 14, 2007
13,203
154
63
Texas!!!
What mods are done to the truck? An early truck should not have a temp sensor in the mirror unless someone has swapped in the later style mirrors.
 

CrazyM

New member
Nov 28, 2011
5
0
1
What mods are done to the truck? An early truck should not have a temp sensor in the mirror unless someone has swapped in the later style mirrors.
SDP y bridge kit, fleece cheetah, cp3 swap.

mirrors are factory DPN mirrors, rpo code in my glove box states so. Build date of 3/14.

even if the mirrors were upgraded still doesn’t make sense why I was able to update to the latest calibration for ipc and bcm as the mid year 15’s.

that mid year change uses the front sensor which is wired to the ipc for radio/hvac and the mirror becomes solely for the ecm/powertrain system.

attached a screen shot with some good info as well. I also have the k40 option as mentioned, as a diesel obviously.
 

Attachments

Users Who Are Viewing This Thread (Users: 0, Guests: 1)