White signals

dak dmax

New member
Sep 4, 2020
7
1
3
Minnesota
www.duramaxdiesels.com
Hey guys i got an lb7 just but installed 100% injectors dual ats cp3 pump and 200 gph AD LIFT. Thing ran fine at idle but poured out black smoke unerload because of to much fuel obviously I have no tune on it yet I bought efi live v2 and down loaded ecm on computer litereally started it an hour before idled just fine after download thing pours out so much white smoke at idle I smoked out the whole block and has a loud injector or rod knock. Im at a loss rn everything is brand new and I dont think it is injectors because ther brand new dont even have 100 miles on them ..... Please give me some advice. Thanx
 

ironmax

chock full of goodies
Jul 6, 2010
465
13
18
Col. Ohio
1-who did the work?
2-who decided that parts list?
3-where did the injectors come from?
4- are there any codes?
5-spend a little more money and take it someplace reputible.
6- where are you located so we can send you someplace reputible.
 

dak dmax

New member
Sep 4, 2020
7
1
3
Minnesota
www.duramaxdiesels.com
There was no tune on it.
I know I was getting a MAF code I will check again when I get home.
And the only other wired things that were happening was my actual rail pressure was at 125 at idle and my desired was telling me it should be at 30. (Im sorry I dont remember the value thing ) and my main injection would hover around 1 degree of timing and the would drop to around -13 degrees of timing.
Thats all I can think of rn guys i hope that helped.
If there anything I can look up or do with my flashscan v2 let me know
Thanx
 

Bdsankey

Vendor
Vendor/Sponsor
Feb 1, 2018
2,048
45
48
Neenah, Wisconsin
Dumb question, why on earth where you driving it without a tune for 100% over injectors? I understand maybe backing it out of the shop/garage etc but driving it (especially if you try and lean on it) is idiotic.


125mpa is ~18ksi where the truck was commanding 30mpa/~4.4ksi. IMO 4.4ksi is low for 100% but as you stated there is no tune in the truck to account for the larger nozzles. The injectors will be very noisy at idle at 18ksi.

As for your MAF code, is your truck still stock style intake or did you go from that to say an S400 single or compound setup?
 

dak dmax

New member
Sep 4, 2020
7
1
3
Minnesota
www.duramaxdiesels.com
I only drove the truck 2 or 3 times just to make sure i got everything put back together right it was about a mile each trip as for the intake that is a stock set up rn kinda ran out of funds after i bought all that other shit for it.
I will hook up the flash scan when i get home and get some more accurate data and I thought my rail pressure was to high Thanx for clearing that up because now that explains the injector timing problem
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)