Cruise control & U0140

2004LB7

Well-known member
Dec 15, 2010
3,456
244
63
Norcal
ok, so driving down the freeway and my dash all of a sudden lights up like a Christmas tree. ABS, service 4WD, check engine light lit. along with multiple messages for reduced engine power, service 4WD, ABS, etc. everything seems to be running fine and I was close to my destination so I push on. pull into the parking lot and turn truck off.

attempt to read codes with my V2 and no communication with ecm. try and restart engine and doesn't crank. disconnect the batteries and reconnect. cranks and starts. V2 now reads codes. (see attached photo) looks like high fuel pressure, thermostat engine temperature off, couple of glow plugs and lost communication with TCM.

cleared codes and when on my way. everything looks good. but I did notice that the cruise control does not turn on now. no gear light on dash nothing. read codes again and U0140 is still present. wont clear, comes back right away.

so, does this code disable cruise control and any ideas for fixing a persistent U0140 code?
 

Attachments

Chevy1925

don't know sh!t about IFS
Staff member
Oct 21, 2009
18,206
440
83
Phoenix Az
Check fuses in the underhood fuse block. the fuse block has been known to have issues some times. might be the culprit
 

2004LB7

Well-known member
Dec 15, 2010
3,456
244
63
Norcal
yeah, that was one of the first things I checked in the parking lot. sorry I forgot to mention it. didn't find any blown. I didn't check the ones down inside by the driver's door. I guess I can do that
 

Chevy1925

don't know sh!t about IFS
Staff member
Oct 21, 2009
18,206
440
83
Phoenix Az
there is a board under the fuse block that goes bad and can cause the issues you are seeing. sadly, i dont know a good way to test it. makes it seem like the BCM is bad.

maybe check wiring first and go from there? i dont think its an issue with the inside fuse panel but never hurts to check
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)