OBDII Not Ready

Suprzr1

New member
Jun 10, 2024
5
0
1
77
Santa Ynez, Ca
I'm new here, this is my first post, Rio Vista Chevrolet in Buellton, Ca. suggested I look for other posts having the same problem. My 2020 3500 failed the OBDII test on 5-20-24, have driven additional 650 miles and still fails so into the Dealer today to have Drive Cycle and smog referee smog check paperwork started. I'm hoping the Dealer can fix so I can avoid the smog referee process. Very frustrating to say the least. Truck passed the test two years ago with 32k miles now has 53k. I'll share results as soon a I hear back which I assume will be tomorrow.
I see that many others have had this issue so any advice or suggestions will be appreciated.
 
Last edited:

Chevy1925

don't know sh!t about IFS
Staff member
Oct 21, 2009
21,296
5,206
113
Phoenix Az
We need to know the system that is not “ready”, then we can help.

Cali is making smog a real pain in the ass for diesel.
 

Suprzr1

New member
Jun 10, 2024
5
0
1
77
Santa Ynez, Ca
OBDII is the aspect that is not ready, I don't know what that is or what it means but my rather limited understanding is that some sensor just isn't accumulating the information it needs so it doesn't register as passing on the smog testing report I got from the dealer. If you can advise as to what is happening I would appreciate any further information.
 

Suprzr1

New member
Jun 10, 2024
5
0
1
77
Santa Ynez, Ca
Thanks for the link, I'll check it out. The VIR says that its the Exhaust Gas Sensor/ PM Filter. No further info as to why or what steps to take to get it ready, When I tested two years ago truck had 32,336 miles now has 53,112, why it isn't ready could be not enough miles driven? Truck is at the Dealer now having the drive cycle completed and the smog referee paperwork started, I'll post results as soon as I hear back.
 

2004LB7

Well-known member
Dec 15, 2010
6,531
1,863
113
Norcal
You very likely have a EG sensor on its way out. Maybe not enough to trip a code but enough to not trigger the readiness. I just dealt with an LML doing something similar. We changed some of the exhaust temperature sensors and commanded a regular regen and took it for a drive.

All cleared but the PM filter which may take several regens to clear. But there is an exception for the PM filter so when discussed with the smog tech they passed the vehicle

media-1718131316563-May_17_2024_1_16_PM.jpg
 

Suprzr1

New member
Jun 10, 2024
5
0
1
77
Santa Ynez, Ca
Thanks for the info. Dealer called me today to update, says they are going through their testing and resetting protocols and hopefully will be completed tomorrow. I'll update as soon as I know something.