Compound turbo tuning

juddski88

Freedom Diesel
Jul 1, 2008
4,656
120
63
Chesterfield, Mass.
I believe so. It's a JZ Mfg 63mm, got them through Brad. I originally wanted Danville and thought they were gone for good until Brad mentioned that JZ is practically a Danville turbo. I'm very curious what's Mark's tuning would be like with this turbo.

So message him and see if he will send you a base file with his vane tables for that turbo....for a fee. Either way, there are certainly ways to make it spool quickly, but it is a compromise. The 10 blade is just a bit laggy with stock injectors no matter how you slice it. Get bigger injectors and you will completed forget you had all this trouble spooling in short order.
 
  • Like
Reactions: Ridin'GMC

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
Bigger injectors are the next thing to add on this. Ended up having to put it back together so I could use it to take the family camping. I know my injectors are due for a replacement but its not making low rail pressure.. yet. Now I need to find out how big of an injector can the exergy sportmans can support. Couldn't do the 10mm cp3 as that wasn't in my budget at the time.
 

Bdsankey

Vendor
Vendor/Sponsor
Feb 1, 2018
3,954
1,101
113
Neenah, Wisconsin
The JZ VVTs are 10 blade, he (and I) won't touch anything 9 blade until quality is consistently good.

Bigger injectors are the next thing to add on this. Ended up having to put it back together so I could use it to take the family camping. I know my injectors are due for a replacement but its not making low rail pressure.. yet. Now I need to find out how big of an injector can the exergy sportmans can support. Couldn't do the 10mm cp3 as that wasn't in my budget at the time.
A sportsman realistically will handle ~625-650whp worth of fuel demand so a bit small for what that compound setup is capable of for max effort.

A set of 60% or 100% injectors would be ideal with that setup and really wake it up overall.
 
  • Like
Reactions: Ridin'GMC

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
The JZ VVTs are 10 blade, he (and I) won't touch anything 9 blade until quality is consistently good.


A sportsman realistically will handle ~625-650whp worth of fuel demand so a bit small for what that compound setup is capable of for max effort.

A set of 60% or 100% injectors would be ideal with that setup and really wake it up overall.
Thanks Brad. 100% is really my goal. Hopefully I'll get it next year.
 

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
So... After a while of going back and forth on the tune trying to get it dialed in, still coming up with the same issue of falling on its face at the top end. Thinking it was the torque limiter, had it raised with the help of member on here, it's still falling on its face at the top end. Now I'm thinking it may be more of a fueling issue, even though the rail pressure is still holding at 24k psi. Is it possible the fuel line may be collapsing, even with a lift pump? Or more likely from injectors returning too much fuel at WOT? I'm suspecting injectors as I reused the original 267k mile injectors. It's not hazing or running rough.
 

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
If you have pressure you have pressure. Look elsewhere
What else would be limiting at the top end. First I thought it was the torque limiter so made some adjustments, and it's a little better but still the same issue. Something is pulling back and I'm unable to figure out by looking at the logs.
 

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
What are you commanding for vane position at WOT when it starts to fall off?
From watching on my insight gauge it'll drop down from 65-50 to 23% and hold there since that's the set minimum vane position.
So does the mm3 or even injector pulse show a drastic decrease when you think it's falling off?
On my last tune which was my last log before I made adjustments to the torque limiters, it'll drop down to 70mm³ and hold there.
Post the log up
Definitely will do sometime this week when I find time to log it with the current tune it's in now.
 

Ridin'GMC

I like red
May 20, 2010
620
7
18
MA
Finally got around to doing a new set of logs. See what you guys think might be the issue. You may notice on the vane position that dropped to the low 10's, I immediately noticed that and found a discrepancy in the vane setting that was easily overlooked by me and corrected that, should be fixed now but haven't tested yet my tune I adjusted to correct the error.
 

Attachments

  • E35_0021.zip
    9.5 KB · Views: 3
  • E35_0022.zip
    10.4 KB · Views: 0
  • E35_0023.zip
    11.9 KB · Views: 0