Built Allison 1-2 shift flare when cold

LBZ_Baker98

Member
Jul 8, 2016
205
2
18
Texas
Mine only flares slightly when it makes the first few 1-2 and 2-3 shifts for the day or when cold. Once fluid temp is over 100* it never skips a beat. Shifts quick, firm and flawlessly! Unfortunately I have to drive it so for the first few 1-2 and 2-3 up shifts I stay easy on the throttle so it doesn’t flare hardly at all if any and then I drive it like normal after getting about a mile from the house! Goerend R converter here!
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,680
231
63
Fullerton CA
What if the stator is damaged? Would that cause pressure issues that could possibly make a flair happen.

The common failure of the stator support is the shaft moving out of its bore or twisting in the bore. When that happens the symptoms will usualy be constant.
I gaurantee your sealing rings are no good as they were defective when new. You also are running Alto Red Eagle clutches with slotted C3/C4 clutches which are known to start failing after high mileage. They will warp. Your mainline pressure is only 250 psi which is low. Your Transgo trim springs are probably worn out or bent which can cause slippage.
 

08lmm72mm

Active member
May 13, 2019
369
104
43
Saskatchewan, Canada
The common failure of the stator support is the shaft moving out of its bore or twisting in the bore. When that happens the symptoms will usualy be constant.
I gaurantee your sealing rings are no good as they were defective when new. You also are running Alto Red Eagle clutches with slotted C3/C4 clutches which are known to start failing after high mileage. They will warp. Your mainline pressure is only 250 psi which is low. Your Transgo trim springs are probably worn out or bent which can cause slippage.

My truck has been used for work traveling lots on the road and not pulling squat. It sat for 1.5 years in 2017-18. I've fixed a ton of issues with the truck now this trans is the last thing I'm working on to make it run perfect.

I found an old post that you commented on in another web forum saying that the converter that came with the trans I bought didnt come with a billet stator. Now over the course of the years there has been some good burnouts done and a couple boosted 4wd launches so I'm sure its took damage. There was fairly loud rattleish type noise coming from the bell housing last year with a rough idle after it sat for awhile and I started driving it again so I had a Suncoast flex plate installed. Upon inspect my stock flex plate has no visible damage. Although after my rough idle persists, some days its smoother than others and watching balance rates it's like the ecm is constantly changing them to find the perfect idle. I'm putting in a new FPR in along with the new converter this week.

Acceleration isnt what it used to be either, truck feels very laggy down lower where it used to just fly. Injectors are fine, cp3 keeps up, zero boost leaks. Everything I've done is leads me to believe the stator is damaged in this TC.

Is there anything I could replace in the valve body or on the trans without doing a full rebuild at the moment? Keeping costs lower for a bit here. Thanks for the advice!
 
Last edited:

Bdsankey

Vendor
Vendor/Sponsor
Feb 1, 2018
3,194
459
83
Neenah, Wisconsin
My truck has been used for work traveling lots on the road and not pulling squat. It sat for 1.5 years in 2017-18. I've fixed a ton of issues with the truck now this trans is the last thing I'm working on to make it run perfect.

I found an old post that you commented on in another web forum saying that the converter that came with the trans I bought didnt come with a billet stator. Now over the course of the years there has been some good burnouts done so I'm sure its took damage. There was fairly loud rattleish type noise coming from the bell housing last year with a rough idle so I had a Suncoast flex plate installed. Upon inspect my stock flex plate has no visible damage. Although after my rough idle persists. I'm putting in a new FPR in along with the new converter this week.

Acceleration isnt what it used to be either, truck feels very laggy down lower where it used to just fly. Injectors are fine, cp3 keeps up. Everything I've done is leads me to believe the stator is damaged in this TC.

Is there anything I could replace in the valve body or on the trans without doing a full rebuild at the moment? Keeping costs lower for a bit here. Thanks for the advice!


Buy a gasket set and AT LEAST tear into it to inspect the clutches. The old red eagles aren’t known to have the best life and I’d agree with Mike, some of your tolerances may have opened up.
 

LBZ_Baker98

Member
Jul 8, 2016
205
2
18
Texas
Okay, just to update everyone! I took the truck to Josh last Tuesday and picked it up today. He Was slammed and still managed to get me worked in. For starters my warranty was 110% expired. I failed to get the truck to him before the warranty was up despite him telling me to bring it back long long ago. Any how, Josh pulled the trans and found cleanses to a bit off from what he likes in C3. Joshes resolution was to replace c3 and c4 clutches and steels and re clearance c1. The best part was he covered it all. Charged me for fluid and filters and that is it. I had told josh in the beginning I didn’t expect him to warranty it since it was my fault I didn’t get it to him in time yet he still took care of me. Josh and all the guys at Top Notch Garage are stand up, honest, down to earth people and I can’t say enough good things about them and their work!
 
  • Like
Reactions: ShopSpecialties

KyleC4

Tech
Dec 30, 2016
470
48
28
Bay Area
Nice to hear you got it all fixed up. Good people like that are hard to find In this world anymore. Thankfully some of them post on this site so it makes it easier to contact them. And I hope you at least tipped them generously for their time and effort