Duramax Diesels Forum Truck of the Week
  #1  
Old 04-11-2018, 10:07 AM
notalent notalent is offline
FNG
 
Join Date: Oct 2013
Posts: 1
Default 2014 lml no start intermittent

truck is a 2014 GMC LML 3500 hd base model crew cab (4 FULL DOORS) with power locks and power windows but vinyl floors etc.

Has anyone ever dealt with this before or seen this.

I have read and read and read about this and tried everything I've seen, read and even some stuff no one suggested so now I'm asking for advice.

I know a no start on the LML's isn't a new thing I've seen it a couple times and fixed a couple but this one is making zero sense.

So here is the problem:

random no crank no start, cluster will light up and all accessories will power up communication with ecm, tcm, bcm and security module are all good via a scan tool. zero codes. truck will go two or three days perfectly then not start for a week, leave it sit and don't do a thing to it and try to fire it up in a day or two and it'll fire up and be totally normal until it gets mad again.

what has been tried:

swapped the following:

ecm, tcm and security module as well as programmed new key, ignition switch "box" in column

replaced:

key, all relays, any fuses with any carbon or were questionable, diode on rear of harness, shut down security on ecm via EFI LIVE.

clean under fuse box and all connectors to main wiring harness (fuse box didn't look bad on bottom side but cleaned it none the less) chased all grounds and cleaned them and ohm'd out grounds and powers into ecm and tcm to made sure didn't have broken wire or loose pin in a connector or corrosion to the ground connection on the body or engine. have checked the harness for rub marks under cab and on chassis to ensure it wasn't grounding a circuit there as per the GM TSB's

anyone have any input on this?

any input is greatly appreciated.
Reply With Quote
  #2  
Old 04-11-2018, 10:53 AM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 1,427

Default

What ohm reading do you have on the can bus?
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #3  
Old 04-11-2018, 11:52 AM
Yngdmax92's Avatar
Yngdmax92 Yngdmax92 is offline
Hotrodder
 
Join Date: Sep 2013
Posts: 628
Default

Check the wiring really really closely going to the back of the truck. Wires going to the sending unit and the trailer brake system.

Had a recent problem like this and found 2 wires rub through and create a no start Condition on a 2011 lml

Sent from my Pixel 2 using Tapatalk
__________________
2003 2500 hd cc/sb (leftovers) MPS 63.5 ihi, built trans, airdog 150, 30 overs..... Sold


New and improved! 2007 classis lbz LS ec/sb

Egr delete, pcv re-route, PIPED, airdog 4g 165,

Danville performance tunes.
Reply With Quote
  #4  
Old 04-11-2018, 02:00 PM
sargenthp sargenthp is offline
FNG
 
Join Date: Dec 2017
Posts: 3
Default

Check both batteries and their connection?

Sent from my Moto G (5) Plus using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:44 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors