Ticking noise when accelerating

ElReeso

New member
Apr 9, 2019
10
0
0
New to the forum and new to Diesels!

I just bought my first Diesel and its an 04 LB7 with 156k on it.
Truck needs some work but thats not the issue.. While test driving I noticed a ticking sound from 1100 rpm till short of 3000rpm. If I´m flooring it it goes away and nothing at idle or very light acceleration. Stops as soon as I let off the pedal at any rpm.

Bought the Truck anyway and drove 800 miles home. All held up but now it is parked till I know what is going on.

I haven´t checked the Injector Balance rates because I´m lacking the tool for it and the Banks tuner isn´t showing them. It´s not smoking or doing anything weird, neither do I have blow by.. This is all a know so far as a Diesel newbie..

So what could this ticking be and how can I diagnose it? I want to buy different things for the truck but first I need to know if I need injectors or other engine stuff..
 

Dukchunter

New member
Jan 12, 2018
52
0
0
Can you determine if the ticking noise was coming from one side of the engine or the other?

Sent from my SM-G960U using Tapatalk
 

ElReeso

New member
Apr 9, 2019
10
0
0
I listened while my girl reved it a bit and I thought it was coming more from the driver side.
I´m not sure on that though.. I will try to upload a video while driving and while reving.
 

Dukchunter

New member
Jan 12, 2018
52
0
0
Sounds like my lb7 did after doing headgaskets and valve adjustment.... and 10k miles later it dropped a valve... dont want to scare you tho. So there is a possibility ots pilot ignition but that seems like its definately too loud for pilot. Someone else will chime in hopefully that knows more about that. I would honestly check for exhaust leaks around the exhaust manifold first before tearing into anything major

Sent from my SM-G960U using Tapatalk
 

ElReeso

New member
Apr 9, 2019
10
0
0
From my understanding the LB7 has no EGR.. its Canada specd Truck.

I really hope I can fix this soon and with a small amount of money..
 

duramaxnate

Professional Amateur
Feb 18, 2014
513
0
16
28
Norco, CA
www.mcfooracing.com
Well lets take a few diagnostic steps.

1) Do you know what is all done to the truck? Tuning? Mileage?

2) Do you have any type of scanning device to look at the trucks parameters?

3) Do you have any previous service records for that truck?

4) Where are you located?

And certain LB7s did indeed have EGR systems. RPO codes YF5 (California) NE1 (North east) and VCL (Clean fleet)

To me it sounds normal. LB7s can be noisy but it doesn't hurt to run through some steps to see if there is anything wrong.
 

ElReeso

New member
Apr 9, 2019
10
0
0
1) Banks Air Intake and Banks IQ Tuner, Boost Increase Valve. Banks is currently set to Setting 2.

2) just a normal OBDII Reader and the Banks unit. Both won´t show Injector Balance rates

3)No Service Records available unfortunatly so no Info about Injector change or other changes

4)located in South Germany.. not much Duramax around here:(

5) yes I know about the Cali Specd Trucks but mine has none of the RPO codes you listed so it shouldn´t have EGR
 

duramaxnate

Professional Amateur
Feb 18, 2014
513
0
16
28
Norco, CA
www.mcfooracing.com
1) Banks Air Intake and Banks IQ Tuner, Boost Increase Valve. Banks is currently set to Setting 2.

2) just a normal OBDII Reader and the Banks unit. Both won´t show Injector Balance rates

3)No Service Records available unfortunatly so no Info about Injector change or other changes

4)located in South Germany.. not much Duramax around here:(

5) yes I know about the Cali Specd Trucks but mine has none of the RPO codes you listed so it shouldn´t have EGR

What I would do is try to put the stock tuning back on and see what difference it makes. Sometimes tuning can make the injectors rattle like that.
 

ElReeso

New member
Apr 9, 2019
10
0
0
Thats problem number two.. I clicked through the powerlevels from 1 to 6 and absolutly nothing changes.. no added boost or smoke on setting 6 and same ticking sound on level 1.

I think I need to mess around with the tuner a bit more to see a change maybe.. did the clicking twice and it hung up the last time..
 
Feb 2, 2019
93
0
6
29
Utah
Well lets take a few diagnostic steps.

1) Do you know what is all done to the truck? Tuning? Mileage?

2) Do you have any type of scanning device to look at the trucks parameters?

3) Do you have any previous service records for that truck?

4) Where are you located?

And certain LB7s did indeed have EGR systems. RPO codes YF5 (California) NE1 (North east) and VCL (Clean fleet)

To me it sounds normal. LB7s can be noisy but it doesn't hurt to run through some steps to see if there is anything wrong.





Sent from my iPhone using Tapatalk
 

Dukchunter

New member
Jan 12, 2018
52
0
0
Listen in through the driver's side wheel well... see if it isnt loudest there

Sent from my SM-G960U using Tapatalk
 

ElReeso

New member
Apr 9, 2019
10
0
0
Your videos make me think valve lash.

Sent from my SM-G960U using Tapatalk
Watched a few videos on it. Could be possible.. Its my first duramax and i have no clue about them but it seems like its slow and doesn´t have power at low rpms.. could it already be to late and my valves are seated in?
 

Solo Ascent

New member
Apr 25, 2020
1
0
0
Watched a few videos on it. Could be possible.. Its my first duramax and i have no clue about them but it seems like its slow and doesn´t have power at low rpms.. could it already be to late and my valves are seated in?
Did you find the problem yet?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)