Running Hot

Jall

New member
Aug 22, 2019
5
0
1
07 Duramax with Allison runs hot. Recently discovered that the cooler in rad had clutch material from a prior failure. Replaced rad. Ran 150 degrees for several days and then all of the sudden was running 190-200 without towing anything. checked trans temp with infared gun and it matches gauge. No codes in trans and trans shifts fine. Thank you
 

Jall

New member
Aug 22, 2019
5
0
1
Ongoing complaint with running hot. C3/C4 clutches had some hot spots (not bad) and were replaced and reman convertor installed. Stock parts. Cooler was flushed out with hot flush machine. After problem still occurred, rad was replaced. How do you recommend checking temp? Thank You
 

Bdsankey

Vendor
Vendor/Sponsor
Feb 1, 2018
2,449
135
63
Neenah, Wisconsin
Ongoing complaint with running hot. C3/C4 clutches had some hot spots (not bad) and were replaced and reman convertor installed. Stock parts. Cooler was flushed out with hot flush machine. After problem still occurred, rad was replaced. How do you recommend checking temp? Thank You
Reference the OEM temperature sensor or add one to the pan. An IR gun is not going to provide anywhere close to an accurate reading for the actual fluid temperature.
 

08lmm72mm

Member
May 13, 2019
43
2
8
Saskatchewan, Canada
When my OEM TC started slipping and I put a new built trans and tc in I had the trans cooler flushed but the trans would still run hot and I had to pull over and let the truck cool down on the hiway to get the trans Temps down. It took a second trans flush to get it right.

Maybe the GM dealer that did the flush the first time never did it right ill never know but that could be the case you are having. My built trans now has 120,000 miles not a day under 500hp and works great.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)