Rail pressure climbs while coasting.

darkness

Active member
Jul 15, 2009
950
65
28
45
vegas
I’m having an issue with rail pressure. While coasting it wants to climb to 14.5k while desired sits where it’s supposed to be. Also it doesn’t do it as bad after motor starts warming up. At operating temp it’ll only go to about 9.5k. As soon as the truck comes to a stop it’ll fall back in line with desired. And as soon as I hit the gas while coasting it falls back in line with desired. I honestly don’t know when it started doing it but it started popping the p0089 code a couple months ago and that’s when I started noticing it. It does in on any tune, it did it with the lb7 regulator and also now with the Lbz reg. And also before and after the SAC45’s which I just did. Lift pump pressure is 6-7 psi. Thanks for any insite!
 

Yngdmax92

Active member
Sep 26, 2013
933
32
28
my truck still does it to date, lift pump pressure is right on the edge, when trucks cold pressure rises while descending down a hill. get back to idle and it levels out. i never adjusted mine cause i dont drive mine in the winter. so it does it maybe 1 or 2 times a year
 

2004LB7

Well-known member
Dec 15, 2010
3,848
354
83
Norcal
Regulator control isn't open enough on the bottom, downside is a pressure drop at times if you get it fixed for the rise while decel it can create an issue in a different spot.
I had this same problem. could never get it to work all across the range. when I got the pressure right during decel it had issues during idle. that's why I ended up just increasing the time before the code sets. worked for me
 
  • Like
Reactions: MarkBroviak

darkness

Active member
Jul 15, 2009
950
65
28
45
vegas
I’ll poke around some tables. Sounds like a just deal with it problem, which isn’t really a problem as the motor doesn’t seem to notice. It stays quiet and no real lope while it’s doing it. Thanks guys!
 
  • Like
Reactions: MarkBroviak