LML P128e?

ComnRailPwr

New member
Sep 17, 2012
4
0
1
Got an lml in the shop that keeps getting code p128E and going into reduced power. Any idea on what the gm fixes are for this? Truck just had a complete new fuel system installled due to cp4 crapping out and the install work was less than good. I believe this to be the cause. Code wasn't pressent before IP bombed. Efilive shows actual rail going to max and injectors start rattling. It is not consistent with anything. Almost acts like bad fca connection. Google tells me this is not a common code.
 

ComnRailPwr

New member
Sep 17, 2012
4
0
1
Yeh customer needed his truck and picked it up. Also started getting p0090. I think its a rail sensor, fpr or a wiring issue. Guy who did the work on the new fuel system made a mess.
 

cokane1

New member
Nov 5, 2012
11
0
1
Did you find anything out on this? My LML was doing the same thing, so I took it in and got the cp4 upgraded to a CP3. My CP4 hadn't grenaded yet, I assumed it was just about to go though.

Same symptoms. 0-40% throttle position it was fine at first, then you'd hear the rattle and the data log would show it going from 18,500 rail psi to full spike at 29k triggering the p0128 code and reduced engine power. clear the code, it went away, then it would start the whole thing all over again.
 

ComnRailPwr

New member
Sep 17, 2012
4
0
1
Did you find anything out on this? My LML was doing the same thing, so I took it in and got the cp4 upgraded to a CP3. My CP4 hadn't grenaded yet, I assumed it was just about to go though.

Same symptoms. 0-40% throttle position it was fine at first, then you'd hear the rattle and the data log would show it going from 18,500 rail psi to full spike at 29k triggering the p0128 code and reduced engine power. clear the code, it went away, then it would start the whole thing all over again.
was this after your cp3 upgrade? Customer needed it so I could not troubleshoot further. I believe it to be fpr, rail sensor or wiring harness related. I just put a deleted stock file on it and told him to take it easy. If he lets out when it starts to rattle the code wont pop up.it also started throwing p0090.
Man I better do a CP3 upgrade to mine.
Yeh hes 6k deep into repairs. It would be on my hot list. Bad thing is he didn't know any different and it got a cp4 put back on it best I could tell
 
Last edited:

ComnRailPwr

New member
Sep 17, 2012
4
0
1
Truck I tuned had 128k. I believe the issues to be caused by the chitty work that was done installing the new parts.
 

cokane1

New member
Nov 5, 2012
11
0
1
was this after your cp3 upgrade? Customer needed it so I could not troubleshoot further. I believe it to be fpr, rail sensor or wiring harness related. I just put a deleted stock file on it and told him to take it easy. If he lets out when it starts to rattle the code wont pop up.it also started throwing p0090.

Yeh hes 6k deep into repairs. It would be on my hot list. Bad thing is he didn't know any different and it got a cp4 put back on it best I could tell
My problem was before the cp3 swap. If I let out before 40% TP, the rattle would stop and no code as well... But you can't really drive a truck like that LOL. Cp3 is a must on these trucks. CP4 just isn't reliable even if you're not trying to make big power.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)