P0742 Confusing Problem

justin722

New member
Aug 8, 2014
10
0
1
Hey guys, over last summer I got a P0742 code and range shift inhibited when I shifted back to park, then limp mode sometimes unless I shut the truck off and on again.

I did some reading on the code and found some good info to check/symptoms like mine. The truck will not do a break stand or even pull out on a slope sometimes. It takes a few seconds for it to realize what it’s doing and then the rpms go up and spools and it goes.

TCC solenoid shows 11 ohms almost exactly. (Unless you’re holding the metal, found that one out and saw some crazy numbers lol)

Fluid showed way low. Which was odd because I hadn’t had any leaks. Drained coolant & transfer case and had no mixing in any oils. I filled the fluid and still had the same problem, now after the truck sitting a couple months the fluid is way way high. To the point that it was about 3 inches up on the back of the pto cover. Where was this fluid? Possibly locked up in TC?

Not sure what else I can do to troubleshoot or if replacing the solenoid would be worth it? I’ve read they don’t go bad often, but anything’s possible right?

Any help is appreciated!!
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,515
149
63
Disneyland, CA
Your converter clutch is not releasing. What's the history on the trans? Mileage? Stock or built?
 

justin722

New member
Aug 8, 2014
10
0
1
Stage 4 ATS (unfortunately), has always shifted really rough 3-4 and ATS says it’s “normal” for a built trans. Built roughly 25,000 miles ago. Truck has 220,000. Never had a single problem with converter lock/unlock though until this. Tow haul and 5th gear lockup still seemed to work fine while having this issue.
 

justin722

New member
Aug 8, 2014
10
0
1
Sitting here stumped I keep testing the ohms on the solenoid, sometimes I get a higher reading 12-24 ohms randomly then test again and it’s 11-11.5. Not sure how crucial this is
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,515
149
63
Disneyland, CA
Sonds like a typical ats converter gone bad. Pull pan and peel open filter and see what's inside. Maybe a bad F trim solenoid, but I doubt it.
 

justin722

New member
Aug 8, 2014
10
0
1
Pan is off already and didn’t notice any chunks or much metal at all in the pan or on the plug, but what exactly am I looking for in the filter just more material? & thank you I appreciate the help a lot.
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,515
149
63
Disneyland, CA
Red or tan paper material. You will have to peel the filter open and unfold filter paper to see it. Make sure you have another filter handy when you do this or you are dead in the water as far as driving.
 

justin722

New member
Aug 8, 2014
10
0
1
This might be real dumb question but what do you mean peel it apart? Looks like I would have to cut it or something, lol. But the trucks all torn apart anyways at the moment I don’t drive it all the time thankfully.
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,515
149
63
Disneyland, CA
Your filter is plugged dude. Time to pull it apart. This is more than a converter problem. This is an ats problem. Time for a build.
 

justin722

New member
Aug 8, 2014
10
0
1
What are you looking at on that? Should the filter not be so saturated & dark and that shows how much clutch material is worn off? I appreciate you being straight up with that, I’m not trying to question what you said even a little bit I’m just trying to learn more.
 

Mike L.

Got Sheep?
Staff member
Vendor/Sponsor
Aug 12, 2006
15,515
149
63
Disneyland, CA
Do you see the small pink spots on your filter? Those are the unplugged parts of the filter left. Those pink spots are where the pump is trying to suck fluid through. Aint happening. If you can't figure this out, I can not help you anymore.
 

justin722

New member
Aug 8, 2014
10
0
1
Nope that’s precisely what I was looking to confirm as it just makes sense. Just didn’t want to throw out my opinions on what I saw without having the knowledge to do so.

Any cause that you've found to this or just typical for ATS? Honestly I haven’t been happy with the build since day one of the build but in my head I blamed the guy that built it. He told me to buy the ATS copilot and that’ll solve my problems with hard shifts.

I’m on the east coast, do you still recommend Limitless Diesel? If you’d rather talk over PM for business things I understand that as well.

Once again thank you for your help and advice. You’re exactly the person I was hoping to hear from.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)