Non-Allison - Mike or Evan know anything about a 6T70?

Cougar281

Well-known member
Sep 11, 2006
1,489
32
48
St Louis, MO
I know this isn't Allison related, but Mike Mike and Evan are the most trusted 'go-to' people for transmissions, so hopefully one of them knows something about the 6T70 transaxle (I THINK that's what's in the car, I haven't been able to definitively confirm it... it's almost certainly a '6Tsomthing' since it's a 6 speed front wheel drive but results are all over the place.. seems it may be a 6T70 M7W as that appears to have been paired with the LTG in the Malibu according to GMAuthority, but Wiki shows the 6T70 as only being in the Malibu from 2008-2012 with the LY7)....

My wife's 2015 Malibu has started shifting BAD. Like indescribably bad. I've always thought there was something 'not right' going on between some shifts, but this is a whole different level. I've noticed in the past some shifts feeling 'odd,', but nothing OMG bad. As usual, she doesn't say anything until something's about to grenade :rolleyes:. But anyway, the fluid right now is BURNT. It has the appearance of used motor oil, color wise... So I'd say it's on borrowed time at best.

Do either of you (or anyone else) have any experience with these, and might you have a rebuild kit for them, or be able to recommend a reputable place to go for a kit? If you search Amazon or fleabay you get 6,000 results, but who knows which ones truly are good and which are junk. I'd much rather go to you guys for the parts if you have them, but I'd settle for a source you'd recommend.
 

duckmans83

Member
Oct 13, 2018
95
0
6
GA
Hope you get something back from someone with real info. My friend use to park on a hill with his chevy car and was slipping with burnt or dirty oil. After some Google, we did a simple fluid change and he quit parking on the hill and he is good now. I think the hill was causing a fluid pickup issue and Google said not to change the filter or flush because that would cause more issues. Good luck!

Sent from my SM-G970U using Tapatalk
 

PureHybrid

Isuzu Shakes IT
Feb 15, 2012
2,707
28
48
Central OH
Does the owners manual say what trans? I think the newer equinox of the in laws had a 6T50? Pretty simple to do a drain / fill on the trans but there's very little info online about it
 

Cougar281

Well-known member
Sep 11, 2006
1,489
32
48
St Louis, MO
I skimmed the manual and it doesn't seem to indicate exactly what it is... It had been run 'low' once a bit back, but after I found that and topped it off, as of now, the level is fine, just VERY brown... Not even a hint of red/pink. I doubt a hill comes to not play in this case because it's parked on pretty flat terrain 95% of the time. It seems, based on my time riding in it this evening, downshift 'clunks' seem to be the worst, but she says earlier, upshifts were equally bad... Problem here is there are no codes (I have a MDI2 and GDS2), and with the way it's shifting and the burnt fluid, I'm rather surprised there isn't at least one transmission code.

I should probably note that in general, the TCC slip tended to be well above desired most of the time while I was logging.

A simple fluid change might help to some degree, but I suspect there's more going on and that's akin to a bandaid on an severed leg...

Sent from my Pixel 5 using Tapatalk
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)