No start condition -- need help

toorealmonte

New member
Mar 1, 2020
4
0
0
Westland michigan
Looking for help or advice. Has a new cp3 2 injectors new fass new filters deleted filter head n put back on n off. New fprv made truck run for 2 days now back down dropped tank 2x. Iddles at 5300 psi no haze when running ive read n read for a month spent 1000 bucs so far still not fixed runs fine 1 day then down for a wk then after messing with bunch of crap runs a day or 2 then down
 

TheBac

Why do I keep doing this?
Staff member
Apr 19, 2008
13,375
21
38
Mid Michigan
Moved this into it's own thread in LB7 so it'll be seen.

O/P referenced this thread for advice: https://www.duramaxdiesels.com/forum/showthread.php?t=43258

Monte, based on the fix in the thread you originally posted in, how old are your fuel lines? I had to replace mine b/c rust built up within the quik-connect fittings, causing enough of an air leak that the truck wouldnt run.
 
Last edited:

toorealmonte

New member
Mar 1, 2020
4
0
0
Westland michigan
I didnt replace them guy i bought truck from had shop only change 1 and guy that has my truck at shop says it seems 1 injector is pinging but also that the lines that go to filter head are bad and leaking which i dont see them leaking but are dryrotted pretty bad. So im ganna buy 1/2 fuel line in replace instead of using the gm pieces cuz there 130 bucs for to lil rubber hoses
 

toorealmonte

New member
Mar 1, 2020
4
0
0
Westland michigan
Yea i no its not enough thats whst im tryin to figure out why its only getting up to 1100 then dropping fuel lines look ok kinda rusty really rusty were lines meet fuel cooler in front of tank
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)