New to me '06 LBZ

shakenfake

Moron
Sep 15, 2022
9
0
1
Shlumpt, TX
Good afternoon everyone! I just purchased about a week ago a 2006 LBZ GMC Sierra that was very very nice on the outside and inside. Test drive and a quick check around the common problem areas told me it was fine and off I went with my purchase. I was recommended this site by someone I know on another board. I am now having a few troubles with my truck which seem to be quite the pain in the ass for most. Truck was well taken care of and had all the records of maintenance as well.
1663789716144.png

So far I am loving the truck except for these codes I am getting. Hopefully I can learn and diagnose the problems properly. Glad to be here
 

Bdsankey

Vendor
Vendor/Sponsor
Feb 1, 2018
3,069
376
83
Neenah, Wisconsin
Welcome! If you were aiming to post codes or an image (beyond the truck) then they did not attach.

What codes are you having pop up? What kind of issue are you seeing?
 

shakenfake

Moron
Sep 15, 2022
9
0
1
Shlumpt, TX
Welcome! If you were aiming to post codes or an image (beyond the truck) then they did not attach.

What codes are you having pop up? What kind of issue are you seeing?
P2510
P2610
P2563
I also had a P003A code but I have not seen that one again recently.
So far I cannot say for sure that I have any "issues" this truck is new to me so I am still getting my bearings on the power. I couldn't reasonably say for certain that the truck is low on power. I know the latter 2 codes are turbo related and I have looked into diagnosing the issue. I have an Autel scanner but I have not had a chance to try commanding the VPS and seeing what happens.

The P2510 and P2610 someone told me that the 2510 is a ground problem, although on alldata sheet it says nothing about a ground. Also apparently 2610 is remnants of a tuner that someone may have used? I do not have such a thing. I see on alldata I can unplug the ECM and reconnect and clear codes and it should fix it but I have yet to try it, been a little busy. I do not have any detrimental issues because of these two codes that I can find.
 

2004LB7

Well-known member
Dec 15, 2010
4,237
500
113
Norcal
P2510 can occur if something like a lift pump is installed using the ignition to power it and / or a bad ground location was used. I haven't looked too much into that code but I believe it is something along the lines of the ECM is still seeing some voltage on the ignition when it should be off
 

shakenfake

Moron
Sep 15, 2022
9
0
1
Shlumpt, TX
Yeah the vane solenoid and vanes is what I figured. I will try and command the vanes to move and see what happens.

This truck is stock from everything I see. Certainly no lift pump. I am assuming once upon a time someone may have had a canned tuner but it is not deleted.
 

1FastBrick

Active member
Dec 1, 2016
753
69
28
Junkyard
Whale Cum Homo!!!

Good to See you found your way over here with the new acquisition. Lots of smart People on this site to point you in the right direction.
 

shakenfake

Moron
Sep 15, 2022
9
0
1
Shlumpt, TX
I made a thread about this topic. P2610 went away somehow