LB7 power steering fluid leak

tkerb92

New member
Mar 21, 2020
11
0
1
About two months ago I topped off the power steering fluid and its now low enough where it doesn't show up on the dip stick so I know its a ps fluid leak
I could use some help diagnosing the leak. I degreased and hosed everything off the best could. Then I started the truck and let it idle and turned the wheel a few time while trying to find the leak but over 15-20 minutes I didn't see anything new. So now the truck has been sitting for a week and I see a new oil puddle sitting under the truck so I looked in the driver sider fender and all the areas I cleaned are coated in fluid again.
So since it leaks while just sitting and not running I'm curious where the leak would most likely be coming from? I'm not too familiar with power steering components and it seems to be the one thing on a vehicle I haven't worked on before so any help would be awesome. Thanks
 

silvrmax04

IBEW local 24
Apr 18, 2007
88
1
8
md
most common place is one of the 3 hoses under the pump. Drivers side front. If so I would replace all 3.
 

tkerb92

New member
Mar 21, 2020
11
0
1
most common place is one of the 3 hoses under the pump. Drivers side front. If so I would replace all 3.
would those leak while the truck is not running?
it isn't leaking a whole lot which makes it hard to tell where its coming from since it took a few days for me to notice a spot under the truck
 

silvrmax04

IBEW local 24
Apr 18, 2007
88
1
8
md
would those leak while the truck is not running?
it isn't leaking a whole lot which makes it hard to tell where its coming from since it took a few days for me to notice a spot under the truck

Sure if it’s the return line or even the supply draining out of the hose.
 

silvrmax04

IBEW local 24
Apr 18, 2007
88
1
8
md
Just crawl under there and see where it is coming from. Wipe everything down then start it up. Take a short drive and see if you can find the leak.
 

tkerb92

New member
Mar 21, 2020
11
0
1
so I cleaned everything up and then let it idle for a bit, didn't see anything so a few hours later I checked on it and it looks like its leaking from the pump itself.
Cant tell exactly where its coming from but I don't think its either of the lines.
IMG_0427.jpg
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)