help truck just shut down..

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Truck in sig.. I was just driving it was like I turned the key off.. it has enough rail pressure to start it.. Injector command is at 0 and rpm is at 0 when cranking... Things ive checked all fuses and swapped the crank sensor out.. still nothing any ideas would be great before i take it somewhere.. I need to check and see if theres power at the crank sensor yet.. but I'm guessing there won't be any power cause thats my luck.. and there isn't any codes.. again thanks for any advise.
 

Dirtymaxx03

Active member
Aug 3, 2009
3,108
1
38
My truck randomly shut down once, no codes, nothing. Just died. Wouldn't start so I had it towed to a dealership. The truck got there, they backed it off the trailer and it started right up. Hasn't done it sense.
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Haha I just got it off the trailer I I told the guy driving to hit all the bumps he could lol. But didn't work for me.. and I will check the grounds
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Ok thanks i will after work.. what happens when the ecm takes a crap? Only reason i ask i cause i just put in a kill switch and was hooked to the ecm and we tested it yesterday morning.. then this happens
 

Leadfoot

Needs Bigger Tires!
Dec 27, 2006
851
11
18
45
Western MA
www.matpa.org
Ok thanks i will after work.. what happens when the ecm takes a crap? Only reason i ask i cause i just put in a kill switch and was hooked to the ecm and we tested it yesterday morning.. then this happens

Can you "undo" what you did and see if that makes a difference? Kinda a big coincidence you did that recently.
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Ya as soon as it died I was hoping it somehow blew the ecm fuse but nope its good and i unhooked the kill switch.. but ya that's what i thought..
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Ok guys I have no power at the crank sensor.. does the power come from fuse box Or ecm.. I'm waiting for gm to get back to me with wiring diagram as I'm not even sure which wire should have powere yet lol but none of the three do. so i figured id ask u guys thanks
 

Stingpuller

The Pusher Man
Jan 11, 2007
2,018
35
48
54
central Ohio
Sensor

I think it comes from the ECM. There should be a few other (dead) 5 volt ref. that also come from the same 5 volts. I would have to look to see which one is hot and I don't have my paperwork here. If you can't find it I will dig it up wed.
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Ok I appreciate it.. I have checked continuity from sensors to bale connecter its good. If that helps lol.. I hate wiring. But Ive been told its unlikely my ecm..
 

blk smoke lb7

<-----Lots of green $
Nov 8, 2010
5,694
0
36
54
belvidere,ill
Its a long shot but try clamping a ground wire on the ecm with a vise grip and ground it to the batt or a goot frame ground and se if it starts.

We took a buddies truck to get tuned and when he took the batt cable off to ook up his dsp5 it feel down and must have touched the ecm and sparked.It blew every ground inside the ecm,we limped it home with a ground wire vise griped to the ecm and grounded to the frame till he could get another ecm. he drove it for a couple weeks like that so if that is what it is you could soder a ground wire onto the ecm and run it like that i guess.Just something to try anyways.
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Ok thanks a lot guys.. I'm bout to pull my hair out lol.. its just weird that there's no codes and no other problems that I can see besides no power at crank sensor.. and does it go thru the fuse box Or right to ecm?? I didn't get that far last night and gm never got back to me.. thanks again guys I woulda much rather the cp3 take a crap Or something lol
 
Last edited:

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Just to update.. I've now checked all fuses.. checked pins.. tested wires all way from sensor to ecm plug in.. swapped crank sensor.. swapped in a used ecm to see if I could get power.. so im pretty lost.. have now found I had a rat under fuse box with some bare wires but none burnt Or broken and never blew a fuse... The truck will most likely be on a trailer tomorrow night heading to the dealershi:spit::spit:
 

bluecollar

New member
Feb 28, 2012
351
0
0
ia
Hey guys its alive.. don't let anyone tell u a cam sensor will not cause a no start.. the sensor was grounding out the 12 volt reference and is connected to the same circut as the crank sensor in ecm.. i wanna thank u guys for all the help.. un plugged the cam sensor and had power at the crank sensor
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)