GM Trouble Codes - Master List:

McRat

Diesel Hotrodder
Staff member
Aug 1, 2006
11,247
0
0
61
Norco CA
www.mcratracing.com
GM had a brain-furt in 2006. The LBZ was originally ID'd as LLY, badged at 310HP, made about 335 in real life, and has ZERO parts interchangeability with the LLY (maybe the fuel filter? Maybe not...)
 

McRat

Diesel Hotrodder
Staff member
Aug 1, 2006
11,247
0
0
61
Norco CA
www.mcratracing.com
2006 LLY should have mostly identical codes/procedures to 2006/2007 LBZ since all the sensors and computers are the same.

It is most likely an oversight on whoever manages that website that LBZ is not included with LLY (should be LLY/LBZ).
 

turfcat1

I AM Commercial Grade
Oct 6, 2010
2
0
0
Elgin, Texas
Need help with trouble codes

Codes P0380 and P0540

Well, I just completed an injector replacement on my '02, and after a few tense moments of cranking, it roared to life. I've since driven it about 150 miles, and it's doing great. However, it threw two codes out (checked these at Autozone) related to the intake air heater. Out of the whole operation, the one thing I was uncertain about was reconnecting the glow plug controller. I couldn't remember with absolute certainty which wire went where. Anyway, I understand that, once the issues are addressed, the "check engine" light will go out. I did do a cursory check of the connections down at the glow plugs themselves, and found the left side front had a loose connection. Took care of that, but the light comes on and stays on.

Other than these two codes popping up, everything else is perfect - truck runs awesome. I'm still not sure about the connections up at the controller. I've looked throughout this forum board, and others, but I can't locate a diagram or photo that shows how the wires are connected. Can anyone give me specifics as to which wire goes where. A pic, or even some sort of drawing would really help a bunch.

Thanks!
 
Jul 24, 2013
174
0
11
jacksonville nc
Codes P0380 and P0540

Well, I just completed an injector replacement on my '02, and after a few tense moments of cranking, it roared to life. I've since driven it about 150 miles, and it's doing great. However, it threw two codes out (checked these at Autozone) related to the intake air heater. Out of the whole operation, the one thing I was uncertain about was reconnecting the glow plug controller. I couldn't remember with absolute certainty which wire went where. Anyway, I understand that, once the issues are addressed, the "check engine" light will go out. I did do a cursory check of the connections down at the glow plugs themselves, and found the left side front had a loose connection. Took care of that, but the light comes on and stays on.

Other than these two codes popping up, everything else is perfect - truck runs awesome. I'm still not sure about the connections up at the controller. I've looked throughout this forum board, and others, but I can't locate a diagram or photo that shows how the wires are connected. Can anyone give me specifics as to which wire goes where. A pic, or even some sort of drawing would really help a bunch.

Thanks!
Mines doin the same thing did you ever figure it out?


04 Lb7 cc/SB new guy to the forum
 

DirtyMax32

New member
Sep 10, 2013
139
0
0
Mines doin the same thing did you ever figure it out?


04 Lb7 cc/SB new guy to the forum
Same here. My 01 LB7 threw P0380 and the intake heater code and I replaced both glow plug relays but that didn't fix the engine light. So I unplugged the power going to the glowplugs since I live in Texas.

Sent from my SAMSUNG-SGH-I747 using Tapatalk
 
Jul 24, 2013
174
0
11
jacksonville nc
Same here. My 01 LB7 threw P0380 and the intake heater code and I replaced both glow plug relays but that didn't fix the engine light. So I unplugged the power going to the glowplugs since I live in Texas.
Haha well I give up f*ck you glow plugs hahaha I like it
Sent from my SAMSUNG-SGH-I747 using Tapatalk



04 Lb7 cc/SB new guy to the forum
 

DirtyMaxxLB7

New member
Nov 30, 2013
1
0
0
Multiple Codes, Any Suggestions?

So this is my First Diesel Truck and im in love with it, ive had it little over a month and its been running perfectly strong until it died on me this Thursday..thats right, on thanksgiving. long story short I suddenly felt a shift in the engine lost almost all power when I gave it throttle the check engine came on immediately and when I put my OBDII these are the codes I get p0202 p0203 p0205 p0208 which are injectors 2 3 5 8 also p2149 which is injector positive voltage control circuit group 2 p0670 which is glow plug control module performance and last but not least p0700 transmission control module requested MIL illumination can anyone please help guide me on where to start or what to check or change first? any advice is appreciated it as I don't know much at all about diesels
 

McRat

Diesel Hotrodder
Staff member
Aug 1, 2006
11,247
0
0
61
Norco CA
www.mcratracing.com
Check the Bale connector. This the large pair of harnesses on the top driver's side of the engine. When a lot of things fail at once, it's often a pin pushed in or a bad Edge or Banks module (they plug in there).
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)