Emergency Relearn on ECM works on LBZ

Kat

Wicked Witch of the West
Staff member
Aug 1, 2006
17,898
0
36
57
Norco, CA
Someone left me a message that they got there truck started. Here is how you do it in case anyone every needs to swap ECM's :D

Try to start it, then turn the key back to run. DO NOT TURN IT TO OFF.

Wait 11 minutes (time it).

Try to start again, then turn key back to run. ditto.

On the third cycle, it will ignore the VIN differences in the various modules and will start.

This is how you get a busted truck on the side of the road running when you fry the PCM. You put in a PCM from any other truck of the same type engine, and go through the procedure.

A Tech2 can do the same thing in 1 minute instead of 30 minutes.

OR.... Fire up your scan tool, connect to the ECM, activate DVT select "Learn Now" under "VATs Relearn". :D

If for some reason that doesn't work, and you need to go through the long relearn process and can flash your ECM, go to G0302, change it from 600 seconds (10 minutes) to 10 seconds, so it'll be:
Turn ignition on
Try to start (it won't)
Leave ignition on.
In 10 seconds exactly the SECURITY (lock) light will turn off.
Try to start (it won't)
Leave ignition on.
In 10 seconds exactly the SECURITY (lock) light will turn off.
Try to start (it won't)
Leave ignition on.

In 10 seconds, the light will go out, and it will start up, and will "marry" the ECM to the BCM permanently.
 

Kat

Wicked Witch of the West
Staff member
Aug 1, 2006
17,898
0
36
57
Norco, CA
just to be clear... is this turn to start ( as in crank it) then release and let it sit in the "run" position and let it sit?
Yes, you try to crank and then release it to the run position and let it sit.
 

Lonnie

Horsepower Addict
Kat,
That procedure will definitely work on your Corvette as well. I did that with a PCM swap on a Z06. You typically wait until the "service engine light" flashes, which is just over 10 minutes, so your 11minute delay works. Third time it runs....
 

LBZ

Super Moderator
Staff member
Jul 1, 2007
9,615
28
48
43
B.C.
Kat, can we make this a sticky??

I'm sure it's going to come up again!!
 

ripmf666

Super Moderator
Staff member
Vendor/Sponsor
Sep 20, 2006
15,114
0
36
44
Wentzville Mo
LOL ears burning Kat lol.

first ecm didnt work guess no vin in it,
Turn key to run wait 11 min's,after that turn key of for split second then right back to run postion dont try to start wait 11 mins again or til the security light goes off in left corn of cluster,after that 11 mins turn key off for 3rd and last time for split second and back to run do not try starting wait 11 mins last time after the 11 mins or light is out turn key off the try starting, truck will start and run, if you check vin with efi live v2 will read the wrong vin but all runs great.

Thanks
Kat and Pat
 

ripmf666

Super Moderator
Staff member
Vendor/Sponsor
Sep 20, 2006
15,114
0
36
44
Wentzville Mo
When I did the swap it worked for me,I bought the extra ecm from the diesel place and it was another OS then mine and truck started up after I did this.
 

WanaDmaxsub

Junior Member W/gray hair
Feb 17, 2007
644
1
18
A little OT here....but...
This same (30 min) procedure works on a Saturn ION when you have to replace the ignition switch. The only thing I'll add is that you have to turn the key off after the last 10 cycle before you start the car. If you don't you have start all over again.
 

ripmf666

Super Moderator
Staff member
Vendor/Sponsor
Sep 20, 2006
15,114
0
36
44
Wentzville Mo
A little OT here....but...
This same (30 min) procedure works on a Saturn ION when you have to replace the ignition switch. The only thing I'll add is that you have to turn the key off after the last 10 cycle before you start the car. If you don't you have start all over again.

This is built into all Gm built cars and truck, You also have to turn it off on the trucks to on the last cycle.
 

blazin dmax

New member
Apr 30, 2008
58
0
0
az
I'm assuming this is for vehicles that are in a crank but no start condition? I'm dealing with a 04.5 LLY that is in a no crank situation after a failed ecm read with efi live. Tried doing a vats relearn through efi live scan tool and it wouldn't talk to the ecm. Pretty sure I've got a bricked ecm.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)