EFI Live reset after DEAD batteries??

MarquisVII

New member
Dec 31, 2013
3
0
0
I have an EFI Live AutoCal and I've recently been experiencing a parasitic battery drain (still haven't had time to diagnose) to the point that the batteries are DEAD. Brand new Interstate batteries being completely drained in a few days BTW. Anyways, after the batteries were drained completely dead and then jumpstarted, my EFI told me on my CTS screen something to the effect of it no longer recognizing my vehicle and being unable to load a tune. It now appears that the only tune I have is bone stock and I can't adjust it. What's the procedure to get up and running to full functionality again? I just learned ATP closed shop, so obviously they can't help anymore!
 

Chevy1925

don't know sh!t about IFS
Oct 21, 2009
17,021
3
38
Phoenix Az
This doesn’t have much to do with efi live. You can try re-flashing the tune in from the autocal or reloading the cts but that’s about it.

Dead batteries can play havoc on the ecm
 

MarquisVII

New member
Dec 31, 2013
3
0
0
I'll give it a go. Just wanted to make sure that starting from scratch with the EFI flash wouldn't muck anything up. Thanks!
 

Trimox

Member
Aug 31, 2017
111
0
16
I have had this happen once before. Still don't know why my batteries did not die. Go into the CTS setting and turn EFI Live ON. For some reason the CTS and turned that feature off on it's own. I didn't have to reflash ecm hope this helps.
 

MarquisVII

New member
Dec 31, 2013
3
0
0
Trimox - that what it was! Thanks, ha, glad it was such an easy fix - I would never have thought it was something so silly. Thanks!