LMM: CP3 Knocking HELP!

TowU4Free

#SecretSquirrel
Aug 27, 2011
457
2
18
Ok guys, Im still at a loss, and id love to gather anyones ideas. PPE dual pump setup a few years old, bought used. When i had stock injectors the pump just started to lightly knock when you first hit the key over then it went away after a few seconds. Now i have Exergy 100s and the pump constantly knocks.. NOT fuel injector rattle as you can hear that plain as day when you unhook the regulator. I Installed a new pump on it last night and same thing :(. Also got a low rail pressure code on my tune 4 just test driving it earlier (I think thats odd) Valley cp3 was fine when i did the duals and theyre only about 2 months old on my truck. Raptor 150 feeding them. Unhook the liftpump and the knock goes away and truck tries to surge and die. So....Who can tell me whats going on?? 114k miles LMM 68stg2r 100s,built trans all supporting mods, dual pumps. https://www.youtube.com/watch?v=CFs3ZHi-W7w
 
Last edited:

TowU4Free

#SecretSquirrel
Aug 27, 2011
457
2
18
Im fairly certain, used a stethescope and pinned the noise on the cp3. Tried maybe the power steering pump too and it has the same harmonic noise but doesnt change with wheel turn or anything. The noise does go up with RPM. You can hear it clear as day on the pump. Did your alternator make that noise?
 

TowU4Free

#SecretSquirrel
Aug 27, 2011
457
2
18
Yea, I reckon thats my next venture tonight. That damn LMM fan shroud will cut you up if youre not careful !
 

catman3126

Ehhh?.... You don't say?
Jul 24, 2012
2,636
0
36
NE Oregon
pull the belt completely and make sure its not one of the timing gear also. couple things to help you isolated. Like said above also.
 

Tothemax

xgmtech
Oct 15, 2014
585
1
18
new york
It's the valley pump you hear knocking? I recently put a second cp3 on and 60 over injectors and now my valley pump knocks. I'll being following this thead
 

TowU4Free

#SecretSquirrel
Aug 27, 2011
457
2
18
did you see the video i posted up top? is yours like that? Mines the top pump
 

Tothemax

xgmtech
Oct 15, 2014
585
1
18
new york
Just saw video. Mine isn't as loud but same kind of sound. And on mine it's the valley pump. I noticed it from the start after the injectors and second pump. I've put about 2000 miles on it and ran her on the dyno 2 weeks ago. And it wasn't till the other day I concluded the noise was from the valley pump. So far no drive ability issues. But you changed out the noisy pump and the new one did the same thing?
 

IdahoRob

New member
Jun 5, 2007
1,151
0
0
What's your rail pressure doing? Lift pump psi? Too high of lift pump psi and it will cause a knock. As you can remove the power from the lift pump and it quiets down, that'd be my first test.
 

IdahoRob

New member
Jun 5, 2007
1,151
0
0
Watch the rail pressure when the lift pump power is pulled and the knock stops, tell Mark what that PSI is to the rail. May smoke with those big injectors at idle though with the lowered rail pressure at idle.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)