4L80E TCM input

max57

Member
Dec 12, 2014
117
0
16
Upstate, NY
Having trouble getting TCC to apply. The Brake switch is sending 12V until it is Pressed so working correct. I think 12v gets send to ECM. Ecm sends a signal to TCM . Does anyone know what signal I should get at from ECM to TCM. 5v,12v or ground. And what other parameters would stop the ecm from sending that signal. ABS or Cruise??? Thanks
 

max57

Member
Dec 12, 2014
117
0
16
Upstate, NY
I think it ground, but someone will need to back me up bc I had surgery today and I'm a little loopy...:roflmao:
Thanks for reply. I checked today i get enough ground to give me a dim test light. with brake applied I get nothing. So i do get a signal of some kind. Volt test will read 12v. Not sure where to go know. Had someone look at my TCM tune on EFI LIve site and all looks good. tried someone elses tune and no convertor. But I can command Lockup on HPTuner and it locks.
How can I check the pwm pulse volts.??
 

max57

Member
Dec 12, 2014
117
0
16
Upstate, NY
I see the cruise control and TCC release are both on signal from ECM. I know the cruise control releases when brake is applied on and can turn it back on after let brake off so not that signal messing with things.
 

juddski88

Freedom Diesel
Jul 1, 2008
4,373
6
38
Chesterfield, Mass.
Thanks for reply. I checked today i get enough ground to give me a dim test light. with brake applied I get nothing. So i do get a signal of some kind. Volt test will read 12v. Not sure where to go know. Had someone look at my TCM tune on EFI LIve site and all looks good. tried someone elses tune and no convertor. But I can command Lockup on HPTuner and it locks.
How can I check the pwm pulse volts.??
Where are you probing?
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)