1 bad new injector

08lmm72mm

Member
May 13, 2019
123
15
18
Saskatchewan, Canada
Hey guys, I put a set of brand new set (not reman) of injectors in my truck a week ago with 45 over LBZ nozzles on them and at first it ran really good. All balance rates are under +1- , except for cylinder #4 which has a balance rate of +1.8 and cylinder #6 which had a balance rate of -1.8.

The motor ran super smooth but has deteriorated since. All balance rates are still the same except for cylinder #6 now the balance rate is around -2.8 and the truck has a very slight haze at idle and sounds like very slight fuel knock/rattle from the drivers side while under throttle accelerating. I bought these from a supporting vendor on this site and have put around 100 miles on them. I plan on calling them first thing Monday.

Is it possible to get 1 replacement oversized Injector? All I ever see is a set of 8 and that's not an option to buy another set. Is there something else on a lmm that could be causing this? Thanks for any help.
 
Last edited:

bimmer95

Member
Mar 15, 2019
58
5
8
Morgantown Pennsylvania
If your copper washers are not sealing well they could mess with the balance rates and cause the rattle your hearing..did you clean the injector bores well and use new washers?What did u torque the hold downs to?

Sent from my SM-G981U using Tapatalk
 

08lmm72mm

Member
May 13, 2019
123
15
18
Saskatchewan, Canada
New washers were used and hold downs were torqued to 22lbs. Cylinders 2, 4, and 6 were extremely dirty on tear down, and I do recall not cleaning out the bolt hole for the injector hold downs. On those 3 cylinders as I did them first.

Think it's worth pulling injector 4 and 6? I never thought that they would mess with balance rates if they were leaking slightly.

I remember one leaking in the past on another truck enough that you could hear it under boost and it never changed the balance rates at all.
 

08lmm72mm

Member
May 13, 2019
123
15
18
Saskatchewan, Canada
20210418_100152.jpg

Strange, there was no leaking past either copper washer on cylinder 4 and 6, so I swapped which hole each Injector was in with new washers Orings and bolts and all is good! Injector rattle is 90% gone and it has a buttery smooth idle again 😎
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)