Duramax Diesels Forum Truck of the Week
  #16  
Old 04-12-2008, 07:32 PM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

Quote:
Originally Posted by SmokeShow View Post
I opened the drive pressure pid and I don't see how it will log the drive pressure based on which PIDs are selected in that file?????


Also, what I have is AutoMeter's Cobalt series eetrical gauges and I'm wanting to log the following data:

EGT
Boost
Drive Pressure &
Fuel Pump Pressure


I am as lost as it gets on setting things up so that these will log along with some other PIDs that are already available. Any and all help woud be greatly appreciated. :
No can do with EGTS

Boost DP and lift pump Yes,I hooked mine up today to do this very same thing on the 01 My 05 only has lift pump and DP capable of logging

As far as the PID i will have to double check it? But it is just needing AUX input 1 as far as the DP to be able to log,Then you create a Calc PID and use it

I will locate the link for the post that this info is on Mitch and then post it in here

I have a excel sheet that I made that has what you need to log most of the A/M gauges 0-15, 0-30 ,0-60 and 0-100 PSI the only one i never did was NOS but it wouldnt be to hard to add that if you need.
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #17  
Old 04-12-2008, 07:37 PM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

Mitch
Look at post #12

If you need electrical pins,I posted it in PART#s
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #18  
Old 04-12-2008, 11:03 PM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Ok, lots of progress today.... I seen your Excel sheet Simon; and got that part taken care of.

Also finally got the calculated PIDs to show up in the PID list. Got them selected and referencing the corresponding EXT.AD1-4 PIDs BUT and when logging the show the math as being right that I put in the calc_pid.txt file it's just that the EXT.AD PIDs aren't getting any signal. No votage was shown through the pins when tested with a meter while running. Not real sure what the deal is with that. Any suggestions???

The EGT gauge is working but not right. From what I've seen, the probe from a SPA has worked for some so that's what we've got. No bueno though.

FWIW, we used pin locations 4 for neg. and 10 for positive on the plugs into the gauges. They were vacant ports in the plugs.

Another question.... I seen a document referenced several times called "sae_generic.txt." BUT I never could find it in V4 or V5 EFI Live. I needed it to figure out the "UNIT" part of the calc_pid.txt file so for now, our logs will be unitless but that's minute at this point. Good data is paramount.

Thanks yall. Is it too much to ask you that log drive pressure to post up your actual "calc_pid.txt" file so I can check it against ours????
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
  #19  
Old 04-13-2008, 09:40 AM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

Quote:
Originally Posted by SmokeShow View Post
Ok, lots of progress today.... I seen your Excel sheet Simon; and got that part taken care of.

Also finally got the calculated PIDs to show up in the PID list. Got them selected and referencing the corresponding EXT.AD1-4 PIDs BUT and when logging the show the math as being right that I put in the calc_pid.txt file it's just that the EXT.AD PIDs aren't getting any signal. No votage was shown through the pins when tested with a meter while running. Not real sure what the deal is with that. Any suggestions???

The EGT gauge is working but not right. From what I've seen, the probe from a SPA has worked for some so that's what we've got. No bueno though.
I myself cant help ya there

FWIW, we used pin locations 4 for neg. and 10 for positive on the plugs into the gauges. They were vacant ports in the plugs.
Use the volt meter with the truck on and try to get a reading directly from thos 2 spots....You should have something between 0-5 volts

Another question.... I seen a document referenced several times called "sae_generic.txt." BUT I never could find it in V4 or V5 EFI Live. I needed it to figure out the "UNIT" part of the calc_pid.txt file so for now, our logs will be unitless but that's minute at this point. Good data is paramount.
Not sure its been a while since i have done anything with EFI,Ill have a look later

Thanks yall. Is it too much to ask you that log drive pressure to post up your actual "calc_pid.txt" file so I can check it against ours????
I posted a log from my truck with stock tune somewhere in this part of the forum? Ill look for it

You can do things 2 ways, 1 being just get the voltage and then convert it when you DL the log to Excel

2- being you can use EFI to do it,I used the first way when I started playing around so i could figure out the correct formulas

Ill be starting to play around with this more in a lil bit here,But as of right now I dont even have electric gauges in my 05 and the 01 Doesnt even have a battery
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #20  
Old 04-13-2008, 11:56 AM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Thanks Simon. I appreciate your help. Next step is to check the voltage at the gauge. No voltage is shown at the plugs into the EFI Live hand unit. I'm assuming the elec. gauges work off of the same voltage reading that we are looking for and they are working so they are getting the voltage sent to them, just gotta get that signal from the gauge to the EFI Live hand held unit.

On the EGT logging. The truck has two probes. One goes to the gauge in the truck and is the supplied probe for the gauge and is working properly. The other probe is the SPA K-type probe and is run directly to the EFI Live V2 hand unit and plugged into the Temp1 port. It does some minor fluctuation but the information/data is completely wrong. i.e. sitting idling it's at about 70-85*, while the gauge shows 2-300. When revving up the gauge shows EGTs jumping up a couple hundred degrees and the EFI Live log shows it going from about 75* up to about 100-105*. So it does slowly fluctuate but it just isn't right.

Isn't it member "greyarea" that mentioned being able to log EGTs with one of these SPA probes???


C-ya
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
  #21  
Old 04-13-2008, 12:01 PM
McRat's Avatar
McRat McRat is offline
Diesel Hotrodder


 
Join Date: Aug 2006
Location: Norco CA
Posts: 13,263

Default

A "SPA style" EGT sensor has the amplifier built in. You supply it with 12v, and it will output 0.5 - 5.0v ? so you read those kind in with a EXT port with EFIlive.
__________________


2005 GMC 2500HD LLY "Casper"- LLY O/S 8758. 10.59 @ 129. EFILive "2CP3" Tuning, Mike L Suncoast Trans. PPE Dual CP3's, GT4202R.
2004.5 GMC 3500 SRW LLY "Big Blue" - LLY O/S 1668. 13.12@103. Powered by PPE/VA with Mike L Suncoast Trans.
2006 GMC 2500HD CC/SB LBZ "Wendy"- LBZ O/S 6128. 12.50 @ 107.x. EFILive tuning, Mike L trans.
Pat and Kat McSwain
"Casper" - Record Holder, Bonneville & El Mirage. Best Clocked Speed 197mph, Bonneville '09.
"World's Fastest Production Diesel Pickup - 174.586mph"
Reply With Quote
  #22  
Old 04-13-2008, 12:47 PM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Quote:
Originally Posted by McRat View Post
A "SPA style" EGT sensor has the amplifier built in. You supply it with 12v, and it will output 0.5 - 5.0v ? so you read those kind in with a EXT port with EFIlive.
ahhh, in lieu of the temp ports???


Will try that asap! Thanks a BUNCH Pat!! BTW, this is on Garrick's truck. You all have been talking lately.



C-ya
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
  #23  
Old 04-13-2008, 12:51 PM
McRat's Avatar
McRat McRat is offline
Diesel Hotrodder


 
Join Date: Aug 2006
Location: Norco CA
Posts: 13,263

Default

If I was in the shop, I would get you a pic of the SPA sensor info.
__________________


2005 GMC 2500HD LLY "Casper"- LLY O/S 8758. 10.59 @ 129. EFILive "2CP3" Tuning, Mike L Suncoast Trans. PPE Dual CP3's, GT4202R.
2004.5 GMC 3500 SRW LLY "Big Blue" - LLY O/S 1668. 13.12@103. Powered by PPE/VA with Mike L Suncoast Trans.
2006 GMC 2500HD CC/SB LBZ "Wendy"- LBZ O/S 6128. 12.50 @ 107.x. EFILive tuning, Mike L trans.
Pat and Kat McSwain
"Casper" - Record Holder, Bonneville & El Mirage. Best Clocked Speed 197mph, Bonneville '09.
"World's Fastest Production Diesel Pickup - 174.586mph"
Reply With Quote
  #24  
Old 04-15-2008, 06:47 AM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Hey Pat, I have a SPA gauge in my truck and was looking over the components and it appears like the gauge itself may be where the conversion from 12V to 5V occurs. Is that right???

If so, my bud got one broke off in him cause all he got was the probe (based on a Part # on EFI Live website). Wonder how we can get the signal from the probe to a 0-5V signal???


C-ya
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
  #25  
Old 04-15-2008, 04:48 PM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

Quote:
Originally Posted by SmokeShow View Post
Thanks Simon. I appreciate your help. Next step is to check the voltage at the gauge. No voltage is shown at the plugs into the EFI Live hand unit. I'm assuming the elec. gauges work off of the same voltage reading that we are looking for and they are working so they are getting the voltage sent to them, just gotta get that signal from the gauge to the EFI Live hand held unit.

On the EGT logging. The truck has two probes. One goes to the gauge in the truck and is the supplied probe for the gauge and is working properly. The other probe is the SPA K-type probe and is run directly to the EFI Live V2 hand unit and plugged into the Temp1 port. It does some minor fluctuation but the information/data is completely wrong. i.e. sitting idling it's at about 70-85*, while the gauge shows 2-300. When revving up the gauge shows EGTs jumping up a couple hundred degrees and the EFI Live log shows it going from about 75* up to about 100-105*. So it does slowly fluctuate but it just isn't right.

Isn't it member "greyarea" that mentioned being able to log EGTs with one of these SPA probes???


C-ya
Mitch you get everything working? And you are useing pins or did you just stick the wire in there? I have evn had issues with the volt meter not reading
But you should see somewhere between 0-5 volts and the gauge must be plugged into the harness

Quote:
Originally Posted by McRat View Post
If I was in the shop, I would get you a pic of the SPA sensor info.
How bout some part#s And would we be better of useing a probe from a DPF pipe?
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #26  
Old 04-15-2008, 04:52 PM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

FWIW
If you are selecting a PID you can right click on it and click "more info"
this will tell you if you need another PID selected to log this PID
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #27  
Old 04-15-2008, 04:57 PM
McRat's Avatar
McRat McRat is offline
Diesel Hotrodder


 
Join Date: Aug 2006
Location: Norco CA
Posts: 13,263

Default

Quote:
Originally Posted by sweetdiesel View Post
Mitch you get everything working? And you are useing pins or did you just stick the wire in there? I have evn had issues with the volt meter not reading
But you should see somewhere between 0-5 volts and the gauge must be plugged into the harness



How bout some part#s And would we be better of useing a probe from a DPF pipe?
DOH!!! BRB!
__________________


2005 GMC 2500HD LLY "Casper"- LLY O/S 8758. 10.59 @ 129. EFILive "2CP3" Tuning, Mike L Suncoast Trans. PPE Dual CP3's, GT4202R.
2004.5 GMC 3500 SRW LLY "Big Blue" - LLY O/S 1668. 13.12@103. Powered by PPE/VA with Mike L Suncoast Trans.
2006 GMC 2500HD CC/SB LBZ "Wendy"- LBZ O/S 6128. 12.50 @ 107.x. EFILive tuning, Mike L trans.
Pat and Kat McSwain
"Casper" - Record Holder, Bonneville & El Mirage. Best Clocked Speed 197mph, Bonneville '09.
"World's Fastest Production Diesel Pickup - 174.586mph"
Reply With Quote
  #28  
Old 04-15-2008, 06:33 PM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Quote:
Originally Posted by sweetdiesel View Post
Mitch you get everything working? And you are useing pins or did you just stick the wire in there? I have evn had issues with the volt meter not reading
But you should see somewhere between 0-5 volts and the gauge must be plugged into the harness



How bout some part#s And would we be better of useing a probe from a DPF pipe?
still nada.

We used the wires right into the plugs that go into the efi live hand unit and pins in the harness at the back of the gauges.

Thanks for the heads-up on the right clicking to see what other PIDs are needed to get the right data... I'll be sure to check that. Although, it should just need the calc pid I created and the external pid, right?

Simon, the part number is listed on EFI Live sight for the correct SPA gauge. HERE


C-ya
Mitch
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
  #29  
Old 04-15-2008, 07:01 PM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Thailand
Posts: 13,425

Default

Quote:
Originally Posted by SmokeShow View Post
still nada.

We used the wires right into the plugs that go into the efi live hand unit and pins in the harness at the back of the gauges.

Thanks for the heads-up on the right clicking to see what other PIDs are needed to get the right data... I'll be sure to check that. Although, it should just need the calc pid I created and the external pid, right?

Simon, the part number is listed on EFI Live sight for the correct SPA gauge. HERE


C-ya
Mitch
Thanks Mitch

Correct on the external PID,Really that is all you need
the Calc will just do conversion on your log.At first I was just useing Excel to convert the voltage over to data

but both work well,Its just something to keep in mind if you want to keep the PID list shorter if you know what i mean?

Im confused as to why you cant get voltage from the back of the gauge though? HMM

Mitch this is with or with out the pins? Perhaps try pulling 2 wires out of a unused gauge and stick them in the one you are trying to log ( JUST FOR NOW)? Just a thought
__________________
2017 2.5L D-Max Trail Blazer
Stock
07 RC/LB 2wd
SOLD
05 CC/LB 4X4
SOLD
Abby 01 RC/LB 10.28@144mph
SOLD
Reply With Quote
  #30  
Old 04-15-2008, 08:14 PM
SmokeShow's Avatar
SmokeShow SmokeShow is offline
Hotrodder
 
Join Date: Nov 2006
Location: Lawrenceburg, KY
Posts: 7,245

Default

Quote:
Originally Posted by sweetdiesel View Post
Thanks Mitch

Correct on the external PID,Really that is all you need
the Calc will just do conversion on your log.At first I was just useing Excel to convert the voltage over to data

but both work well,Its just something to keep in mind if you want to keep the PID list shorter if you know what i mean?

Im confused as to why you cant get voltage from the back of the gauge though? HMM

Mitch this is with or with out the pins? Perhaps try pulling 2 wires out of a unused gauge and stick them in the one you are trying to log ( JUST FOR NOW)? Just a thought
We are using pins, not just wired in.

We used your picture of the plug/harness to set up the wiring.
__________________
Mitch

SOLD02 Chevy 2500HD D/A EC SB LS
SCIII & X-Case brace by MA, Team Salad tuning & Trippin's DSP5, 4" Diamond Eye exhaust, Fumoto Valve, partially debadged, Rhino Bed Liner, SuperDiesel Intake Manifold and Ported Turbo Inlet



1983 GMC K30 CC SHORT BED
Awaiting Dmax/Allison Chassis Swap



Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors