Duramax Diesels Forum Truck of the Week
  #1  
Old 08-26-2018, 05:27 PM
daltongd daltongd is offline
Gearhead
 
Join Date: Sep 2010
Posts: 43
Default Tow Haul Issue

I have a 2002 LB7 with 243K that is running and shifting just fine. The last two times I have used it to haul my 5th wheel I noticed that the tow haul does not seem to be working right. The light comes on so its not that. The problem is the shift patterns don't seem to be right. Before when in tow haul it would not shift from 4th to 5th until 62 to 65 MPH and now its shifting around 55 mph. Its almost like there is no difference. Also the down shifting does not seem to be working like it should. When going down hills and I tap the break nothing happens when before it would down shift. I did some research and there is a tap shifter you can buy that will allow you to manually shift so that may be an option. Any ideas on what might be happening or what I should do?
Reply With Quote
  #2  
Old 08-26-2018, 05:50 PM
duramax on fire's Avatar
duramax on fire duramax on fire is online now
Hotrodder
 
Join Date: Apr 2015
Location: dallas
Posts: 407
Default

I do know the wires get cut or worn around the shifter just under the plastic cover where the key goes. But usually the light won't come on. I would still start there. There's two really small wires.
Reply With Quote
  #3  
Old 08-26-2018, 06:06 PM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 1,424

Default

What temp is the transmission running at when it doesn't seem to be acting normal?
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #4  
Old 08-26-2018, 06:18 PM
daltongd daltongd is offline
Gearhead
 
Join Date: Sep 2010
Posts: 43
Default

Less than 200 deg on this last trip I just took. A few years back I did a quick mod to my transmission cooler by building a air deflector to pass air by the cooler. The stock cooler is behind the bow tie and does not get good flow so the mod really helped out.
Reply With Quote
  #5  
Old 08-26-2018, 06:21 PM
daltongd daltongd is offline
Gearhead
 
Join Date: Sep 2010
Posts: 43
Default

The transmission acted the same during the whole trip. It was about an hour on Thursday and then an hour home again today. I tried engaging and disengaging the tow button several times. On the way up on Thursday it eventually seemed to do better and quit shifting from 4th to 5th at 55 mph.
Reply With Quote
  #6  
Old 08-26-2018, 07:16 PM
Ridin'GMC's Avatar
Ridin'GMC Ridin'GMC is offline
I like red
 
Join Date: May 2010
Location: MA
Posts: 592
Default

Well looks like you're not the only one. I'm having the same exact issue on my lbz. Tow haul light is on but my shift pattern from 4th to 6th is near like normal mode, downshift doesn't work right half the time. Haven't looked into the issue yet but hopefully someone can chime in and see what the issue may be.
__________________
07 LBZ CCSB

RIP 4/1/17
06 LLY CCSB
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:51 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors