Duramax Diesels Forum Truck of the Week
  #1  
Old 05-26-2018, 07:11 PM
Philv's Avatar
Philv Philv is offline
Gearhead
 
Join Date: Jan 2018
Location: Surprise, AZ
Posts: 79
Default Loping idle

So I've been doing a lot of research and I'm still not certain on what's causing my issues. Some say I need injectors, but then someone else has roughly the same problem as me and it's the fpr. I tried to upload 2 videos, but it says files are too big. Could someone pm me their number or email, and I can send them to try and figure out where I should start?

Also forgot to mention, longer crank times at temp and truck falls on it's face on wot. Half throttle it'll move pretty good. And I still can't do a burnout.lol

Sent from my Moto Z (2) using Tapatalk
__________________
2001 GMC Sierra 2500HD SLE EC/LB 4x4
Cold air intake
4" exhaust
Wastegate trickery thingy. Lol

Last edited by Philv; 05-26-2018 at 07:52 PM.
Reply With Quote
  #2  
Old 05-26-2018, 08:08 PM
Burn Down's Avatar
Burn Down Burn Down is online now
Hotrodder
 
Join Date: Sep 2008
Location: Boise Idaho
Posts: 6,402

Default

Lots of info on here about t/s and diagnosing lb7 injectors and fpr... I would start with the basics.
__________________
04.5’ CCSB ole blue, built trans, mpi twins
03’ Reg Cab ZF 6
05’ CCSB ole crappy, built eng, built trans, mpi twins
Reply With Quote
  #3  
Old 05-27-2018, 05:29 AM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is online now
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 3,027

Default

Prolly injectors, do some tests and you’ll figure it out, or drive it til it blows up, that’s what I usually do.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles. Piston eater.

Wife's ride- 2016 Pearl white Legacy limited 3.6R

Rig ride/new DD-02' Black Eddie Bauer explorer 4.6, -180k, still sporting original trans, outlasted two Duramaxs.
Reply With Quote
  #4  
Old 05-27-2018, 05:31 AM
ZeroGravity58's Avatar
ZeroGravity58 ZeroGravity58 is offline
Hotrodder
 
Join Date: Mar 2008
Location: Maryland
Posts: 823

Default

Sounds like injectors are returning to much fuel.
__________________
09 lmm ccsb ltz, ATP tuning, mpi s480 over stocker, big dipper trans, 60 overs, 10mm stroker pump, ppe up pipes and manifold, banks intercooler & exhaust, airdog165, isspro guages, traction bars, the list goes on
01 lb7 red RC/LB 11.58@119 MPH, SOLD
01 lb7 Black CC/LB, SOLD
Reply With Quote
  #5  
Old 05-27-2018, 07:15 AM
04Max's Avatar
04Max 04Max is offline
FNG
 
Join Date: Jul 2009
Location: Florida
Posts: 10
Default

Same problem I had when the injectors started going bad. Seemed like it had a race cam lop at idle. Off idle run smooth. Sounded bad at red light stop. Did that for about 2-3 mo. then started the gray smoke. Tried all kinds of injector cleaners along the way. Some helped but the only thing that fixed it was new injectors.
__________________
04 Chevy LT 2500HD EC/ShortBed LB7/Allison 2WD
ATP AutoCal - Isspro Boost & Pyro Gauges - Kennedy Lift Pump - Racor Diesel Filter Kit - Cat Filter adaptor - PPE Boost valve - AFE CAI - Profab air horn - MotoBlue Quite Thunder Down Pipe - FLO-PRO 4" SS exhaust - Allison Deep Pan - Velvet-Ride Springs - Air Lift springs & compressor - Line-X Liner - Hard Folding Tonneau Cover
Reply With Quote
  #6  
Old 05-27-2018, 04:53 PM
Philv's Avatar
Philv Philv is offline
Gearhead
 
Join Date: Jan 2018
Location: Surprise, AZ
Posts: 79
Default

The reason why I don't think injectors is 18.5 mpg doing 75-80. I guess I just need to replace everything on the fuel system.
__________________
2001 GMC Sierra 2500HD SLE EC/LB 4x4
Cold air intake
4" exhaust
Wastegate trickery thingy. Lol
Reply With Quote
  #7  
Old 05-27-2018, 05:26 PM
NC-smokinlmm's Avatar
NC-smokinlmm NC-smokinlmm is offline
<<<Future tuna killer
 
Join Date: May 2011
Location: At Da Beach
Posts: 3,885
Default

Do LLY top end swap...
__________________
2010 GMC 1500 SCSB Denali Clone < lifted 22's/33's, Kooks, Magnaflow, 5.3, 6l80, TVS1900, lots of boost, Mayhem tuned, etc...

2015 Corvette Stingray Z 51 < Stock...

2016 LML CCSB Denali < Lifted 22's/35's, Fox 2.0 < I officially need help.
Reply With Quote
  #8  
Old 05-27-2018, 06:25 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is online now
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 3,027

Default

Quote:
Originally Posted by Philv View Post
The reason why I don't think injectors is 18.5 mpg doing 75-80. I guess I just need to replace everything on the fuel system.
Mine got decent mileage with bad injectors, it’s returning the fuel to the tank not pushing it into the cylinders
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles. Piston eater.

Wife's ride- 2016 Pearl white Legacy limited 3.6R

Rig ride/new DD-02' Black Eddie Bauer explorer 4.6, -180k, still sporting original trans, outlasted two Duramaxs.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:50 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors