Duramax Diesels Forum Truck of the Week
  #1  
Old 03-30-2018, 07:14 AM
Vash Vash is offline
FNG
 
Join Date: Mar 2018
Location: South, Tx
Posts: 2
Default Electrical Issues

Hey guys/gals, I'm new to the forum (and Diesels/Duramax/Chevy's... etc).

I'll try to be as detailed as necessary without getting to far in the weeds.

So a couple of weeks I purchased a 2015 LML, Silverado LT. It had 48k miles and was very clean. I've noticed some small electrical "funny business", but nothing too off (Bluetooth would hold the phone connection even after the truck was turned off and I exited the vehicle. Now I've had vehicles my who life with BT issues, so I thought nothing of it.)

No codes have yet been appearing.

Yesterday (3/29), I installed an AirDog lift pump and GDP EZ Lynk tuner. I have not removed any emissions equipment. But lets backup half a step...

Upon near completion of the AirDog install, I thought I had found the fuse that would turn on when the key was a the "on" position, but not cranked. Not the case, had to go with another switch (I forgot right now which it was). In doing so, the computer started going a little crazy. I received 3+ codes on the screen calling out the trailer brake system, trailer lights, "Stabilitrack"... etc. Freaked me out. To make matters worse, when I did find a switch that would only turn on with the "On" position, primed the AirDog, the engine would only crank once and then not turn over. Again, multiple codes on the dash display. I everywhere.

After calling AirDog (and the dude acting like a complete asshole at first as if I was blaming AirDog... was just looking for some help, but I understand), I resolved it was simply an electrical issue, and I needed some data to work with. Welp, I bought this fancy little EZ Lynk for this reason, just didn't think I'd need it yet. Plugged it in, the truck fired up and all was good......

Now everything seems...ok.... but when I switch tunes, sometimes.. the install may stall out and the same behavior as above... not crank, tons of codes.

Should I be worried or is this typical "modified truck" / "weekend warrior" risky business? I would like to not ruin my multi-thousand dollar new toy.

Thank you in advance for all your help and replies. Please forgive the ignorance regarding the truck as I'm a new enthusiast. I have a slightly mechanical/plant/engineering background.

Kind Regards,
Vash
Reply With Quote
  #2  
Old 03-30-2018, 07:20 AM
Dozerboy's Avatar
Dozerboy Dozerboy is offline
Hotrodder
 
Join Date: Jun 2009
Location: TX of course
Posts: 3,822

Default

What fuses did you try and tap into? How did you try and tap into them?

If you’re not extremely careful with aftermarket electrical Equipment on new vehicles you can cause yourself a lot of headaches.


Sent from my iPhone using Tapatalk
__________________

06 GMC 2500 CCSB SLT LBZ 4X4





These views expressed on this post are not my own, but rather randomly generated computer gibberish, and in no way should be used to judge the author's IQ or mental health.
Reply With Quote
  #3  
Old 03-30-2018, 09:05 AM
Vash Vash is offline
FNG
 
Join Date: Mar 2018
Location: South, Tx
Posts: 2
Default

I followed the instructions of the airdog, I believe it was fuse 47. This fuse was taken, so I piggy backed it with the provided "micro fuse tap" supplied by AirDog.

This is what I believe caused all the problems, however it has been acting a little funny since purchase.

It is now in a more suitable fuse location, it was an empty fuse, and I want to guess (i'll go confirm) it was fuse 27, 31 or 32. It was an empty terminal near all those in the cluster.

Maybe I caused something to happen, but I'd like to fix any relays/fuses or whatever else that may be bugging out. How would I go about diagnosing this problem? It is not throwing any codes in normal or installed tunes.
Reply With Quote
  #4  
Old 05-04-2018, 12:27 AM
scramHD's Avatar
scramHD scramHD is offline
"2 pints of booze"
 
Join Date: Aug 2008
Location: Tx / MS / AL / MEX
Posts: 91
Default

electrical funny business.............
__________________
02 LB7, cc/sb 2wd
EFI LiveV2/Neens/ATS/SoCal/PPE/SuperDiesel/Industrial Injection/TrentNell/MFrank/TTS/-McRat--Kat-/Dan
12.2/114


15.5 LML cc/sb 4wd
Zone 5"/ Fox 2.0 Resi / 4k lb rear leafs
Kryptonite UCA's/WB's/LBJ's
Cognito PISK / SB end links / Kryptonite tie rods
63.5mm 6+6 / AD 165 4g / sump by Ohio Diesel
Mishimoto hot & cold intercooler pipes / 4" CAI by me
3" MBRP downpipe / 4" ex / Magnaflow 20"
DEI heat wrapped ex / hand polished factory tip by me
Revmax Billet Triple / vb mods & T87 tuning by me
E86b Ridgerunner / EFIv2 / l25hp / 75hp / mOOnshine
Autometer pod / oil temp / boost / CTS2
Bora 1.5" / 18s / 295/70


12 yz450f
polished frame/swingarm by hand by me
GYTR head / Cycra powerflo / Flo motorsports/ Vortex bars / Ascerbis X seat / ASV shorty levers/
Bazzaz Tuning/Logging /SCAR racing / Scorcher SS header /HotCams / Twin Air
Reply With Quote
  #5  
Old 05-04-2018, 12:34 AM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 3,080

Default

Maybe you stretched out the fuse holder when you used the fuse tap and now the fuse isn’t making a good connection.
__________________
2008 GMC duramax crew cab short bed 2500.
10.98@124mph

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #6  
Old 05-15-2018, 08:30 AM
scramHD's Avatar
scramHD scramHD is offline
"2 pints of booze"
 
Join Date: Aug 2008
Location: Tx / MS / AL / MEX
Posts: 91
Default

Check all the grounds also. I went through similar issue but also had a lost communication with abs control module. Ended up being the ground screw under drivers side door....loosened on its own. Cleaned it, tightened it...all codes gone.
__________________
02 LB7, cc/sb 2wd
EFI LiveV2/Neens/ATS/SoCal/PPE/SuperDiesel/Industrial Injection/TrentNell/MFrank/TTS/-McRat--Kat-/Dan
12.2/114


15.5 LML cc/sb 4wd
Zone 5"/ Fox 2.0 Resi / 4k lb rear leafs
Kryptonite UCA's/WB's/LBJ's
Cognito PISK / SB end links / Kryptonite tie rods
63.5mm 6+6 / AD 165 4g / sump by Ohio Diesel
Mishimoto hot & cold intercooler pipes / 4" CAI by me
3" MBRP downpipe / 4" ex / Magnaflow 20"
DEI heat wrapped ex / hand polished factory tip by me
Revmax Billet Triple / vb mods & T87 tuning by me
E86b Ridgerunner / EFIv2 / l25hp / 75hp / mOOnshine
Autometer pod / oil temp / boost / CTS2
Bora 1.5" / 18s / 295/70


12 yz450f
polished frame/swingarm by hand by me
GYTR head / Cycra powerflo / Flo motorsports/ Vortex bars / Ascerbis X seat / ASV shorty levers/
Bazzaz Tuning/Logging /SCAR racing / Scorcher SS header /HotCams / Twin Air
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:08 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors