Duramax Diesels Forum Truck of the Week
  #1  
Old 06-26-2018, 06:02 AM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default Service Stabilitrak message

Monday evening going home from the hanger driving down the highway I hear 3 chimes and the Service Stabilitrak message appears and the light comes on. There are no codes that my CTS or AutoCal show. I've googled this and used the search on here but haven't found much help. Most of the search results have dtc's or the Traction Control or ABS issues with the stabilitrak. Truck drives fine, I did notice when I made a right turn leaving my subdivision this morning I got the 3 chimes but no other signs of any problem. I had this happen before but it had the Traction Control messege also when the TCM failed.

I have stock size wheels with one size bigger tire that been on the truck for as long as Ive had it. Last weekend I did an engine oil and filter change and I changed the internal trans filter and installed an Allison deep pan and changed the fluid. I also changed the tune from tow to street and have just driven it normal since.

I really don't have a good shop here to take it to, both dealers service center couldn't figure out my emissions problems so I had to delete it just so I could drive it not in limp mode.

I've read of problems in the 1500's on the steering wheel sensor going bad but it thru dtc's. If I have a bad wheel sensor how do I know which one?

Any ideas? I can't be the only one that this has happened to.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #2  
Old 06-26-2018, 08:25 AM
zakkb787's Avatar
zakkb787 zakkb787 is offline
<that’s not me...
 
Join Date: Sep 2014
Location: Granite Falls NC
Posts: 1,525

Default

Not sure if it’s the same problem but my lbz had a similar issue. Abs light would come on when making sharp turns. Someone told me to hook a scanner up that will read the abs sensors while you’re driving and see if one is going haywire. May help you I’m not sure.
__________________
2006 LLY CC/SB LT3 mostly stock

Other toys:
1982 K10 6.2 Detroit diesel/sm465/np205 with 4 inch lift and 35s. Fixed and driving again
2011 Yamaha YFZ450X
2003 Yamaha YZ250
2003 Kawasaki Z1000
Reply With Quote
  #3  
Old 06-26-2018, 09:58 AM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

I do not have a scanner that will read the wheel sensors so I'm gonna test them with a multimeter once life gives me a spare minute. I've been reading and watching videos when I have a spare minute and it seems that there should be a code for these going bad or the steering wheel sensor.

Since the wheel sensor uses a reluctor wheel I'm guessing the sensor is a magnet. Maybe I'll get lucky and its just some debris on one of them.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #4  
Old 06-26-2018, 12:21 PM
Whitetail Addict's Avatar
Whitetail Addict Whitetail Addict is offline
Rockin' the stock tune
 
Join Date: May 2008
Location: South Central Pennsylvania
Posts: 2,307

Default

If you have the navigation screen, do the lines move with the steering wheel? When my steering wheel sensor went out those lines wouldn't move.
When it went out it was one trip of the message on a left hand 90° turn from a stop. Then a few weeks later it overreacted and did stupid stuff in the middle of a sweeping turn.
__________________
Brandon

'12 LML
'03 LB7


If you feel like everything is under control, you're not going fast enough - Mario Andretti
Reply With Quote
  #5  
Old 06-26-2018, 12:29 PM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

I have the NAV screen. I'm not sure what lines you are talking about, the map display? The backup cam?
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #6  
Old 06-26-2018, 12:42 PM
Whitetail Addict's Avatar
Whitetail Addict Whitetail Addict is offline
Rockin' the stock tune
 
Join Date: May 2008
Location: South Central Pennsylvania
Posts: 2,307

Default

On the backup camera, the direction lines that move with the steering wheel.

The 2011 and 2012 may be different.
__________________
Brandon

'12 LML
'03 LB7


If you feel like everything is under control, you're not going fast enough - Mario Andretti
Reply With Quote
  #7  
Old 06-26-2018, 12:44 PM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

I thought that was what you meant. My 2011 truck doesn't have the steering lines it's just a camera the shows what is behind me.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #8  
Old 06-29-2018, 08:48 AM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

I finally had a chance to get my truck checked for DTC's as my reader and my AutoCal didn't show any. I show a C0292 Lost Communications with Engine Control System. I do not understand why this code is showing a Service Stabilitrak message. Only other code shown in history is a glow plug code I know about...waiting to change all 8 for the fix for it.

I did change tunes right before this message came up. The changing tunes went fine as far as I can tell and there weren't any errors shown. Any ideas on what to do to correct this? Should I contact my tuner?

edit: The above meaning for the C0292 I got from here. I read the reader again and it says: VSES Combination Sensor Circuit Voltage Above Threshold.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi

Last edited by Trotorx2; 06-29-2018 at 09:05 AM. Reason: Different info
Reply With Quote
  #9  
Old 07-01-2018, 11:57 PM
scramHD's Avatar
scramHD scramHD is offline
"2 pints of booze"
 
Join Date: Aug 2008
Location: Tx / MS / AL / MEX
Posts: 91
Default

Check for loose ground somewhere. Follow ecm ground. Follow abs module ground. Under hood check on firewall drivers side. Check ground on frame rail under drivers seat and an engine ground on drivers side. If all is good and clean with good contact and none loose try going back to another tune. Regardless, if its the tune contact tuner. Also check ground for license plate light rear bumper. I have documents saved for the electrical pathways in and out of all the control modules and plugs if you need them I can search for them and send them to you. You can find the bad ground or short this way also.
__________________
02 LB7, cc/sb 2wd
EFI LiveV2/Neens/ATS/SoCal/PPE/SuperDiesel/Industrial Injection/TrentNell/MFrank/TTS/-McRat--Kat-/Dan
12.2/114


15.5 LML cc/sb 4wd
Zone 5"/ Fox 2.0 Resi / 4k lb rear leafs
Kryptonite UCA's/WB's/LBJ's
Cognito PISK / SB end links / Kryptonite tie rods
63.5mm 6+6 / AD 165 4g / sump by Ohio Diesel
Mishimoto hot & cold intercooler pipes / 4" CAI by me
3" MBRP downpipe / 4" ex / Magnaflow 20"
DEI heat wrapped ex / hand polished factory tip by me
Revmax Billet Triple / vb mods & T87 tuning by me
E86b Ridgerunner / EFIv2 / l25hp / 75hp / mOOnshine
Autometer pod / oil temp / boost / CTS2
Bora 1.5" / 18s / 295/70


12 yz450f
polished frame/swingarm by hand by me
GYTR head / Cycra powerflo / Flo motorsports/ Vortex bars / Ascerbis X seat / ASV shorty levers/
Bazzaz Tuning/Logging /SCAR racing / Scorcher SS header /HotCams / Twin Air
Reply With Quote
  #10  
Old 07-02-2018, 10:06 AM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

Thanks for the reply...I had given up on help from here.

I have been researching this C0292 VSES Combination Sensor Circuit Voltage Above Threshold DTC (this info came off of the Bosch code reader I borrowed from O'Reilly) and it keeps coming up check the Yaw Rate Sensor to see if it is good or the check EBCM to see if it has the right calibration in it.

The "Lost Communications with Engine Control System" is what the C0292 shows on a code list I found here. I emailed Kory but havn't seen a reply back from him yet. The tune change went smooth.

I will look around at what grounds I can find. I haven't done any work on this truck other than I had the dash cover replaced for the cracking that GM didn't think deserved a recall last fall and like I said the truck has ran fine and still does (except for the smokey tunes) it just seems odd that after an engine oil and trans oil and filter change this happens.

I haven't found a pin readout for the yaw sensor or I would have checked it this weekend.

Edit: I looked again at the DTC list on here and it shows the "Lost Communications with Engine Control System" as being set by the EBCM not the Engine Control Module so I guess the tune change and the other maintenance I did recently didn't effect this.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi

Last edited by Trotorx2; 07-02-2018 at 10:31 AM.
Reply With Quote
  #11  
Old 07-02-2018, 04:48 PM
gassux gassux is offline
Hotrodder
 
Join Date: Mar 2010
Posts: 284
Default

https://www.youtube.com/results?sear...+service+light
__________________
07 2500HD CC LBZ For Sale 92k 29,000neg
"Young man, I'm gonna twist off your head and spike it onto the floors of a nightmare you can't even imagine! I will dance with you inside the six-sided ring of fire, unless you move from this area, far and fast, NOW!"

Quote:
Originally Posted by RPM Motorsports View Post
That would suck getting nailed for dyed fuel ..., "But officer it's the Koolaid, call McRat!!"
Reply With Quote
  #12  
Old 07-02-2018, 06:09 PM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

Thanks, I've seen those.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #13  
Old 07-02-2018, 06:53 PM
Whitetail Addict's Avatar
Whitetail Addict Whitetail Addict is offline
Rockin' the stock tune
 
Join Date: May 2008
Location: South Central Pennsylvania
Posts: 2,307

Default

I've gotten a p0606 which is a "lost communication with ecm" code if I hammer on it. I clear it and keep running.

How new are your batteries? Did you load test them? It's just an idea. I can see that causing an issue with a "service stabilitrak" message plus I usually get 7 years out of ACDelco batteries.
__________________
Brandon

'12 LML
'03 LB7


If you feel like everything is under control, you're not going fast enough - Mario Andretti
Reply With Quote
  #14  
Old 07-02-2018, 07:31 PM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

My batteries aren't very old. I looked at the terminals the day the message appeared. I have a tester at work I can check them tomorrow.
I'm leaning towards it being a wiring issue maybe a dirty ground somewhere. Tomorrow I'm gonna try to find the EBCM and look at it.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
  #15  
Old 07-10-2018, 10:12 AM
Trotorx2's Avatar
Trotorx2 Trotorx2 is offline
Hotrodder
 
Join Date: Sep 2006
Location: Beaumont, Texas
Posts: 696

Default

Update:
I looked for prints or troubleshooting for this truck online but couldn't find anything so I took the truck to a local shop to have them scan the truck. They said that the Yaw Rate Sensor was bad and ordered one. I will take it in tomorrow for them to replace it. Hopefully that is the problem.
__________________
Ed


2011 GMC Sierra 2500HD Denali Crew Cab. Flo Pro 4" full delete exhaust, EGR blocked, S&B Intake, PPEI tuned.

2006 Silverado ECSB LBZ Suncoast Stage 3 w/ ML Converter Allison Deep pan, EFI Live DSP5, Castflow Manifolds, Profab up pipes with Blocker plate, Profab VVT Downpipe, Profab egr delete, MBRP 4” exhaust, Air Dog 100 with shimmed FPRV, S&B intake, Isspro Gauges, Sleeves, All Seasons centerlink brace, Rancho 9000 shocks, Sulastic Shackles, Boulder H2’s, BF Goodrich Rugged Trail T/A 265/70-17

Died 12/4/2013 RIP


Semper Fi
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors