Duramax Diesels Forum Truck of the Week
  #1  
Old 09-20-2018, 09:38 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default 6spd Allison issues

06 LBZ 6spd Allison trans

Alright let’s get started with the intermittent clunk between 5th and 6th at high way speeds then itt feels like trans/shaft releases and disengages and I watch my rpms spike up to 2500-3000. Was never a problem until about a week ago, then I got the clunk from 4th, 5th and 6th. Bought the truck with 145k on it. Just about at 170k

Tuned by starlight diesel here in Utah, threw codes for p0606, shift inhibitor,,incorrect ratio and 1 more that I’ll post when I get my scanner back. At first all the above issues would disappear when battery disconnected and reconnected. But now after it sitting. For 2 days, as soon as it shifts to second manually or automically it feels like the torque converter is free spinning right at shift and rpms spike to 2500 before I catch it and let off throttle, after rpms drop down trans engages and will go again but just to disengage again a few moments after throttle applied. Any suggestions?

Last edited by dirtydriftnutz; 09-20-2018 at 09:54 AM.
Reply With Quote
  #2  
Old 09-20-2018, 10:34 AM
BoiseRob's Avatar
BoiseRob BoiseRob is offline
Hotrodder
 
Join Date: Oct 2007
Posts: 271

Default

Trans is toast, time to rebuild it...
Reply With Quote
  #3  
Old 09-20-2018, 10:42 AM
Rivera.alan's Avatar
Rivera.alan Rivera.alan is offline
Gearhead
 
Join Date: Jun 2014
Location: Orange County CA
Posts: 70

Default

Quote:
Originally Posted by BoiseRob View Post
Trans is toast, time to rebuild it...
X2
__________________
L5p
DDP Intake Pipe
DDP Intercooler Pipe
Cognito leveling kit
Cognito Pisk
Fox Shocks
Mike L dummy trans solenoid
18x9 +18 Method wheels
295/70/18 Nitto Terra G2's

LB7 - Sold
Reply With Quote
  #4  
Old 09-21-2018, 09:37 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Drove the truck last night and got an incorrect gear ratio for 5 and 6
Then this morning only for #2
Reply With Quote
  #5  
Old 09-21-2018, 09:41 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by BoiseRob View Post
Trans is toast, time to rebuild it...
If it was toast wouldnít the problem be more persistence through each gear change?

Iíll post scanner info later on today on what info Iím getting
Reply With Quote
  #6  
Old 09-21-2018, 09:44 AM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 14,824

Default

start searching on here as to what those codes mean. trans is shot. put it on stock power and hope it dont limp or build it
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LB7, LLY, LBZ, LMM, LML, L5P 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #7  
Old 09-21-2018, 09:47 AM
graystonelbz's Avatar
graystonelbz graystonelbz is offline
Hotrodder
 
Join Date: Jul 2007
Location: Prior Lake,MN
Posts: 235
Default

I know its a tough pill to swallow, but you asked and people answered.
__________________

SSDT DSP 5
MBRP stainless 4 inch
AFE stage 2
Braces & Sleeves
Reply With Quote
  #8  
Old 09-21-2018, 10:01 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by graystonelbz View Post
I know its a tough pill to swallow, but you asked and people answered.
Yes it is, I just donít get that each time it throws a different code and not the same ones
Reply With Quote
  #9  
Old 09-21-2018, 10:02 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by Chevy1925 View Post
start searching on here as to what those codes mean. trans is shot. put it on stock power and hope it dont limp or build it
Yeah it more than likely is but Thanks for the help
Reply With Quote
  #10  
Old 09-21-2018, 10:05 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

I know everyone prefers suncoast, any other rebuild kits that are dependable to 600hp
Reply With Quote
  #11  
Old 09-21-2018, 10:06 AM
LBZ_Baker98 LBZ_Baker98 is offline
Hotrodder
 
Join Date: Jul 2016
Location: Texas
Posts: 142
Default

Quote:
Originally Posted by Rivera.alan View Post
X2
x3
__________________
07 LBZ CCSB EFI Live DSP5 and trans tuning by Quinton Schwertener, Transgo JR, Airdog 150, LML Torque converter
Reply With Quote
  #12  
Old 09-21-2018, 10:36 AM
Mike L.'s Avatar
Mike L. Mike L. is offline
Got Sheep?
 
Join Date: Aug 2006
Location: Disneyland, CA
Posts: 14,776
Default

Seems every time I see any codes with P06XX, the TCM is involved.
__________________
Inglewood Transmission Service
Shop 714 870 7300
Cell 310 918 9678

Tuned by Idaho Rob.
Reply With Quote
  #13  
Old 09-21-2018, 11:20 AM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by Mike L. View Post
Seems every time I see any codes with P06XX, the TCM is involved.
Thatís what I am thinking, and I know the Lml had issues with the heat sink. Iím just wondering if itís electrical related because itís a different code every time and when it goes to limp I get about 6 codes but when cleared they donít come back. Iíll be checking grounds on the tcm and voltage tomorrow
Reply With Quote
  #14  
Old 09-21-2018, 12:18 PM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by Mike L. View Post
Seems every time I see any codes with P06XX, the TCM is involved.
Is there a common wire that feeds off the ecm. Solus is showing 14v at ignition but with the scanner connected and communicating with the ecm the truck wants to die, drops to about 200rpms but picks back up, now back out of the ecm and go into the TCM and not a problem. Gear command goes 1-6 no problems and 6-1 no problems. 1st solenoid Pressure when put in reverse is 232.5 and 2nd matches. When put into drive itís only 21.5 while 2nd solenoid pressure is showing 232.5

Bad PSM? But the 4 switches engage according to the Solus

I feel like if the trans needed a rebuild I wouldnít trying to track down what seems to be an electrical issue
Reply With Quote
  #15  
Old 09-22-2018, 07:47 PM
dirtydriftnutz dirtydriftnutz is offline
FNG
 
Join Date: Sep 2018
Posts: 9
Default

Quote:
Originally Posted by Mike L. View Post
Seems every time I see any codes with P06XX, the TCM is involved.
update... could have sworn i was getting a signal reading before but took it out today and was not getting any VSS reading. 0.0mph no matter what gear. swapped with a known good one and still nothing. decided to inspect wiring loom that goes back about 12" to connector and all seemed okay. unpluged ISS just a little further to inspect and now not getting a reading from that. wondering if these share a common ground im just not seeing
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:54 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors