Duramax Diesels Forum Truck of the Week
  #1  
Old 12-04-2017, 07:27 PM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default Those dang fpr issues....

Hello duramax lovers,mechanics,enthusiasts. I am having some minor issues after installing my fuel pressure regulator on my 2004 chevy 2500hd lb7.
So my problem is when I am in drive the truck shutters and it has a higher idle then usual. Also when I put the vehicle in reverse it does the same dang thing. The truck has power like a beast there is no white smoke. I am not tuned I am bone stock. Also when the truck is in park it idles normally. I recently did an oil change fuel filter change and I always keep diesel kleen in the tank every fill up. When I replaced the fpr it took me roughly two days because my auto parts store didnt have the parts I needed and I left the wire harness unplugged. My question is should I give my truck some time to relearn everything or what direction should I take.

Thank you in advanced
Reply With Quote
  #2  
Old 12-04-2017, 07:39 PM
IOWA LLY's Avatar
IOWA LLY IOWA LLY is offline
Yes, its really me
 
Join Date: Feb 2007
Posts: 2,262
Default

You forgot to plug in the ECT sensor. It's located right beside the alternator. If you didn't forget to plug it in then you might have pinched a wire.


Sent from my iPhone using Tapatalk Pro
__________________
2003 GMC CCSB LLY
Built by me, tuned by me.

2009 ECI Diesel Truck Points Champion
2010 ECI Diesel Truck Points Champion
2011 ECI Diesel Truck Points Champion
2012 ECI Diesel Truck Points Champion

Big thanks to everyone who helps me.

Best 1/8th, 7.29, 98.6MPH (Street tires, fuel only, single Journal bearing GT42 charger) (2010)

Best 1/8th, 6.93, 104.24MPH (Street tires, fuel only, single HX60 turbo) (2016)

Best 1/8th, 6.60, 106.6MPH (Street tires, fuel only, single HX60 turbo) (2017)
Reply With Quote
  #3  
Old 12-04-2017, 07:47 PM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default

Thank you I appreciate your response I am on shift right now I will get back with you in the morning thank you.
Reply With Quote
  #4  
Old 12-04-2017, 07:56 PM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default

Ok I went outside to my truck and I found the ect sensor has a shitty splice.
Reply With Quote
  #5  
Old 12-04-2017, 08:01 PM
tsd_billy tsd_billy is offline
Hotrodder
 
Join Date: Apr 2016
Location: oklahoma city
Posts: 449

Default

Quote:
Originally Posted by Codido187 View Post
Ok I went outside to my truck and I found the ect sensor has a shitty splice.


If its crimped solder it , should solve the issue. Its changing the fuel table up every time it shorts


Sent from my iPhone using Tapatalk
__________________
Vgt swapped lb7, street block built by bobby at Mikes performance engine
Reply With Quote
  #6  
Old 12-04-2017, 08:03 PM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default

Dang good to know gents I will borrow my girlfriends grandpas soldering iron. What size of heat shrink would y’all get? I would suppose when I removed the alternator I yanked on the already bad wire connections. Why would the truck idle wierd in park and drive is my question. I don’t understand how the ect works as this is my first diesel truck.

Last edited by Codido187; 12-04-2017 at 08:17 PM.
Reply With Quote
  #7  
Old 12-04-2017, 08:24 PM
IOWA LLY's Avatar
IOWA LLY IOWA LLY is offline
Yes, its really me
 
Join Date: Feb 2007
Posts: 2,262
Default

The fuel tables and idle rpm will vary with coolant temperature. And if the ECT sensor is disconnected it will think the coolant temp is very cold. (-40f) So the idle rpm will be raised and all sorts of other strange things will happen because the ECM is trying to compensate for the extreme cold.


Sent from my iPhone using Tapatalk Pro
__________________
2003 GMC CCSB LLY
Built by me, tuned by me.

2009 ECI Diesel Truck Points Champion
2010 ECI Diesel Truck Points Champion
2011 ECI Diesel Truck Points Champion
2012 ECI Diesel Truck Points Champion

Big thanks to everyone who helps me.

Best 1/8th, 7.29, 98.6MPH (Street tires, fuel only, single Journal bearing GT42 charger) (2010)

Best 1/8th, 6.93, 104.24MPH (Street tires, fuel only, single HX60 turbo) (2016)

Best 1/8th, 6.60, 106.6MPH (Street tires, fuel only, single HX60 turbo) (2017)
Reply With Quote
  #8  
Old 12-04-2017, 08:25 PM
tsd_billy tsd_billy is offline
Hotrodder
 
Join Date: Apr 2016
Location: oklahoma city
Posts: 449

Default

Quote:
Originally Posted by IOWA LLY View Post
The fuel tables and idle rpm will vary with coolant temperature. And if the ECT sensor is disconnected it will think the coolant temp is very cold. (-40f) So the idle rpm will be raised and all sorts of other strange things will happen because the ECM is trying to compensate for the extreme cold.


Sent from my iPhone using Tapatalk Pro


Well said sir


Sent from my iPhone using Tapatalk
__________________
Vgt swapped lb7, street block built by bobby at Mikes performance engine
Reply With Quote
  #9  
Old 12-04-2017, 08:30 PM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default

Very interesting thank you for the explanation. I will sodder everything up in the morning. Thank you both for your quick responses I’ll let you know if it changes the roughness. I am sure it will y’all know what your talking about
Reply With Quote
  #10  
Old 12-04-2017, 11:41 PM
stibuilder's Avatar
stibuilder stibuilder is offline
Hotrodder
 
Join Date: Oct 2016
Location: Snoqualmie, WA
Posts: 218
Default

Is this the same thing for the LBZ?
__________________
2007 Kodiak C4500 (quadcab)
Efi Live, FASS 150, Custom Exhaust, Bunch of Gauges, Tahoe Headlights, Custom Stereo,National Air Seats, Flat bed, Profab Y Bridge, ARP Studs, 12x12x2 Oil cooler, BAT Sandwich adapter, 12x12x2 trans cooler, Oil Pressure/Temp Gauges, Belly mount Onan 5500w Generator. LDS 30% Overs.

28FT Intech Car trailer

@stibuider
Reply With Quote
  #11  
Old 12-04-2017, 11:59 PM
DAVe3283's Avatar
DAVe3283 DAVe3283 is offline
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 2,773

Default

Quote:
Originally Posted by stibuilder View Post
Is this the same thing for the LBZ?
Yes, all years compensate for coolant temperature, and behave oddly if the reading is bad or intermittent.

Sent from my Cat S60 using Tapatalk
__________________

Reply With Quote
  #12  
Old 12-05-2017, 08:07 AM
Codido187 Codido187 is offline
FNG
 
Join Date: Dec 2017
Posts: 15
Default

Ect is buttoned up still surging in reverse and drive. I wonder if I got a bad fpr when I replaced it? Or I have a bad ect but I am not popping any codes
Reply With Quote
  #13  
Old 12-05-2017, 08:30 AM
IOWA LLY's Avatar
IOWA LLY IOWA LLY is offline
Yes, its really me
 
Join Date: Feb 2007
Posts: 2,262
Default

What were the symptoms before you replaced the FPR? Where did you get your new FPR from?

Surging and erratic idle can be caused from a whole host of things.....


Sent from my iPhone using Tapatalk Pro
__________________
2003 GMC CCSB LLY
Built by me, tuned by me.

2009 ECI Diesel Truck Points Champion
2010 ECI Diesel Truck Points Champion
2011 ECI Diesel Truck Points Champion
2012 ECI Diesel Truck Points Champion

Big thanks to everyone who helps me.

Best 1/8th, 7.29, 98.6MPH (Street tires, fuel only, single Journal bearing GT42 charger) (2010)

Best 1/8th, 6.93, 104.24MPH (Street tires, fuel only, single HX60 turbo) (2016)

Best 1/8th, 6.60, 106.6MPH (Street tires, fuel only, single HX60 turbo) (2017)
Reply With Quote
  #14  
Old 12-05-2017, 08:31 AM
tsd_billy tsd_billy is offline
Hotrodder
 
Join Date: Apr 2016
Location: oklahoma city
Posts: 449

Default

Unplug the frp and start the truck. Should max out your cp3. If not you know where to start at least


Sent from my iPhone using Tapatalk
__________________
Vgt swapped lb7, street block built by bobby at Mikes performance engine
Reply With Quote
  #15  
Old 12-05-2017, 08:34 AM
tsd_billy tsd_billy is offline
Hotrodder
 
Join Date: Apr 2016
Location: oklahoma city
Posts: 449

Default

Bad rps , rail plug (pretty uncommon but not impossible), bad tunes etc lol


Sent from my iPhone using Tapatalk
__________________
Vgt swapped lb7, street block built by bobby at Mikes performance engine
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:27 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors