Duramax Diesels Forum Truck of the Week


Go Back   Duramax Diesels Forum > Duramax/Diesel Technical > Duramax Hard Parts > LMM

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 05-21-2020, 09:57 PM
MasterN8er's Avatar
MasterN8er MasterN8er is offline
Broke on a budget
 
Join Date: Apr 2020
Location: Texas
Posts: 4

Default Mystery Coolant leak

I have a 2009 LMM. The EGR Cooler has been removed ("for offroad purposes") and im using Sinister Diesel's delete kit in its place. Basically its a silicone hose connected to the coolant lines in the firewall. The hose clamps that come with it seemed to come off every couple of months and empty my coolant. Ive since fixed that issue.

I noticed today my coolant light came on, I parked it where I could and let the engine cool of some before checking it out. So before I opened the reservoir cap I had no coolant in there what-so-ever. I then started to turn it and it all came up to where it needed to be. I added a little bit of water to be safe and sure enough the notification came back on.

I drove it 15 mins to home and I let it sit for about 3 hours. I just checked it and the reservoir is empty. I dont see any any visible leaks and my hose in the back is still on fully.

I was going to dig into it in the morning, any suggestions or ideas to look at or worry about? I just hit 130k miles.

Any feedback or help is appreciated!
Reply With Quote
  #2  
Old 05-21-2020, 11:29 PM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 3,557

Default

Coolant hoses on turbo
__________________
2008 GMC duramax crew cab short bed 2500.
[email protected]

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #3  
Old 05-22-2020, 03:17 AM
TheBac's Avatar
TheBac TheBac is online now
Why do I keep doing this?


 
Join Date: Apr 2008
Location: Mid Michigan
Posts: 13,248

Default

Moved to LMM
__________________
Tom
"BBT" -- 2003 GMC CC/SB 4x [email protected]
"Kleshay" -- 2000 C5 Corvette -- the toy
2019 Ford Fusion Hybrid -- the DD


Marlene (Molly) Bacon -- 1936 - 2019 -- RIP Mom You're already missed, at home and on the piano.

Two wrongs dont make a right, but three rights do make a left.
Reality is a matter of perspective.
This forum isn't for the weak of heart.....or wallet.
"Lets build a race car they said. Itll be fun they said. I don't know who "they" are.........but they need a good punch in the face!" -- mufflerguy (yb)
Reply With Quote
  #4  
Old 05-22-2020, 05:47 AM
MasterN8er's Avatar
MasterN8er MasterN8er is offline
Broke on a budget
 
Join Date: Apr 2020
Location: Texas
Posts: 4

Default

Alright so I just checked it added some water to see if it went anywhere. It didn't start leaking until I moved the truck and it appeared to come from the passenger side. Any ideas? Im about to take off my airbox to see if maybe tbe hose to the reservoir is ****ed
__________________
NA$TYNATE

_______________________
2009 CCSB 2500 415 HP
1990 ECLB 1500 Phantom Dually
Reply With Quote
  #5  
Old 05-22-2020, 11:27 AM
1FastBrick 1FastBrick is offline
Hotrodder
 
Join Date: Dec 2016
Location: Junkyard
Posts: 395
Default

Can you tell if its front or back of motor?

What about the coolant block off on the block/transmission adapter plate?
Reply With Quote
  #6  
Old 05-22-2020, 12:46 PM
MasterN8er's Avatar
MasterN8er MasterN8er is offline
Broke on a budget
 
Join Date: Apr 2020
Location: Texas
Posts: 4

Default

From the water spot I found it looked to be from the front passenger side. I checked the hoses going to the intercooler and I couldnt find any holes or cuts. Im starting to wonder maybe my radiator took a shit
__________________
NA$TYNATE

_______________________
2009 CCSB 2500 415 HP
1990 ECLB 1500 Phantom Dually
Reply With Quote
  #7  
Old 05-22-2020, 01:03 PM
M.A.M.'s Avatar
M.A.M. M.A.M. is online now
Hotrodder
 
Join Date: Jan 2016
Location: Ohio
Posts: 393
Default

Easiest thing to do is put a pressure tester on it. Borrow one from somebody, or loan it from the part store.


Sent from my iPhone using Tapatalk
__________________
2015 CCLB (built motor/trans, compounds)
2017 dually (work)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vB.Sponsors