Duramax Diesels Forum Truck of the Week
  #1  
Old 07-12-2019, 12:59 PM
Mac Daddy's Avatar
Mac Daddy Mac Daddy is offline
Hotrodder
 
Join Date: Apr 2008
Location: Mont Belvieu,TX.
Posts: 128
Default LMM A/C issues

A/C works fine for 5-8 minutes then starts blowing warm air. If I turn off ignition and open driver door then restart truck it will blow cold again for a little while then warm again. Took it to a mechanic and A/C checked out with no problems and blend doors were working properly, he said it needed an update from Chevy. The truck is 11 years old with 247K miles I don't see how an update from Chevy would help. Anyone ever had this issue?
__________________
'08 Chevy CC/SB Z71
20" Rockstars (black) w/ 35x12.50x20 General Grabbers
6" SuperLift suspension kit
5" SS Magnaflow exhaust (deleted DPF and cat)
N-Fab wheel to wheel steps
Weather Tec floor mats (doesn't help performance but I like em)
McRat 120Hp Tune
Reply With Quote
  #2  
Old 07-12-2019, 01:06 PM
snowman22's Avatar
snowman22 snowman22 is offline
Hotrodder
 
Join Date: Jan 2018
Location: SoCal
Posts: 206
Default

You need to get a set of gauges on it and see what's going on.
__________________
2015.5 LML GMC Denali 3500 SRW 4wd CCLB 100k Miles
Mike L Trans, 4" FlowPro, MBRP Down Pipe, 30" FTE Resonator, S&B Intake, Twin Kennedy Pumps, Bilstein 5100, Poly U/LCA Bushings, Kryptonite Tie Rods, EBC Sport Rotors Yellow Pads, Edge CTS2
Reply With Quote
  #3  
Old 08-28-2019, 06:52 AM
Mac Daddy's Avatar
Mac Daddy Mac Daddy is offline
Hotrodder
 
Join Date: Apr 2008
Location: Mont Belvieu,TX.
Posts: 128
Default

Quote:
Originally Posted by snowman22 View Post
You need to get a set of gauges on it and see what's going on.
Found out the magnet on the AC was weak...replaced compressor and works fine now.
__________________
'08 Chevy CC/SB Z71
20" Rockstars (black) w/ 35x12.50x20 General Grabbers
6" SuperLift suspension kit
5" SS Magnaflow exhaust (deleted DPF and cat)
N-Fab wheel to wheel steps
Weather Tec floor mats (doesn't help performance but I like em)
McRat 120Hp Tune
Reply With Quote
  #4  
Old 08-28-2019, 08:48 PM
THEFERMANATOR's Avatar
THEFERMANATOR THEFERMANATOR is offline
LEGALLY INSANE
 
Join Date: Feb 2009
Location: ZEPHYRHILLS, FL
Posts: 3,741
Default

Quote:
Originally Posted by Mac Daddy View Post
Found out the magnet on the AC was weak...replaced compressor and works fine now.
The magnet was probably fine(it's just an electro magnet coil), the clutch gap was probably too large for it to pull closed when hot. This is a common issue on anything with more than 100k miles. I've lost track of how many clutches I've re-gapped for people that other shops said needed a new clutch or a whole compressor. Yes a new clutch/compressor "fixxes" it, but removing a shim works just as good 99% of the time, and can normally be done in under 30 minutes with zero parts cost VS a few hundred for a comprrssor.
__________________
1995 GMC 2500 SUBURBAN powered by 01 DURAMAX/ALLISON, little of this, a little of that,
DIAMONDEYE 4" exhaust, CORSA muffler, AFE stage 1 dry filter, custom tuning by me, KENNEDY single pump and pump rub kit.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:58 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors