Duramax Diesels Forum Truck of the Week
  #31  
Old 03-13-2018, 09:54 AM
Bdsankey Bdsankey is offline
Hotrodder

 
Join Date: Feb 2018
Location: Oshkosh, WI
Posts: 249

Default

Quote:
Originally Posted by Dragbear View Post
Yea the fist thing I did after the install was pressure test the boost side to 20psi.
My S371 only ran 2 or 3 psi on the street along with the factory vnt .
My S371 on a pull at 3600 RPM would run 42 boost and 57 drive.
At 2800 it was 52/52
At 3900 it was 31 boost and 71 drive
I wound this S475 up to 4500 and it did the same thing 30 boost and 70 drive.
It makes that boost/drive ratio because the turbine isn't driving the compressor hard enough.

I've seen many 476/87/1.10 chargers make gobs of power and run pretty darn good boost/drive ratios. Friend of mine made 55-60psi on a 476/87/.90 with 100s and a single 10mm. His drive wasn't far off.
__________________
Current Rides:
1) Toy: 2005 LLY ECSB, Leather, Sunroof
-820hp/1748ft-lbs @ Duramax Tuner (6/25/18)
-Built Motor, Bullseye Batmowheel S475/87/1.0 "Comp R75", Exergy 250% overs with "Redman" internal mods, Exergy 14mm street pump w/AN feed, Goerend "J" Converter, Built Trans, AD2 165, Beans Sump, E-Locker, TrueTrac, Yukon 4340 Shafts, Traction Bars, DHD Center Link Brace, DHD Lower Crossmember Support


Past Rides:
1) 2002 LB7 CCSB, Leather, Loaded
-New Bosch Reman Injectors, New LBZ CP3, FASS 150, RCD Sump, 3" MBRP Downpipe, 4" Downpipe Back w/ Muffler, Sleeves, DHD Centerlink Brace, DHD Lower Crossmember Support, Steering Wheel Radio Control Swap
Reply With Quote
  #32  
Old 03-13-2018, 10:08 AM
DAVe3283's Avatar
DAVe3283 DAVe3283 is offline
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 2,810

Default

Quote:
Originally Posted by Dragbear View Post
Yea the fist thing I did after the install was pressure test the boost side to 20psi.
My S371 only ran 2 or 3 psi on the street along with the factory vnt .
My S371 on a pull at 3600 RPM would run 42 boost and 57 drive.
At 2800 it was 52/52
At 3900 it was 31 boost and 71 drive
I wound this S475 up to 4500 and it did the same thing 30 boost and 70 drive.
Something is wrong with your setup or tuning, IMO. I have a S371 and I see more boost than that even with my big cam and Wagler heads, and this is on the street with a smoke-free tune. If you were running a big tune, you should've seen in excess of 60 PSI out of the S371. Been there, blown up a S371 in the process. (They don't like to run 60+ PSI on hills for more than a couple seconds, especially at altitude. Seems to survive 50 PSI, so far.)

Even with the tight .90 AR on the S475, you should be flowing enough to get the boost up in the midrange. I presume this is an ungated install?

If you have 70 PSI of backpressure, it should be spooling the turbo. Besides a tune being WAY off somehow, I don't know why it isn't working for you. Assuming no major boost leaks, of course.
__________________

Reply With Quote
  #33  
Old 03-13-2018, 10:09 AM
ctodd36 ctodd36 is offline
Gearhead
 
Join Date: Nov 2016
Location: Otego, NY
Posts: 92

Default

Sounds like you’re done pulling spi rick!


Sent from my iPhone using Tapatalk
__________________
04 ECSB 2.5 puller
15 CC Dually
Reply With Quote
  #34  
Old 03-13-2018, 10:11 AM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,857

Default

Did u go from a 4" intake on the s300 to a 5" with the s400? And is the tuner aware of that?

Sent from my XT1585 using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #35  
Old 03-13-2018, 12:08 PM
Dragbear Dragbear is offline
Dragbear
 
Join Date: Aug 2013
Posts: 36
Default

Yes 5" intake
No change in tune yet. Need to get a data log to tuner.
I already discenagrated the compressor on one S396 from over speed. Use to run 3rd gear start all the way at 3900rpm. I run 4th gear start all last year at 3200rpm. Made a lot more power and turbo was much happier. As soon as the drive pressure got up around 70 psi you could feel the power drop off.
__________________
S&B intake, Fleece 63mm cheetah turbo, Exergy 60% over injectors, Industrial Injection 12mm 85%over CP3, Banks down pipe, Sinister intake tube & egr cooler delete, Diamond turbo down pipe, Cat-DPF delete, Black Cloud stack kit, Grand Rock 6" Aussie stacks, Drop in stack mufflers, Fass titanium 150, Ported fuel rail fitting, Pressure relief block off, EFI Live, Built Trans, Vigilante converter, Trany to transfer case brace, Traction bars, Drive shaft hoops, Eaton front e-locker, Cognito braces, Tie rod sleeves, Edge insight.
Reply With Quote
  #36  
Old 03-13-2018, 12:45 PM
Bdsankey Bdsankey is offline
Hotrodder

 
Join Date: Feb 2018
Location: Oshkosh, WI
Posts: 249

Default

Quote:
Originally Posted by Dragbear View Post
Yes 5" intake
No change in tune yet. Need to get a data log to tuner.
I already discenagrated the compressor on one S396 from over speed. Use to run 3rd gear start all the way at 3900rpm. I run 4th gear start all last year at 3200rpm. Made a lot more power and turbo was much happier. As soon as the drive pressure got up around 70 psi you could feel the power drop off.
That isn't helping your issue, get a tune update. The tuner shouldn't require any sort of data log to update your MAF table for a 5" intake vs the 4" that was on there. If your tuner requires a data log for that you may have other underlying issues.

Mark @ Danville shouldn't need a data log to update the MAF table.

The reason you NEED a tune update is because your MAF is now farther away from the center of the air flow.
__________________
Current Rides:
1) Toy: 2005 LLY ECSB, Leather, Sunroof
-820hp/1748ft-lbs @ Duramax Tuner (6/25/18)
-Built Motor, Bullseye Batmowheel S475/87/1.0 "Comp R75", Exergy 250% overs with "Redman" internal mods, Exergy 14mm street pump w/AN feed, Goerend "J" Converter, Built Trans, AD2 165, Beans Sump, E-Locker, TrueTrac, Yukon 4340 Shafts, Traction Bars, DHD Center Link Brace, DHD Lower Crossmember Support


Past Rides:
1) 2002 LB7 CCSB, Leather, Loaded
-New Bosch Reman Injectors, New LBZ CP3, FASS 150, RCD Sump, 3" MBRP Downpipe, 4" Downpipe Back w/ Muffler, Sleeves, DHD Centerlink Brace, DHD Lower Crossmember Support, Steering Wheel Radio Control Swap
Reply With Quote
  #37  
Old 03-13-2018, 01:33 PM
Dragbear Dragbear is offline
Dragbear
 
Join Date: Aug 2013
Posts: 36
Default

Mark has my mass air shut off. It has been off for 2 years now.
I bought a new one but never had it put back into the tuning.
__________________
S&B intake, Fleece 63mm cheetah turbo, Exergy 60% over injectors, Industrial Injection 12mm 85%over CP3, Banks down pipe, Sinister intake tube & egr cooler delete, Diamond turbo down pipe, Cat-DPF delete, Black Cloud stack kit, Grand Rock 6" Aussie stacks, Drop in stack mufflers, Fass titanium 150, Ported fuel rail fitting, Pressure relief block off, EFI Live, Built Trans, Vigilante converter, Trany to transfer case brace, Traction bars, Drive shaft hoops, Eaton front e-locker, Cognito braces, Tie rod sleeves, Edge insight.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors