Duramax Diesels Forum Truck of the Week
  #1  
Old 05-17-2019, 12:33 PM
BigbrettLML BigbrettLML is offline
FNG
 
Join Date: May 2019
Posts: 2
Default battery and mega fuse issue

First post in a forum for me. Was smelling a melting plastic smell in my truck this morning...found that on the driver side battery the terminal the mega fuse was melting the plastic. The connection was loose. I tighten it up. My question is could the loose connection have been the issue. Never had a problem starting and both batteries have 12v.any help would be great thanks.
Reply With Quote
  #2  
Old 05-17-2019, 01:30 PM
lts1ow's Avatar
lts1ow lts1ow is offline
Needs moar PAH!
 
Join Date: May 2012
Location: NJ
Posts: 1,596
Default

Yes, loose connections means comprised surface area which means more current density through what is left.
__________________
2005 LLY: AFE Bladerunner, MBRP downpipe, sewer pipe exhaust, PPE tuner, !EGR

1995 Z28: 76mm, 383ci LTwon, 80e 660hp/750ft-lb 10.2@140

2014 CTD Stock
Reply With Quote
  #3  
Old 05-17-2019, 02:17 PM
BigbrettLML BigbrettLML is offline
FNG
 
Join Date: May 2019
Posts: 2
Default

That's what I figured...I'll see if the problem is fixed. Hopefully that's all it was. Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:02 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors