Duramax Diesels Forum Truck of the Week


Go Back   Duramax Diesels Forum > Duramax/Diesel Technical > Duramax Hard Parts > LB7

Notices

Reply
 
Thread Tools Display Modes
  #1  
Old 05-14-2020, 08:40 AM
byeezy_lb7 byeezy_lb7 is offline
FNG
 
Join Date: Feb 2020
Location: Reno, NV
Posts: 19
Default misfire issue.

hey guys im trying to get my truck dialed in and truck threw a code for misfire cylinder 7.

the truck falls flat on its face off idle and the injectors clack and sputter and then finally decides to get going.

I used the cts2 monitor to check balance rates and i dont know if my monitor is not working properly but they all say 0.0

any ideas?

motor is fully built, triple turbos with 200 over injectors and dual 10mm cp3 pumps...

thanks.
__________________
2003 Lb7

fully built motor, triple turbskis

Mike L built trans with all the billet goodies.
Reply With Quote
  #2  
Old 05-14-2020, 09:44 AM
slowlml's Avatar
slowlml slowlml is offline
Empty Pockets
 
Join Date: Feb 2015
Location: Mountains of wv
Posts: 404
Default

If they all say 0.0 something is wrong. Whose injectors and tuning?
__________________
Nic R
"Flat Back Gorilla" Daily/Tow rig- 04 GMC Sierra LB7 CC Flatbed/Stock..ish
"Empty Pockets" Race/Pulling truck- 2012 CCSB Cummins/Built engine/48re swap
Reply With Quote
  #3  
Old 05-14-2020, 09:54 AM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 2,455

Default

I would be looking at the connection right at the injectors. Maybe a loose nut or two
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #4  
Old 05-14-2020, 10:38 AM
byeezy_lb7 byeezy_lb7 is offline
FNG
 
Join Date: Feb 2020
Location: Reno, NV
Posts: 19
Default

Quote:
Originally Posted by slowlml View Post
If they all say 0.0 something is wrong. Whose injectors and tuning?
S&S injectors and pumps and danville tuning
__________________
2003 Lb7

fully built motor, triple turbskis

Mike L built trans with all the billet goodies.
Reply With Quote
  #5  
Old 05-14-2020, 11:06 AM
Burn Down's Avatar
Burn Down Burn Down is offline
Hotrodder
 
Join Date: Sep 2008
Location: Boise Idaho
Posts: 7,059

Default

X2 on a loose injector nut, bad connection.
__________________
Albert

04.5 CCSB ole blue, built trans, mpi twins, 12.5X @ 108
99' Reg Cab, 1500 2wd, Turbo or Procharged 6.0, 4L80E build inprogress
05 CCSB Millennium Falcon, built eng, built trans, mpi twins, 11.51 @ 119 1.59 60
84' Reg Cab SB, 415 BBC, 4-speed, needs a D-max zf6 swap
Reply With Quote
  #6  
Old 05-14-2020, 01:30 PM
juddski88's Avatar
juddski88 juddski88 is offline
Freedom Diesel
 
Join Date: Jul 2008
Location: Chesterfield, Mass.
Posts: 4,340

Default

Did it start doing it after any hard runs or abuse?
__________________
2001 Chevy 2500HD ECSB
"Sore Subject" - Still don't have time for it.
I would never have learned what I have without George Alexander, Mike Lovrich, David Browning, Matt Handwork, Ben Tyler, Evan Drosehn and countless members of this forum and others.
Thank you.

2014 Jeep Grand Cherokee Limited, Ecodiesel
Reply With Quote
  #7  
Old 05-14-2020, 07:25 PM
KyleC4 KyleC4 is offline
Tech
 
Join Date: Dec 2016
Location: Bay Area
Posts: 285
Default

This won’t help your condition but last time I had an lb7 constantly show 0.0 for balance rates the truck had a bad speed sensor on transfer case. When at a stop the tech 2 was showing 1mph being read by ECM.
__________________
Concord Chevrolet
Mike L and Inglewood transmission
Reply With Quote
  #8  
Old 05-15-2020, 05:13 AM
Bdsankey's Avatar
Bdsankey Bdsankey is offline
Vendor


 
Join Date: Feb 2018
Location: Neenah, Wisconsin
Posts: 1,720

Default

As said above, the truck will not report accurate balance rates if it senses throttle input or vehicle speed. It is also possible that you have a loose nut on an injector causing the issue.
__________________
K&D Service Inc
Call or Text: 906-284-0962
Providing a "one-stop-shop" for all of your automotive needs!

Current Rides:
1) Toy: 2005 LLY ECSB, Leather, Sunroof
-1340hp/2200ft-lbs @ ATS Diesel (06/04/19)
-Built Motor, Triples (2x S369 over a 472), F1 Diesel 300% Inj, Exergy 14mm Street Pump/LBZ CP3, Goerend Bolt Together Converter, Billet Trans, Banks Intercooler, Fuelab Supply Pump/Reg, RCD & Beans Sumps, Front E-Locker, TrueTrac, Yukon 4340 Rear Shafts, Traction Bars, DHD Center Link Brace, DHD Lower Crossmember Support, Banks iDash 1.8 Monitoring System

2) DD/Tow Rig: 2002 LB7 CCSB, Leather, Loaded
-FASS 150,4" Exhaust, RCD Sump, PPE Sleeves, DHD Centerlink Brace, DHD Lower Crossmember Support, Built Motor, Big Oil Cooling, Banks iDash 1.8 Monitoring System
Reply With Quote
  #9  
Old 05-18-2020, 08:27 AM
byeezy_lb7 byeezy_lb7 is offline
FNG
 
Join Date: Feb 2020
Location: Reno, NV
Posts: 19
Default

Quote:
Originally Posted by juddski88 View Post
Did it start doing it after any hard runs or abuse?
It did start doing it after I broke The engine in and started getting on the throttle..
__________________
2003 Lb7

fully built motor, triple turbskis

Mike L built trans with all the billet goodies.
Reply With Quote
  #10  
Old 05-18-2020, 08:46 AM
juddski88's Avatar
juddski88 juddski88 is offline
Freedom Diesel
 
Join Date: Jul 2008
Location: Chesterfield, Mass.
Posts: 4,340

Default

May have lifted an injector, or cup if they aren't threaded... Assuming you don't have an aftermarket head that doesn't use cups. Could be a couple of things, but that's what I would check first. Do a compression test.
__________________
2001 Chevy 2500HD ECSB
"Sore Subject" - Still don't have time for it.
I would never have learned what I have without George Alexander, Mike Lovrich, David Browning, Matt Handwork, Ben Tyler, Evan Drosehn and countless members of this forum and others.
Thank you.

2014 Jeep Grand Cherokee Limited, Ecodiesel
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vB.Sponsors