Duramax Diesels Forum Truck of the Week
  #1  
Old 06-13-2018, 05:05 PM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default Radio Wiring Gremlins

Long story long, I've had my Avid 6000 nex radio in the truck for the last 4 years, it's always ran without a problem.

Last month out of the blue the sound in the speakers stopped intermittently working. All 4 speakers except for the sub would randomly cut out and only the subwoofer with it's own amp would keep playing. All it would take to fix the issue was turning the radio off and on and 4 speakers would work again just fine.

Fast forward to this week, the speakers no longer play any sound.

Here are the a few things that I've done:

1. Checked with a different deck, used the same wiring, but plugged in a newer version of the deck, still no sound, subwoofer works.
2. Checked all the fuses, engine bay and by the driver door, all are working.
3. Check the wiring all the way from the adapter wiring to the speaker, connection seems solid, multimeter confirmed that.
4. Checked with a different speaker in the truck, same wiring, still no sound coming out.
5. Took the speaker out of the truck plugged it into my offroad car, speaker works fine.

Short of getting an amp and running new wire to the speakers, I'm out of ideas.

This is my 2006 Silverado 3500, non-bose radio, no rear audio control, no onstar, came originally with the single cd radio.

I'm out of ideas, any suggestions would be appriciated
__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography

Last edited by turndriverside; 06-13-2018 at 05:12 PM.
Reply With Quote
  #2  
Old 06-13-2018, 05:09 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 14,526

Default

Definitely trans and/or the fan clutch
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #3  
Old 06-13-2018, 05:12 PM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default

Quote:
Originally Posted by Chevy1925 View Post
Definitely trans and/or the fan clutch
I've removed the fan clutch and refilled the transmission with diesel fluid. Those are problems waiting to happen, let's focus on the now jimbo.
__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography
Reply With Quote
  #4  
Old 06-13-2018, 05:14 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 14,526

Default

Quote:
Originally Posted by turndriverside View Post
I've removed the fan clutch and refilled the transmission with diesel fluid. Those are problems waiting to happen, let's focus on the now jimbo.


Why you gotta take the fun out of this? Lmao
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #5  
Old 06-13-2018, 05:39 PM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 2,960

Default

Did you try only hooking up one speaker at a time?
__________________
2008 GMC duramax crew cab short bed 2500.
10.98@124mph

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #6  
Old 06-13-2018, 06:13 PM
Ridin'GMC's Avatar
Ridin'GMC Ridin'GMC is offline
I like red
 
Join Date: May 2010
Location: MA
Posts: 590
Default

Do you have metro or PAC interface module? Those are most likely your issue.
__________________
07 LBZ CCSB

RIP 4/1/17
06 LLY CCSB
Reply With Quote
  #7  
Old 06-13-2018, 07:41 PM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default

Quote:
Originally Posted by gmduramax View Post
Did you try only hooking up one speaker at a time?
I did not, I will give that a try.

Quote:
Originally Posted by Ridin'GMC View Post
Do you have metro or PAC interface module? Those are most likely your issue.
God damn it, I was looking at this shitty plastic chinese box and was wondering myself if it's causing issues. Ordering one now. Thanks!

I'll give it a try when it comes in.

Edit - wait a second, thought you were talking about the interface to keep my steering wheels controls. That's the shitty chinese box I was refering to. Looks like the pac module has something to do with the stock subwoofer? In my case my truck didn't come with one.

Edit Edit - I have one of these, I'll order it just to be safe. https://smile.amazon.com/Axxess-ASWC...wheel+controls
__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography
Reply With Quote
  #8  
Old 06-13-2018, 07:44 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 14,526

Default

Quote:
Originally Posted by turndriverside View Post
I did not, I will give that a try.



God damn it, I was looking at this shitty plastic chinese box and was wondering myself if it's causing issues. Ordering one now. Thanks!

I'll give it a try when it comes in.

Edit - wait a second, thought you were talking about the interface to keep my steering wheels controls. That's the shitty chinese box I was refering to. Looks like the pac module has something to do with the stock subwoofer? In my case my truck didn't come with one.


Hes talking about that module buddy. The one that keeps the door chime, steering controls and other crap workin in your rig.
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #9  
Old 06-14-2018, 02:49 AM
Ridin'GMC's Avatar
Ridin'GMC Ridin'GMC is offline
I like red
 
Join Date: May 2010
Location: MA
Posts: 590
Default

That module also control the speakers too.
__________________
07 LBZ CCSB

RIP 4/1/17
06 LLY CCSB
Reply With Quote
  #10  
Old 06-14-2018, 02:59 AM
Ridin'GMC's Avatar
Ridin'GMC Ridin'GMC is offline
I like red
 
Join Date: May 2010
Location: MA
Posts: 590
Default

Everything goes through the can bus data. Without the interface to communicate to the BCM, the speakers won't work.
__________________
07 LBZ CCSB

RIP 4/1/17
06 LLY CCSB
Reply With Quote
  #11  
Old 06-14-2018, 06:32 AM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default

Quote:
Originally Posted by Chevy1925 View Post
Hes talking about that module buddy. The one that keeps the door chime, steering controls and other crap workin in your rig.
No door chimes here, just that other steering wheel control.

Quote:
Originally Posted by Ridin'GMC View Post
That module also control the speakers too.
Quote:
Originally Posted by Ridin'GMC View Post
Everything goes through the can bus data. Without the interface to communicate to the BCM, the speakers won't work.
Got it! Thanks!
__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography
Reply With Quote
  #12  
Old 06-14-2018, 07:00 AM
DAVe3283's Avatar
DAVe3283 DAVe3283 is online now
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 2,808

Default

From what I have seen of most radio's protection circuits, if there is a short on any one speaker, ALL speakers are turned off to protect the radio. The interface module could be the problem, and if it isn't, try disconnecting the speakers one at a time as close to the head unit as possible.

Or just take a multimeter and measure the resistance of all the speakers at the connector to the head unit. They should all be the same value, probably 4 or 8 ohms. If one is different from the rest, trace that wiring and see what you find.
__________________

Reply With Quote
  #13  
Old 06-14-2018, 07:04 AM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default

Quote:
Originally Posted by DAVe3283 View Post
From what I have seen of most radio's protection circuits, if there is a short on any one speaker, ALL speakers are turned off to protect the radio. The interface module could be the problem, and if it isn't, try disconnecting the speakers one at a time as close to the head unit as possible.

Or just take a multimeter and measure the resistance of all the speakers at the connector to the head unit. They should all be the same value, probably 4 or 8 ohms. If one is different from the rest, trace that wiring and see what you find.
Will do, thank you!
__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography
Reply With Quote
  #14  
Old 06-15-2018, 03:23 PM
turndriverside's Avatar
turndriverside turndriverside is offline
Gearhead
 
Join Date: Jul 2012
Location: Litchfield Park, AZ
Posts: 32

Default

Checking the speaker wires with the ohm setting turned out to be the trick, all the speaker wires expect for the back rear we’re coming back with a 4.0, I took the rear right door panel off and bam.

Thanks guys!

__________________
Sebastian | turndriverside@gmail.com | http://TurnDriverSide.com - Motorsports Photography
Reply With Quote
  #15  
Old 06-15-2018, 05:03 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 3,030

Default

Junk chevys, my LLY plugs all shit the bed one by one on my LLY, I had to put new ends on.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles. Piston eater.

Wife's ride- 2016 Pearl white Legacy limited 3.6R

Rig ride/new DD-02' Black Eddie Bauer explorer 4.6, -180k, still sporting original trans, outlasted two Duramaxs.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:20 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors