Duramax Diesels Forum Truck of the Week
  #1  
Old 06-11-2019, 02:28 PM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default 2007 LLY prime issues

Got an 07 lly van here that will only start and run for couple seconds. It will only start after letting the factory lift pump run for a second. It then starts and rail pressure never reaches desired and it then stalls. Will do this repeatedly.
I pulled the supply line off at the engine and ran the pump and it pumps fuel. Not crazy amounts but pumps it steady. Any ideas of how to further diagnose? I would lean towards cp3 after seeing the fuel its pumping. I might run a can of fuel to the engine fitting to eliminate the lines and filters and see if the cp3 will pull a prime by itself. Of course they bring it with the batteries drained down all the way....

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #2  
Old 06-11-2019, 02:49 PM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

I'll add that the van has only 89k on odo. And this problem come up after sitting and not running all winter, stored inside.

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #3  
Old 06-11-2019, 03:56 PM
DAVe3283's Avatar
DAVe3283 DAVe3283 is online now
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 3,053

Default

If you pop the return line off, how much total return fuel after cranking/starting/dying? Either the CP3 isn't able to move enough fuel (bad CP3), or it can move enough fuel but it is getting returned too fast (injectors, CP3, FPRV). Or there is a restriction somewhere, but that seems unlikely if it ran fine when parked.
__________________

Reply With Quote
  #4  
Old 06-11-2019, 04:35 PM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 1,804

Default

Have you tried it with the regulator unplugged?
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #5  
Old 06-11-2019, 05:42 PM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

Quote:
Originally Posted by 2004LB7 View Post
Have you tried it with the regulator unplugged?
Not yet.

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #6  
Old 06-12-2019, 04:38 AM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

It will not start at all with the return line removed. But the lift pump pushes fuel out both the 1/2" supply and the 3/8" return lines. The returning fuel from the pump & injectors combined while cranking is just a dribble.
Could of swore I smelled gasoline in the first bottle of fuel so I took another sample and now I cant smell gas...

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #7  
Old 06-12-2019, 04:40 AM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

And if I feather the throttle I can get it to run roughly at 1600ish frp. Just for a few seconds longer. Has a p0087 set. I guess I'd start with a cp3?

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #8  
Old 06-12-2019, 07:06 AM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

Just ruled out the prv too. no fuel out its hose at all.

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #9  
Old 06-12-2019, 07:18 AM
DAVe3283's Avatar
DAVe3283 DAVe3283 is online now
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 3,053

Default

Quote:
Originally Posted by ikeG View Post
It will not start at all with the return line removed.
That's odd. Not 100% sure what to make of that.

It is sounding more and more like the CP3. Though like 2004LB7 said, you should try it without the regulator plugged in to see what it does.
__________________

Reply With Quote
  #10  
Old 06-12-2019, 08:08 AM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

I know it's pretty straightforward diagnosis on pickups but this factory lift pump has me guessing. Why would it pump fuel out both return and supply. I am able to block off the return side and stop the flow, so maybe it just keeps slight pressure on the return circuit. Kinda like piezo injectors.
And there's the ecm control of the lift pump. It runs at first key on, but when it is commanded to quit, it will not start running again for almost a minute of key off.

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #11  
Old 06-12-2019, 09:49 AM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 1,804

Default

Can you jump out the relay to the LP to keep it running?
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #12  
Old 06-12-2019, 12:50 PM
DAVe3283's Avatar
DAVe3283 DAVe3283 is online now
Heavy & Slow



 
Join Date: Sep 2009
Location: Boise, ID, USA
Posts: 3,053

Default

I am not familiar with the factory lift pump, but if it is anything like my AirDog or any other return style regulated lift pump, it will send excess fuel out the return. The factory return line is very small, so it will try to push out everywhere, not just back to the tank. My truck does the same thing, if I turn on the AirDog, it pushes a few PSI into the return with no demand on the main line.
__________________

Reply With Quote
  #13  
Old 06-12-2019, 12:59 PM
ikeG's Avatar
ikeG ikeG is offline
Oughta Know Better
 
Join Date: Apr 2011
Location: Western PA
Posts: 1,971

Default

Quote:
Originally Posted by DAVe3283 View Post
I am not familiar with the factory lift pump, but if it is anything like my AirDog or any other return style regulated lift pump, it will send excess fuel out the return. The factory return line is very small, so it will try to push out everywhere, not just back to the tank. My truck does the same thing, if I turn on the AirDog, it pushes a few PSI into the return with no demand on the main line.
That is what I suspect

Sent from my SM-G960U using Tapatalk
__________________
Isaac Griffith, formerly 04jimc
03 Chev CC SB ZF6-Gone
04 GMC CC SB SLT LLY
597/1096 Batmostocker-Gone

06 GMC CC DRW-Gone
08 GMC CC DRW-Gone
New DD/Beater: Beat up 06 GMC CCSB w/ 252,000 miles
Current Tow Rig-12 Ram 4500 Crew


'Oughta K
now Better'- PPL Lim Pro Stock 05 3500 Crew Cab 158" WB 2014 PPP 2.6 Champions
Thanks to Blackout Performance

Reply With Quote
  #14  
Old 06-12-2019, 06:01 PM
Tothemax's Avatar
Tothemax Tothemax is offline
xgmtech
 
Join Date: Oct 2014
Location: new york
Posts: 503

Default

i had the same problem with my brother 08 van. if you jump the lift pump to stay running it will probably keep the engine running. mine need a cp3. almost as if the suction side of the cp3 went bad
__________________
2017 l5p cc/sb ltz z71 (stormtrooper edition)


06 lbz ec/sb. stock motor, Danville 4094s2r, built trans by me, limitless 1078 converter, 60% sticks, S&S 12mm pump. dyno tuned by mark @ Danville. 775hp 1383ftlb

best so far. 11.440 @ 118.12 1.623 60ft

06 lbz rc/fb dually work truck. Danville tuned
Reply With Quote
  #15  
Old 06-12-2019, 09:10 PM
THEFERMANATOR's Avatar
THEFERMANATOR THEFERMANATOR is offline
LEGALLY INSANE
 
Join Date: Feb 2009
Location: ZEPHYRHILLS, FL
Posts: 3,705
Default

The van does not use a lift pump, it is a prime pump from what I have gathered. It only runs before cranking to purge the air out for filter changes. It does not run when the engine is running. Check it for air leaks. My bet is your sucking air. The purge pump pushes the air out, it starts, then shuts off once it sucks air again. Jump the pump to stay on and see if it will stay running, if it does, then you know you're sucking air, or have a massive fuel restriction that the cp3's pump can't pull through. And the factory pump can move some fuel. I know somebody that used one as a lift pump, and he said it pumped alot of fuel(was just too noisy).
__________________
1995 GMC 2500 SUBURBAN powered by 01 DURAMAX/ALLISON, little of this, a little of that,
DIAMONDEYE 4" exhaust, CORSA muffler, AFE stage 1 dry filter, custom tuning by me, KENNEDY single pump and pump rub kit.

Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:54 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors