Duramax Diesels Forum Truck of the Week
  #31  
Old 09-11-2019, 12:49 PM
dmaxfireman's Avatar
dmaxfireman dmaxfireman is offline
'Can do' kind of guy
 
Join Date: Apr 2007
Location: CT
Posts: 2,465

Default

Does the truck have a lift pump?
__________________
-Fireman
Reply With Quote
  #32  
Old 09-17-2019, 09:02 PM
MadMax17 MadMax17 is offline
Gearhead
 
Join Date: Mar 2015
Location: maricopa, az
Posts: 63
Default

No mention of engine grounds yet, did you properly ground the engine when you installed? Sometimes these ground strap bolts get left loose after lightly threading it in during install and forgetting to tighten, I have seen this a few times. Sounds like you have covered just about everything else at this point, could be something simple overlooked during install. Should be a ground cable/strap at each side of the block toward the front as well as a braided strap going to the drivers side cylinder head below the GPCM.
__________________
06 LBZ - Bolt on's, EFI by me, 4" TC lift/35's
Reply With Quote
  #33  
Old Yesterday, 11:16 AM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Sorry for the late reply, I’ve been out of town but I did manage to get my hands on a good known ecm and no change. I also replaced all 8 injector pigtails no change. I installed a FASS fuel pump. No change or leaks present. Also I have been over every ground a couple times I Just forgot to mention that part.
I did however get it to idle. But it has what sounds like a hard fuel knock and is now throwing the p0336 consistently. If I hold the rpms right above the knocking point I can get it to an idle by very very slowly lowering rpms. If I drop the rpms fast it dies.
At idle cutting out every injector individually makes it die. Injector balance rates are good. Desired and actual fuel pressure are still good.
At this point I’m not inclined to think it’s a fuel problem but everything checks out on the ckps wiring and I’ve replaced the crank sensor twice. 3 different ecm’s etc.
does anyone know if a lmm reluctor wheel would be clocked different than an lbz? I know the tooth count is correct and the sensor is sending a signal.
Reply With Quote
  #34  
Old Yesterday, 11:35 AM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 16,016

Default

Where did you get the injectors from? your balance rates arent going to tell you much unless you are looking at main fuel rate as well.

this all really sounds like an injector issue to me.

Did you actually verify the reluctor wheel is not loose in there?
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LB7, LLY, LBZ, LMM, LML, L5P 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #35  
Old Yesterday, 04:30 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

I’m about 90% sure it’s not injectors. All 8 were replaced with gm oem injectors right from the dealer and the truck had the issue before the new injectors but hey who knows. And yes the reluctor wheel is tight.
The truck went to the dealer today... I’ll let you guys know what they find
Reply With Quote
  #36  
Old Yesterday, 06:19 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 16,016

Default

Unfortunately, all we can do is base our answers off what we are told and I think thatís about ran its course. Probably best it went there and Iím not saying that in a bad way. Hell of an effort on it!
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LB7, LLY, LBZ, LMM, LML, L5P 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:05 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors