Duramax Diesels Forum Truck of the Week
  #1  
Old 09-09-2019, 05:04 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default Help! Lbz wonít run under 1200 rpm

Hello, first time posting but Iíve been a lurker for quite some time. Iím working on an 06 lbz all stock other than cold air intake. I received this truck with the motor completely disassembled in the bed. I found out itís an lmm block with the rest off the lbz. I assembled the motor and was very thorough. Installed with new cp3, injectors, fuel filter housing. The issue at hand is the engine will not idle. There are no codes. I can get it to start and run if I hold it over 1200rpms and it sounds great. If you let it drop lower it starts fuel knocking like crazy until it dies. The actual and desired fuel pressure are well within spec and do not drop when it dies. Ive tested return rates on the new injectors and they are good. Iíve ran clear lines to verify itís not sucking air. Iíve even vacuum tested the entire fuel system broken down into sections and all are ok. We drained the fuel and filled with fresh diesel.
Weíve compression tested, all cylinders ok. Checked the valve adjustment again. I know Iíve done more but at this point Iím out of ideas. Also it has no tuner. The ecm is stock.
Any thoughts, ideas or crystal balls would be greatly appreciated.
Reply With Quote
  #2  
Old 09-09-2019, 05:19 PM
TheBac's Avatar
TheBac TheBac is offline
Why do I keep doing this?


 
Join Date: Apr 2008
Location: Mid Michigan
Posts: 12,589

Default

Moved to LBZ section.
__________________
Tom
"BBT" -- 2003 GMC CC/SB 4x4 12.14@111.15
"The Cruzer" -- 2014 Chevy Cruze Diesel -- the DD
"Kleshay" -- 2000 C5 Corvette -- the toy

Marlene (Molly) Bacon -- 1936 - 2019 -- RIP Mom You're already missed, at home and on the piano.

Two wrongs dont make a right, but three rights do make a left.
Reality is a matter of perspective.
This forum isn't for the weak of heart.....or wallet.
"Lets build a race car they said. Itll be fun they said. I don't know who "they" are.........but they need a good punch in the face!" -- mufflerguy (yb)
Reply With Quote
  #3  
Old 09-09-2019, 05:22 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Thanks I wasn’t sure where to post.
Reply With Quote
  #4  
Old 09-09-2019, 06:17 PM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 3,395

Default

What injectors were used
__________________
2008 GMC duramax crew cab short bed 2500.
10.98@124mph

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #5  
Old 09-09-2019, 06:33 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Thank you for the reply, all 8 oem GM injectors. I forgot to mention the cp3 and injectors were replaced after the motor install. The problem was present before the injector and cp3 replacement and they made no difference.
Reply With Quote
  #6  
Old 09-09-2019, 07:55 PM
juddski88's Avatar
juddski88 juddski88 is offline
Freedom Diesel
 
Join Date: Jul 2008
Location: Chesterfield, Mass.
Posts: 4,216

Default

Quote:
Originally Posted by Unlimitedauto View Post
Thank you for the reply, all 8 oem GM injectors. I forgot to mention the cp3 and injectors were replaced after the motor install. The problem was present before the injector and cp3 replacement and they made no difference.
Sounds like if you ruled out hydraulics, I'd be looking into the individual injector connectors, and the injector wiring harness.
__________________
2001 Chevy 2500HD ECSB
"Sore Subject" - Still don't have time for it.
I would never have learned what I have without George Alexander, Mike Lovrich, David Browning, Matt Handwork, Ben Tyler, Evan Drosehn and countless members of this forum and others.
Thank you.

2014 Jeep Grand Cherokee Limited, Ecodiesel
Reply With Quote
  #7  
Old 09-10-2019, 06:39 AM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Juddski88- do you think I could have a wiring issue with no codes? I just inspected every injector connector and as much wiring as I could. Also when I had the engine out I inspected the engine harness as best as I could. Nothing obvious was found.
Thanks!
Reply With Quote
  #8  
Old 09-10-2019, 06:46 AM
juddski88's Avatar
juddski88 juddski88 is offline
Freedom Diesel
 
Join Date: Jul 2008
Location: Chesterfield, Mass.
Posts: 4,216

Default

Quote:
Originally Posted by Unlimitedauto View Post
Juddski88- do you think I could have a wiring issue with no codes? I just inspected every injector connector and as much wiring as I could. Also when I had the engine out I inspected the engine harness as best as I could. Nothing obvious was found.
Thanks!
A common problem is loose terminals in the harness connectors at the injectors. Not so common with the lbz and newer but it still happens. Normally it should code, but it might not. Try unplugging each injector one at a time to see it the rattle stops. If you have a good diag tool, use a dvt function to shut each one off.
__________________
2001 Chevy 2500HD ECSB
"Sore Subject" - Still don't have time for it.
I would never have learned what I have without George Alexander, Mike Lovrich, David Browning, Matt Handwork, Ben Tyler, Evan Drosehn and countless members of this forum and others.
Thank you.

2014 Jeep Grand Cherokee Limited, Ecodiesel
Reply With Quote
  #9  
Old 09-10-2019, 07:12 AM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

I do have a snapon Apollo scan tool which will disable injectors individually, however there is no difference with any of the cylinders cut out and I can’t run a cylinder contribution balance test because it won’t idle.
Is it possible I’m chasing the wrong area? Could this be a boost issue? Or does it sound more fuel related?
Again thanks for the reply!
Reply With Quote
  #10  
Old 09-10-2019, 07:44 AM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Posts: 13,202

Default

Does the engine run clean and smooth at or above 1200 rpm? Are the injectors brand new from GM or did you get them used or from a second hand source? Does the engine still have a functioning EGR valve on it?
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
  #11  
Old 09-10-2019, 08:17 AM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Yes it runs smooth like there’s no problem at all if it’s over 1200 rpm. The injectors are new from the dealership and the egr is there and functioning. I cleaned it thoroughly before install as well.
Reply With Quote
  #12  
Old 09-10-2019, 08:26 AM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Posts: 13,202

Default

Can you unbolt the cast intake pipe that runs across the top of the EGR valve and see if the engine will idle with the intake open like that? Just be careful nothing falls down in there while it is running.
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
  #13  
Old 09-10-2019, 02:00 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Doing that now. I’ll let you know how it goes
Reply With Quote
  #14  
Old 09-10-2019, 03:31 PM
Unlimitedauto Unlimitedauto is offline
FNG
 
Join Date: Aug 2019
Posts: 15
Default

Pulled that intake piece and it made no difference. Any other ideas?
Reply With Quote
  #15  
Old 09-10-2019, 04:48 PM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Posts: 13,202

Default

Do you have another rail pressure sensor you can swap in or a different ECM you can test it with?
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors