Duramax Diesels Forum Truck of the Week
  #1  
Old 09-11-2019, 04:49 AM
dzimbric's Avatar
dzimbric dzimbric is offline
Gearhead
 
Join Date: Oct 2015
Location: Shallotte, NC
Posts: 61

Default Trailer Brake & Parking assist fault

I keep getting a Trailer Brake Service fault, intermittently the fault clears and the brakes work. It’s really annoying when towing weight. I have replaced the brake control relay and the tail light circuit board and cleaned the connectors.
Is there another connector between the controller on the dash and the brake relay.
It happens with all of my trailers and even shows when no trailer is connected. I also have had the “Service Park Assist” fault for awhile but just ignore because I am normally pulling a trailer.

Any advice is appreciated.
__________________

2008 K2500HD CC/SB
7-9 inch Cognito Lift, Cold Air Intake. 4 inch exhaust, dsp5 tune by Diesel Addiction (Thanks Dustin), 35" Michelin Defenders on 20 Inch Ultra Spline Rims

'56 C6500 w/tilt
Reply With Quote
  #2  
Old 09-11-2019, 07:26 AM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 16,091

Default

are you running a lift pump?
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LB7, LLY, LBZ, LMM, LML, L5P 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #3  
Old 09-11-2019, 08:37 AM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 1,997

Default

Behind the rear bumper is another connector. Mine was full of dirt and junk
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.

2006 BRM Jetta TDI. Injectors, turbo, Malone custom tuning on ecm and tcm
Reply With Quote
  #4  
Old 09-11-2019, 09:08 AM
TheBac's Avatar
TheBac TheBac is offline
Why do I keep doing this?


 
Join Date: Apr 2008
Location: Mid Michigan
Posts: 12,641

Default

Moved to Towing Section.
__________________
Tom
"BBT" -- 2003 GMC CC/SB 4x4 12.14@111.15
"The Cruzer" -- 2014 Chevy Cruze Diesel -- the DD
"Kleshay" -- 2000 C5 Corvette -- the toy

Marlene (Molly) Bacon -- 1936 - 2019 -- RIP Mom You're already missed, at home and on the piano.

Two wrongs dont make a right, but three rights do make a left.
Reality is a matter of perspective.
This forum isn't for the weak of heart.....or wallet.
"Lets build a race car they said. Itll be fun they said. I don't know who "they" are.........but they need a good punch in the face!" -- mufflerguy (yb)
Reply With Quote
  #5  
Old 09-11-2019, 11:55 AM
Ron Nielson Ron Nielson is offline
Hotrodder
 
Join Date: Oct 2009
Location: Berryton, KS
Posts: 150
Default

When you say you are getting a 'fault', are you referring to a message on the DIC? Or a check engine light that has a DTC associated with it? or ?? And this is for your 2008 truck in your signature?
__________________
Ron Nielson

2008 Chevy Silverado LT, SRW, Crew Cab, LB, LMM/Allison, Rear lowered 2": otherwise, fully stock at this point. Edge Insight CTS
Reply With Quote
  #6  
Old 09-11-2019, 05:02 PM
dzimbric's Avatar
dzimbric dzimbric is offline
Gearhead
 
Join Date: Oct 2015
Location: Shallotte, NC
Posts: 61

Default

Quote:
Originally Posted by Ron Nielson View Post
When you say you are getting a 'fault', are you referring to a message on the DIC? Or a check engine light that has a DTC associated with it? or ?? And this is for your 2008 truck in your signature?
It is for the vehicle in my sig line. I am getting “Service Trailer Brakes’ message on the DIC. I get it with and without the trailer being connected. I replaced the brake light circuit board located behind the bumper and the brake relay located next to the fuel tank on the frame. It may be a loose connection because it was coming back in today with no trailer connected when I would hit a bump.

Suggestions?
__________________

2008 K2500HD CC/SB
7-9 inch Cognito Lift, Cold Air Intake. 4 inch exhaust, dsp5 tune by Diesel Addiction (Thanks Dustin), 35" Michelin Defenders on 20 Inch Ultra Spline Rims

'56 C6500 w/tilt
Reply With Quote
  #7  
Old 09-11-2019, 05:05 PM
dzimbric's Avatar
dzimbric dzimbric is offline
Gearhead
 
Join Date: Oct 2015
Location: Shallotte, NC
Posts: 61

Default

Quote:
Originally Posted by 2004LB7 View Post
Behind the rear bumper is another connector. Mine was full of dirt and junk
I chaged it. No success.
__________________

2008 K2500HD CC/SB
7-9 inch Cognito Lift, Cold Air Intake. 4 inch exhaust, dsp5 tune by Diesel Addiction (Thanks Dustin), 35" Michelin Defenders on 20 Inch Ultra Spline Rims

'56 C6500 w/tilt
Reply With Quote
  #8  
Old 09-11-2019, 05:05 PM
dzimbric's Avatar
dzimbric dzimbric is offline
Gearhead
 
Join Date: Oct 2015
Location: Shallotte, NC
Posts: 61

Default

Quote:
Originally Posted by Chevy1925 View Post
are you running a lift pump?
No
__________________

2008 K2500HD CC/SB
7-9 inch Cognito Lift, Cold Air Intake. 4 inch exhaust, dsp5 tune by Diesel Addiction (Thanks Dustin), 35" Michelin Defenders on 20 Inch Ultra Spline Rims

'56 C6500 w/tilt
Reply With Quote
  #9  
Old 09-15-2019, 02:36 PM
dzimbric's Avatar
dzimbric dzimbric is offline
Gearhead
 
Join Date: Oct 2015
Location: Shallotte, NC
Posts: 61

Default

Does anyone know what the module located next to the trailer brake relay does? It is mounted on the frame behind the fuel tank and has a weird plug that I can’t get apart. Also how do you get the plug off?
__________________

2008 K2500HD CC/SB
7-9 inch Cognito Lift, Cold Air Intake. 4 inch exhaust, dsp5 tune by Diesel Addiction (Thanks Dustin), 35" Michelin Defenders on 20 Inch Ultra Spline Rims

'56 C6500 w/tilt
Reply With Quote
  #10  
Old 09-16-2019, 07:16 AM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Posts: 13,226

Default

Quote:
Originally Posted by dzimbric View Post
Does anyone know what the module located next to the trailer brake relay does? It is mounted on the frame behind the fuel tank and has a weird plug that I can’t get apart. Also how do you get the plug off?
That is the trailer brake control module. I just changed it on my dad's 08 dually because he was having intermittent service trailer brake messages, and diagnostics indicated that it was the problem. The new one is still giving those messages though... I remember the plug being a pain, but I don't remember exactly how it unlatched.
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
  #11  
Old 09-16-2019, 09:19 AM
Ron Nielson Ron Nielson is offline
Hotrodder
 
Join Date: Oct 2009
Location: Berryton, KS
Posts: 150
Default

A new trailer brake control module, which mounts right next to the trailer brake relay, must be programmed. A quick trip to the dealer, or independent garage, is in order. If the module was your problem, you may have a working, error free trailer braking system. If the problem lies elsewhere, you may still have problems.
__________________
Ron Nielson

2008 Chevy Silverado LT, SRW, Crew Cab, LB, LMM/Allison, Rear lowered 2": otherwise, fully stock at this point. Edge Insight CTS
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vB.Sponsors