Duramax Diesels Forum

Duramax Diesels Forum (https://www.duramaxdiesels.com/forum/index.php)
-   Introductions (https://www.duramaxdiesels.com/forum/forumdisplay.php?f=27)
-   -   LB7: P0087 low rail pressure need help (https://www.duramaxdiesels.com/forum/showthread.php?t=60322)

dbdoug 08-16-2014 10:57 AM

P0087 low rail pressure need help
 
I have a 2003 GMC Sierra with LB7 . code P0087 will set when engine is warm and stopping at a traffic light, goes into limp mode till codes are reset. Engine seems to be down on power. The truck starts without any problems. I have changed the FRP Sensor and the FPR. I've removed fuel tank and inside was spotless. Replaced all hoses on low pressure side along with new filter and WIF sensor. checked for air leaks and tried adding a lift pump. When trying to command high fuel pressure the actual pressure doesn't change at all. Fuel pressure does go up as throttle increases and is slightly below desired pressure ( about 1,000-1,500 psi)

bn07classic 08-17-2014 02:15 AM

Since you seemed to have addressed all the common areas, my guess would be the CP3.

1ATony 08-19-2014 11:39 AM

Welcome to the site.
Tony

sirmatthewt 06-11-2018 12:20 PM

Mirrors my symptoms
 
Quote:

Originally Posted by dbdoug (Post 844504)
I have a 2003 GMC Sierra with LB7 . code P0087 will set when engine is warm and stopping at a traffic light, goes into limp mode till codes are reset. Engine seems to be down on power. The truck starts without any problems. I have changed the FRP Sensor and the FPR. I've removed fuel tank and inside was spotless. Replaced all hoses on low pressure side along with new filter and WIF sensor. checked for air leaks and tried adding a lift pump. When trying to command high fuel pressure the actual pressure doesn't change at all. Fuel pressure does go up as throttle increases and is slightly below desired pressure ( about 1,000-1,500 psi)


These symptoms mirror what my LB7 is doing right now. Will drive fine for 15-20 min then codes P0087 at a stop light and usually goes into limp mode. Never codes under load. Starts fine and runs fine when codes are clear, maybe down on power a little and EGT's seem high for the relative rpm and boost, and after driving for a few minutes I can't idle the EGT's down below about 350-375 degrees. Idles fine no haze no smoke. Filter plunger stays firm and doesn't suck down. I've changed the filter, the two filter head hoses, siphoned and swapped out most of the diesel, and straightened a kink in the 1/2 supply back by the fuel cooler.

OP, did you figure out your solution? Anyone else have any thoughts? I lean toward a weak fuel pressure relief valve. For $40 I think I'll order a race plug and plug it. Leaky WIF plug maybe? Leaky bleeder screw?

Bdsankey 06-11-2018 12:30 PM

Quote:

Originally Posted by sirmatthewt (Post 1105122)
These symptoms mirror what my LB7 is doing right now. Will drive fine for 15-20 min then codes P0087 at a stop light and usually goes into limp mode. Never codes under load. Starts fine and runs fine when codes are clear, maybe down on power a little and EGT's seem high for the relative rpm and boost, and after driving for a few minutes I can't idle the EGT's down below about 350-375 degrees. Idles fine no haze no smoke. Filter plunger stays firm and doesn't suck down. I've changed the filter, the two filter head hoses, siphoned and swapped out most of the diesel, and straightened a kink in the 1/2 supply back by the fuel cooler.

OP, did you figure out your solution? Anyone else have any thoughts? I lean toward a weak fuel pressure relief valve. For $40 I think I'll order a race plug and plug it. Leaky WIF plug maybe? Leaky bleeder screw?

A leaking relief valve won't show up at idle. My bets would be towards a weak pump not liking hot fuel. As the vehicle speed increases airflow over the fuel cooler picks up and intern drops fuel temps.


All times are GMT -7. The time now is 07:11 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors