Duramax Diesels Forum Truck of the Week
  #1  
Old 01-30-2012, 01:43 PM
millerman04's Avatar
millerman04 millerman04 is offline
< The Man Cave
 
Join Date: Jul 2010
Location: Clearville, Pa
Truck: EC/SB 4x4
Engine: LB7
Transmission: Automatic
Posts: 969
Default Oil Pressure Sending Unit

A buddy of mine needs help on his father in laws truck. Its an 03 or 04 i think. Needs a location of the oil pressure sending unit. And also the oil gauge operates out of the numbers range. Instead of reading in the numbers while running, it goes past the numbers and comes around underneath the tick marks of the gauge. Any ideas? Thanks!!
__________________
2003 LB-7, ECSB Dark Charcoal Metallic, 285-75-16 AT2 Generals, Moto Metal Black 951's, Bull-Bar, Auto meters, EFI Live Tuned by DA with DSP5, Banks Air Intake, Profab Proflow Air Horn, AIR Dog 2, 4inch Silverline duals, tinted windows, Super Diesel Straight Centerlink, Super Diesel Sleves, Air Bagged Rear, Cranked Torsion Bars, IH Red Traction Bars.


http://creaturesofthenightperformance.com
Reply With Quote
  #2  
Old 01-30-2012, 01:52 PM
02greysixer's Avatar
02greysixer 02greysixer is offline
Hotrodder
 
Join Date: Jun 2011
Location: North Central FL
Truck: CC/SB
Engine: LLY
Transmission: Automatic
Posts: 1,184

Default

Drivers side front, behind and under the power steering pump. Sounds to me like a cluster issue though.


Sint frum tha orijinul smert fone
__________________
2005 lly Silverado 4x4 crew
Rear lowered 2.5"
Front raised 1"
285/75/16 Nitto all terrains
single 4" turbo back straight pipe
FASS 150 pump and filters
Shimmed FPRV
EFILive tuned by me
Pissed off stock trans
Reply With Quote
  #3  
Old 01-30-2012, 02:03 PM
millerman04's Avatar
millerman04 millerman04 is offline
< The Man Cave
 
Join Date: Jul 2010
Location: Clearville, Pa
Truck: EC/SB 4x4
Engine: LB7
Transmission: Automatic
Posts: 969
Default

That's what i thought too. But i guess it's called covering all the bases and getting the info first.
__________________
2003 LB-7, ECSB Dark Charcoal Metallic, 285-75-16 AT2 Generals, Moto Metal Black 951's, Bull-Bar, Auto meters, EFI Live Tuned by DA with DSP5, Banks Air Intake, Profab Proflow Air Horn, AIR Dog 2, 4inch Silverline duals, tinted windows, Super Diesel Straight Centerlink, Super Diesel Sleves, Air Bagged Rear, Cranked Torsion Bars, IH Red Traction Bars.


http://creaturesofthenightperformance.com
Reply With Quote
  #4  
Old 01-30-2012, 02:09 PM
jmg343's Avatar
jmg343 jmg343 is offline
Gearhead
 
Join Date: Sep 2006
Location: NY
Engine: LLY
Transmission: Automatic
Posts: 33
Default

My truck just started doing the exact same thing. Gauge has returned to normal operation but EFI Live is giving me strange readings on oil pressure.
__________________
Jake G.
04.5--12 sec. LLY, same mods as everyone else, stock turbo, injectors, motor, yadda yadda yadda
Reply With Quote
  #5  
Old 01-30-2012, 04:31 PM
fishsmith's Avatar
fishsmith fishsmith is offline
Hotrodder

 
Join Date: May 2008
Location: Monroe, LA
Truck: chevy ccsb 4x4
Engine: lmm
Transmission: Automatic
Posts: 1,439

Default

We got a lmm that reads 0 all the time. Snap on modis also reads 0 we have changed just about everything related to the oil pressure and always get zero. Gauges checked out fine through modis
__________________
Jeremy--
Reply With Quote
  #6  
Old 01-30-2012, 05:49 PM
duratothemax's Avatar
duratothemax duratothemax is online now
<--- slippery roads
 
Join Date: Aug 2006
Location: Wyoming
Truck: duh
Engine: duh
Posts: 7,504
Default

Quote:
Originally Posted by 02greysixer View Post
Drivers side front, behind and under the power steering pump.
Yes that might be where the sensor is on a 2001-2002 truck.............but the original poster has a 2003.

To the OP- your oil pressure sensor is actually towards the back of the block, driver side, just ahead of the oil cooler/filter base, under the coolant tube that goes from the water pump to the oil cooler. Its somewhat difficult to get to, and you'll need a large deep socket to change it.

And also, dont buy a sensor for a 2001-2002 duramax. They are completely different from the 2003-2012 sensors.
__________________
2005 chevy dmax/allison - "HOT AND DANGEROUS" - built engine and trans with parts/advice/help from the best...MikeL.Trippin.Schulte.IdahoRob.TimHecker-St.JoeDiesel.McRat.juddski.dmaxfireman.BigDipper.M PI.Bobo.GMC-2002-DMAX.fingers.RickDLance.dmaxalliTech.EFILive...sor ry no times yet, I just wanted to reserve the truck-name

BT DieselWorks, LLC - Full transmission/engine builds - EFILive tuning - full service for GM gas/diesel trucks and SUVs - Allison lockup controllers - Allison tapshift kits - dmax/alli/GM gasser standalone harnesses - custom truck electronic gadgets

All products available for sale through our online store at www.btdieselworks.com

Be sure to "like" us on Facebook at www.facebook.com/BTDWorks
Reply With Quote
  #7  
Old 01-30-2012, 06:33 PM
02greysixer's Avatar
02greysixer 02greysixer is offline
Hotrodder
 
Join Date: Jun 2011
Location: North Central FL
Truck: CC/SB
Engine: LLY
Transmission: Automatic
Posts: 1,184

Default

Quote:
Originally Posted by duratothemax View Post
Yes that might be where the sensor is on a 2001-2002 truck.............but the original poster has a 2003.

To the OP- your oil pressure sensor is actually towards the back of the block, driver side, just ahead of the oil cooler/filter base, under the coolant tube that goes from the water pump to the oil cooler. Its somewhat difficult to get to, and you'll need a large deep socket to change it.

And also, dont buy a sensor for a 2001-2002 duramax. They are completely different from the 2003-2012 sensors.
My mistake. . Got it half right anyway.


Sint frum tha orijinul smert fone
__________________
2005 lly Silverado 4x4 crew
Rear lowered 2.5"
Front raised 1"
285/75/16 Nitto all terrains
single 4" turbo back straight pipe
FASS 150 pump and filters
Shimmed FPRV
EFILive tuned by me
Pissed off stock trans
Reply With Quote
  #8  
Old 01-30-2012, 06:42 PM
blk smoke lb7's Avatar
blk smoke lb7 blk smoke lb7 is online now
<-----Lots of green $
 
Join Date: Nov 2010
Location: belvidere,ill
Truck: cc/sb
Engine: lb7
Transmission: Automatic
Posts: 6,373
Default

I thought i was having oil gauge issuse so i took 1 of the oil plugs out of the side of the block and installed a mechanical gauge.drilled the plug which is 14 mm and tapped it for 1/8 pipe thread works great
__________________
04 LB7 CC/SB EFI live, S366,S483 , Born again 08/10/2011 11.64@117
Some wicked tuning by Bo-Bo (Bob olson) Thx Bob

Quote:
Originally Posted by flyinelvis11
i'll let you use anything i got except my wife and my truck; it's too easy to throw a rod in either one):h
Quote: Carter 44
Boost is like a hot girl with an STD...you know you want to hit it but your afraid of the consequences
rollncoal07:Twining is wining
Quote:
Originally Posted by McRat View Post

You come off as a Timeshare Condo salesman on this site.

If you were helping folk with problems, or asking for input on your problems, it might be different, but from where I see, you are only a little different than the Russian spammers selling iPads that we delete.

Act like more of a human, and less like a spambot, and you'd probably catch less heat. This is "family", and it's our corner bar, and a group of guys with grease all over them leaning over fenders of somebodies truck that ain't making the right boost.

It's also one of few sites with more hardcore wrenches and racers than wannabees.

You're welcome to be a member here, and post about your build, but don't expect people to shower you with roses yet. That comes with seat time on the site, and on the track.
Reply With Quote
  #9  
Old 01-31-2012, 07:24 AM
millerman04's Avatar
millerman04 millerman04 is offline
< The Man Cave
 
Join Date: Jul 2010
Location: Clearville, Pa
Truck: EC/SB 4x4
Engine: LB7
Transmission: Automatic
Posts: 969
Default

Thanks guys!!! Seems like a common failure? Is there much difference in oil pressure readings between gauges blk smoke lb7?
__________________
2003 LB-7, ECSB Dark Charcoal Metallic, 285-75-16 AT2 Generals, Moto Metal Black 951's, Bull-Bar, Auto meters, EFI Live Tuned by DA with DSP5, Banks Air Intake, Profab Proflow Air Horn, AIR Dog 2, 4inch Silverline duals, tinted windows, Super Diesel Straight Centerlink, Super Diesel Sleves, Air Bagged Rear, Cranked Torsion Bars, IH Red Traction Bars.


http://creaturesofthenightperformance.com
Reply With Quote
  #10  
Old 01-31-2012, 07:36 AM
jmg343's Avatar
jmg343 jmg343 is offline
Gearhead
 
Join Date: Sep 2006
Location: NY
Engine: LLY
Transmission: Automatic
Posts: 33
Default

If anyone could post a pic of where on the block those 2 oil plugs are, it would be a big help and greatly appreciated. I can't honestly say that I have even looked for them yet, but then again I cant honestly say that I would recognize them and be sure that that was them if I were staring right at em.
__________________
Jake G.
04.5--12 sec. LLY, same mods as everyone else, stock turbo, injectors, motor, yadda yadda yadda
Reply With Quote
  #11  
Old 11-25-2013, 01:20 PM
yevoot yevoot is offline
FNG
 
Join Date: Nov 2013
Posts: 1
Default High oil reading

Quote:
Originally Posted by jmg343 View Post
My truck just started doing the exact same thing. Gauge has returned to normal operation but EFI Live is giving me strange readings on oil pressure.
Hey Jake, noticed your comment about a higher oil pressure rating after install of EFI live? Curious if you found a resolution to this, or did it manage to go away after a period of time? I have just done an install from a Superchips Flashpaq and noticed much the same finding. Thanks in advance!
Eric
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:07 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors