Duramax Diesels Forum Truck of the Week
  #1  
Old 04-26-2010, 06:01 PM
MMLMM's Avatar
MMLMM MMLMM is offline
Hotrodder

 
Join Date: Mar 2008
Location: Sin City, Nv.
Truck: Duramax
Engine: 402.6ci
Transmission: Automatic
Posts: 4,441

Default Rail pressure with 2 micron filter....

So I ditched the factory setup and went with my own setup by my lift pump (after it) I am running a 2 micron filter there. I noticed my rail pressure has been low but not sure if I am having lift pump issues again or not. I just swapped on a 12 micron baldwin to test so Ill see if that clears it up a bit later.

What are you guys seeing? 2 micron too little for getting enough fuel through?
__________________

2002 LB7 EC/SB
Fleece Cheetah, ARPs, LBZ CP3, Built Allison, AirDog 165, EFI Live Custom Tuning By Me, Lowering Shackles,
Original Toyo Proxies on 20" XD Spy's, S&B Intake, MagnaFlow DP & 4", and a few other gadgets and appearance mods
Reply With Quote
  #2  
Old 04-26-2010, 06:45 PM
dmaxlover's Avatar
dmaxlover dmaxlover is offline
Hotrodder
 
Join Date: Mar 2007
Location: WI
Transmission: Automatic
Posts: 477
Default

I'm running twin CP3s on my LB7, so not sure if my input will help or not. My Airdog 150 has a 2 micron filter on it, and it's the only filter I run. All the stock filtering is gone, and there is no issues with rail pressure, or lift pump pressure.
Reply With Quote
  #3  
Old 04-27-2010, 03:55 AM
GMC_2002_Dmax's Avatar
GMC_2002_Dmax GMC_2002_Dmax is offline
The Still Master
 
Join Date: Feb 2008
Location: East Coast
Truck: 2002 CC/SB/4x4
Engine: 6.6 Duramax/LB7
Transmission: Automatic
Posts: 1,634

Default

I have a 2 micron CAT filter on my truck and the stick filter ( 2002-LB7 ) with the Laing twin lift pumps.

On my biggest tune it will dip to 19,500 and recover to about 21,000 psi and hold steady.

I have not logged the LBZ with the AD-II/165 yet but as a side note my 2002 has 125K miles and since 7K miles it has had a 2 micron CAT filter on it and it still has original injectors.

I will take the 2 micron filter over a little lost rail PSI any day.

__________________
2012 Denali LML....NOT STOCK ANYMORE......

2007 GMC "Classic", LBZ, SLE1 ,RC/LB, 4x4
~Powered By "MOONSHINE"

12.525 at 107.07


2002-GMC Sierra 2500HD SLE/CC/SB/4X4~Powered By "MOONSHINE"
12.65 fuel only, 12.00 on some N20
Retired 04/18/2009...................SOLD 01/2014


Reply With Quote
  #4  
Old 04-27-2010, 04:37 AM
JOHNBOY's Avatar
JOHNBOY JOHNBOY is offline
< Rocking the Big Single!
 
Join Date: Aug 2006
Location: Saegertown, Pa
Truck: 02 GMC 2500HD
Engine: LB7
Transmission: Manual
Posts: 2,689

Default

I run a CAT(actually WIX) 2 micron filter after my lift pump (Holley HP150). Works great. Bad fuel will clog it in a hurry. What do you have for a lift pump? Have you check pressure after the filter idling? I know I loose almost 2 PSI thru a fresh filter. So if your running a setup with a built in regulator like the PPE then you probably need to up the pressure. I moved my regulator after so the filter gets full pressure.
__________________
The Big Stick
2002 GMC 2500HD Crewcab Long Bed LB7 ZF6 Southbend Triple Disk clutch, Alive with EFI Live from Mcrat Racing, Crower rods, LB7 cut pistons by JB, Cam and push rods by EEP 80% Extrudehone injectors, CP3 X 2, Socal Diesel Springs and Ti Retainers, A/C delete by JB


The wifes truck
2007 Classic Chevy Crewcab Shortbed LBZ 6speed Allison Loaded Basicly stock. Little EFI tune and a Trans Go Jr.
Reply With Quote
  #5  
Old 04-27-2010, 05:07 AM
skintback's Avatar
skintback skintback is offline
Take this one to church
 
Join Date: Mar 2007
Location: Florida
Truck: 05 Chevy CCSB 4x4
Engine: LLY
Transmission: Automatic
Posts: 985

Default

When i installed the AD i did away with the stock setup so i can't say what mine did for psi +/- but before that i ran a edelbrock 1792 with stock filter at 10-17 psi with no problems.

What is the filter # on the cat 2 micron and does it separate water? I'm looking to ditch my AD but i'v already did away with the stock filter so i'll need to get a new filter setup.
__________________
LLY CCSB 4x4
Howards rods
Lockup Box
66/71/16
2CP3's

Reply With Quote
  #6  
Old 04-27-2010, 05:45 AM
JoshH's Avatar
JoshH JoshH is offline
Daggum farm truck
 
Join Date: Feb 2007
Location: Texas!!!
Truck: 06 2500HD CC/SB
Engine: LBZ
Transmission: Automatic
Posts: 11,253

Default

Mike, didn't you ditch your factory filter too?
__________________
06 Silverado 4x4 CC/SB

06 Express 2500 Duramax Van "The Dumpster"


Reply With Quote
  #7  
Old 04-27-2010, 06:47 AM
BoiseRob's Avatar
BoiseRob BoiseRob is offline
Hotrodder
 
Join Date: Oct 2007
Posts: 194
Default

The new filters max flow is 50 gph...
Reply With Quote
  #8  
Old 04-27-2010, 07:17 AM
hondarider552's Avatar
hondarider552 hondarider552 is offline
Getting faster

 
Join Date: May 2008
Location: Arizona
Truck: SC/SB
Engine: Isuzu 6.6 LB7
Transmission: Automatic
Posts: 8,486

Default

im running the cat 2 micron and the stocker filter and I havent seen any rail pressure loss
__________________
2003 Chevy RC/LB.
10.57 @ 133.88 N2O
Mike L trans




2014 Cruze TD 2.0 DD
16.31 @ 87 #2
15.93 @90.8 N2O


Tailgate Crew Member #3
Reply With Quote
  #9  
Old 04-27-2010, 07:59 AM
sweetdiesel's Avatar
sweetdiesel sweetdiesel is offline
That's better
 
Join Date: Aug 2006
Location: Alberta Canada
Truck: 05 GMC 3500
Engine: lly & lb7
Transmission: Automatic
Posts: 13,719

Default

Mike it's all about the gph of the filter it has nothing to do with the micron rating

you can have a 2 micron that flows 500 gph or 5 gph
__________________
07 RC/LB 2wd
A/D lift pump,Tunes from Josh H, BD Manifold and custom up pipes, P&I supports, PPE tie rod sleeves

05 CC/LB
EFI ,A/D lift pump,Cognito 7"lift /P&I supports / Banks air and exaust /ARP head studs/ Mike L stage 4 trans / EPR twins.

Abby 01 RC/LB 10.28@144mph
Arias pistons/ Howards rods / S475 & PBK twin turbos from EPR/PPE 2 CP3 / SoCal stg 2 heads & cam / 100 over sticks /Socal flexplate & dampner & girdle /DPR oil pump / Lenco-bruno trans /BD intercooler / Ted at MPL / turbo blankets from Levi
Reply With Quote
  #10  
Old 04-27-2010, 09:12 AM
MMLMM's Avatar
MMLMM MMLMM is offline
Hotrodder

 
Join Date: Mar 2008
Location: Sin City, Nv.
Truck: Duramax
Engine: 402.6ci
Transmission: Automatic
Posts: 4,441

Default

I have the factory filter gone. I'm running the cat 2 micron. Yea ever thought about the actually filter flow. I honestly think its my piece o chit fass non filter pump. The pump used to read about 14psi at. Idle but I have since removed gauge when I ditched factory filter. I run quite a bit of duration in my tune. Anyone know some flow numbers for these 1-14 (thread size) filters like the cat? I drop to about 131mpa on the rail.
__________________

2002 LB7 EC/SB
Fleece Cheetah, ARPs, LBZ CP3, Built Allison, AirDog 165, EFI Live Custom Tuning By Me, Lowering Shackles,
Original Toyo Proxies on 20" XD Spy's, S&B Intake, MagnaFlow DP & 4", and a few other gadgets and appearance mods
Reply With Quote
  #11  
Old 04-27-2010, 10:30 AM
stacks04's Avatar
stacks04 stacks04 is offline
Hotrodder
 
Join Date: Nov 2007
Location: Terryville,Ct
Truck: 04 Chevy crew cab
Engine: duramax diesel 6.6
Transmission: Automatic
Posts: 800

Default

mike for what its worth, i just logged a wot run to check, i am running the a-d 150 and stock filters. i have not changed or checked the a-d pressure so i dont know what its at but on wot i drop down to 21k and recover to hold 22.5-23k. not a huge pulse but 2900ms. i command 170 mpa. hope this helps.
__________________
2004 CHEVY CREW CAB

Last edited by stacks04; 04-27-2010 at 10:31 AM.
Reply With Quote
  #12  
Old 04-27-2010, 01:17 PM
Burn Down's Avatar
Burn Down Burn Down is offline
Hotrodder
 
Join Date: Sep 2008
Location: Fairbanks Alaska
Truck: 04.5 CCSB Dmax
Engine: lly/lb7
Transmission: Automatic
Posts: 2,599

Default

Quote:
Originally Posted by MMLMM View Post
I have the factory filter gone. I'm running the cat 2 micron. Yea ever thought about the actually filter flow. I honestly think its my piece o chit fass non filter pump. The pump used to read about 14psi at. Idle but I have since removed gauge when I ditched factory filter. I run quite a bit of duration in my tune. Anyone know some flow numbers for these 1-14 (thread size) filters like the cat? I drop to about 131mpa on the rail.
What is the Cat part number on your filter? I'll see what I can come up with for a GPH.
Reply With Quote
  #13  
Old 04-27-2010, 01:27 PM
kjp800's Avatar
kjp800 kjp800 is offline
-
 
Join Date: Aug 2008
Location: New Jersey
Truck: 05 Chevy CCSB
Engine: LLY
Posts: 643
Default

Not to be off topic, but what filter heads are you guys using with the Cat filters? Are you getting them directly from Cat?
__________________
05 Chevy CCSB
02 GMC ECLB 2.6 puller
Reply With Quote
  #14  
Old 04-27-2010, 04:58 PM
Turbotug's Avatar
Turbotug Turbotug is offline
BEER SLAYER
 
Join Date: Sep 2006
Location: Phoenix
Truck: 04 GMC
Engine: THE LB7
Transmission: Automatic
Posts: 1,435

Default

I run three fuel filters. 10m Cat, to a 2m Cat, and finally through the OE filter. With a single Kennedy lift pump I can hold 22k+ @3200ms.
__________________
Brandon


LB7
SunCoast
EFILive
HTT

588hp 1096tq
Reply With Quote
  #15  
Old 06-09-2010, 07:24 PM
backe backe is offline
FNG
 
Join Date: May 2010
Location: NW New Mexico
Truck: SC/LB
Engine: LLY
Transmission: Automatic
Posts: 11
Default

Can you guys get some pics of your lift pump/filter set ups and stock filter delete. thx
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:42 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors