Duramax Diesels Forum Truck of the Week
  #1  
Old 09-10-2017, 06:34 AM
duramaxnate's Avatar
duramaxnate duramaxnate is offline
That guy......
 
Join Date: Feb 2014
Location: Norco, CA
Posts: 375

Default 09 LMM Weird No Start Issue

Got a weird issue.

Truck is a 2009 Sierra, Truck had dead batteries when it came into the shop, so I charged them up fully, Good voltage to the truck, Go to crank it, Nothing but clicks to the starter, BUT when I put a diagnostic relay in (dummy relay with a switch) truck cranks.

Throwing the following DTCs:

P0633
(I will post any other ones in a few when I go check the truck again.)

Truck has the xx8594 Cal in (actually flashed a new one from GM).
The Vats light is NOT lit up on the cluster. Just the TPMS light and MIL light.
Key is already learned according to the tech 2.

Has anyone seen this? I always seem to get the troubled children..

I have been lacking in my visits lately, I promise to visit more often , Shop has been busy and growing.
__________________
SOCAL DIESEL TRUCKS
WWW.SOCALDIESELTRUCKS.COM
MCFOO RACING
WWW.MCFOORACING.COM

-"Casper" 2005 GMC LBZ ECSB
Best Time: 10.59 @ 128 (Kat Driving)

-"Betty" 2006 GMC LBZ CCSB
Best Time: 12.70 @ 104


-"Bender" 1978 Chevy C30 4x4
454/TH400 Currently
Soon...Kodiak LBZ / Ally 2000 5 speed.
and a bunch of different things to come...
"My Glamis cruiser"

-"Mobile Marriott" 2006 Fleetwood Gearbox 300fs
McFoo Racing mobile command center

-"Spooky" 2002 Ford Explorer XLT/SE (Sucks Edition) Daily Driver. New Trans thanks to Mike L.


Thanks to all that helped me
- The McRats
- Mike L @ Inglewood Transmission
- And many others


Reply With Quote
  #2  
Old 09-10-2017, 06:38 AM
NC-smokinlmm's Avatar
NC-smokinlmm NC-smokinlmm is offline
<<<Future tuna killer
 
Join Date: May 2011
Location: At Da Beach
Posts: 3,828
Default

Check grounds and reseat ecu connection.
__________________
2010 GMC 1500 SCSB Denali Clone < lifted 22's/33's, Kooks, Magnaflow, 5.3, 6l80, TVS1900, lots of boost, Mayhem tuned, etc...

2015 Corvette Stingray Z 51 < Stock...

2016 LML CCSB Denali < Lifted 22's/35's, Fox 2.0 < I officially need help.
Reply With Quote
  #3  
Old 09-10-2017, 06:46 AM
duramaxnate's Avatar
duramaxnate duramaxnate is offline
That guy......
 
Join Date: Feb 2014
Location: Norco, CA
Posts: 375

Default

Quote:
Originally Posted by NC-smokinlmm View Post
Check grounds and reseat ecu connection.
Grounds were cleaned at the terminals and the had the ECM out to clean everything. Same results. Next thing I am doing is checking fuses for bad connections (could be something as stupid as that)
__________________
SOCAL DIESEL TRUCKS
WWW.SOCALDIESELTRUCKS.COM
MCFOO RACING
WWW.MCFOORACING.COM

-"Casper" 2005 GMC LBZ ECSB
Best Time: 10.59 @ 128 (Kat Driving)

-"Betty" 2006 GMC LBZ CCSB
Best Time: 12.70 @ 104


-"Bender" 1978 Chevy C30 4x4
454/TH400 Currently
Soon...Kodiak LBZ / Ally 2000 5 speed.
and a bunch of different things to come...
"My Glamis cruiser"

-"Mobile Marriott" 2006 Fleetwood Gearbox 300fs
McFoo Racing mobile command center

-"Spooky" 2002 Ford Explorer XLT/SE (Sucks Edition) Daily Driver. New Trans thanks to Mike L.


Thanks to all that helped me
- The McRats
- Mike L @ Inglewood Transmission
- And many others


Reply With Quote
  #4  
Old 09-10-2017, 02:09 PM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 2,885

Default

Quote:
Originally Posted by duramaxnate View Post
Got a weird issue.

Truck is a 2009 Sierra, Truck had dead batteries when it came into the shop, so I charged them up fully, Good voltage to the truck, Go to crank it, Nothing but clicks to the starter, BUT when I put a diagnostic relay in (dummy relay with a switch) truck cranks.

Throwing the following DTCs:

P0633
(I will post any other ones in a few when I go check the truck again.)

Truck has the xx8594 Cal in (actually flashed a new one from GM).
The Vats light is NOT lit up on the cluster. Just the TPMS light and MIL light.
Key is already learned according to the tech 2.

Has anyone seen this? I always seem to get the troubled children..

I have been lacking in my visits lately, I promise to visit more often , Shop has been busy and growing.

Just had something similar happen to my dads LMM. Was down for headgaskets went to start and batteries were dead. Charged batteries and wouldn't crank, gauges wouldn't work either. Disconnected the batteries and undid the bale connectors checked for bent pins. Hooked everything back up and it started fine and everything worked. No codes.
__________________
2008 GMC duramax crew cab short bed 2500.
10.98@124mph

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #5  
Old 10-04-2017, 08:01 AM
duramaxnate's Avatar
duramaxnate duramaxnate is offline
That guy......
 
Join Date: Feb 2014
Location: Norco, CA
Posts: 375

Default

Truck cranks with the key now!! Had a brain fart, forgot this truck had a battery under the passenger door on the frame, I thought it only had one. Well that battery was dead dead. Swapped both batteries out and everything is good. Going to finish it up tonight or tomorrow morning and she will start for the first time in a while. Btw, It's Black Mamba.
__________________
SOCAL DIESEL TRUCKS
WWW.SOCALDIESELTRUCKS.COM
MCFOO RACING
WWW.MCFOORACING.COM

-"Casper" 2005 GMC LBZ ECSB
Best Time: 10.59 @ 128 (Kat Driving)

-"Betty" 2006 GMC LBZ CCSB
Best Time: 12.70 @ 104


-"Bender" 1978 Chevy C30 4x4
454/TH400 Currently
Soon...Kodiak LBZ / Ally 2000 5 speed.
and a bunch of different things to come...
"My Glamis cruiser"

-"Mobile Marriott" 2006 Fleetwood Gearbox 300fs
McFoo Racing mobile command center

-"Spooky" 2002 Ford Explorer XLT/SE (Sucks Edition) Daily Driver. New Trans thanks to Mike L.


Thanks to all that helped me
- The McRats
- Mike L @ Inglewood Transmission
- And many others


Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:23 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors