Duramax Diesels Forum Truck of the Week
  #1  
Old 10-24-2015, 06:52 AM
countrycorey's Avatar
countrycorey countrycorey is offline
Trust Me I'm an Engineer
 
Join Date: Jan 2010
Location: LA
Posts: 1,333

Default Coolant tank issue

I put a HSP fabbed coolant tank on my LBZ when I put my twin kit on and now I'm having an issue with coolant leaking out of the threads of the low coolant sensor. Anyone else seen or fixed this issue?


Corey

Edit: it's giving me a low coolant light but when I checked it, it's still full?
__________________
2007 Chevy Classic CCSB LS 4x4 w/ LBZ & 6 Spd Ally
Graystone Metallic
295/70/17 Nitto Trail Grapplers on Chrome H2s w/ LMM Centers
Custom CamLocker Toolbox
Grizzly Nerf Bars
Pioneer 4100 Head Unit
JL Audio Components
Sportsman Max4 Seat Covers
MPI GT4202/Stock
HSP Coolant Tank
Tinted Windows
MBRP 5"
PCV Rerouted
EGR Blocker & Fingerstick
Nicktane 1 Micron Filter & Adapter
Banks Hot Side Intercooler Tube
ProFab Y-Bridge and 3" Cold Side Boost Tube
AutoMeter Phantom II Boost and EGT on A-Pillar
Hammerhead Armor Replacement Front Bumper
EFILive from IdahoRob
Fleece All On Mod




Last edited by countrycorey; 10-24-2015 at 11:00 AM.
Reply With Quote
  #2  
Old 10-25-2015, 07:04 AM
countrycorey's Avatar
countrycorey countrycorey is offline
Trust Me I'm an Engineer
 
Join Date: Jan 2010
Location: LA
Posts: 1,333

Default

Anyone?


Corey
__________________
2007 Chevy Classic CCSB LS 4x4 w/ LBZ & 6 Spd Ally
Graystone Metallic
295/70/17 Nitto Trail Grapplers on Chrome H2s w/ LMM Centers
Custom CamLocker Toolbox
Grizzly Nerf Bars
Pioneer 4100 Head Unit
JL Audio Components
Sportsman Max4 Seat Covers
MPI GT4202/Stock
HSP Coolant Tank
Tinted Windows
MBRP 5"
PCV Rerouted
EGR Blocker & Fingerstick
Nicktane 1 Micron Filter & Adapter
Banks Hot Side Intercooler Tube
ProFab Y-Bridge and 3" Cold Side Boost Tube
AutoMeter Phantom II Boost and EGT on A-Pillar
Hammerhead Armor Replacement Front Bumper
EFILive from IdahoRob
Fleece All On Mod



Reply With Quote
  #3  
Old 10-25-2015, 07:15 AM
clrussell's Avatar
clrussell clrussell is offline
pro-procrastinator
 
Join Date: Sep 2013
Posts: 4,880
Default

Did you put thread sealant on the sensor? Mark which way is up right now then pull it out and see if that relates to how the float is on it. I think there was a little arrow on the one I installed that had to point up


Sent from my iPhone using Tapatalk
__________________
17 GMC all terrain L5P, stock with dark windows

07 crew long classic- stolen
.
Reply With Quote
  #4  
Old 10-25-2015, 07:18 AM
countrycorey's Avatar
countrycorey countrycorey is offline
Trust Me I'm an Engineer
 
Join Date: Jan 2010
Location: LA
Posts: 1,333

Default Coolant tank issue

I did, but I guess it wasn't enough. So I'll be redoing that this afternoon!

Thank you!


Corey
__________________
2007 Chevy Classic CCSB LS 4x4 w/ LBZ & 6 Spd Ally
Graystone Metallic
295/70/17 Nitto Trail Grapplers on Chrome H2s w/ LMM Centers
Custom CamLocker Toolbox
Grizzly Nerf Bars
Pioneer 4100 Head Unit
JL Audio Components
Sportsman Max4 Seat Covers
MPI GT4202/Stock
HSP Coolant Tank
Tinted Windows
MBRP 5"
PCV Rerouted
EGR Blocker & Fingerstick
Nicktane 1 Micron Filter & Adapter
Banks Hot Side Intercooler Tube
ProFab Y-Bridge and 3" Cold Side Boost Tube
AutoMeter Phantom II Boost and EGT on A-Pillar
Hammerhead Armor Replacement Front Bumper
EFILive from IdahoRob
Fleece All On Mod



Reply With Quote
  #5  
Old 10-25-2015, 10:33 AM
clrussell's Avatar
clrussell clrussell is offline
pro-procrastinator
 
Join Date: Sep 2013
Posts: 4,880
Default

Quote:
Originally Posted by countrycorey View Post
I did, but I guess it wasn't enough. So I'll be redoing that this afternoon!

Thank you!


Corey

Let me know if that helps. I used normal ole Teflon tape for a few wraps and then installed and made the arrow point up.


Sent from my iPhone using Tapatalk
__________________
17 GMC all terrain L5P, stock with dark windows

07 crew long classic- stolen
.
Reply With Quote
  #6  
Old 10-25-2015, 11:29 AM
countrycorey's Avatar
countrycorey countrycorey is offline
Trust Me I'm an Engineer
 
Join Date: Jan 2010
Location: LA
Posts: 1,333

Default

Quote:
Originally Posted by clrussell View Post
Did you put thread sealant on the sensor? Mark which way is up right now then pull it out and see if that relates to how the float is on it. I think there was a little arrow on the one I installed that had to point up


Sent from my iPhone using Tapatalk

What thread sealant is recommended?


Corey
__________________
2007 Chevy Classic CCSB LS 4x4 w/ LBZ & 6 Spd Ally
Graystone Metallic
295/70/17 Nitto Trail Grapplers on Chrome H2s w/ LMM Centers
Custom CamLocker Toolbox
Grizzly Nerf Bars
Pioneer 4100 Head Unit
JL Audio Components
Sportsman Max4 Seat Covers
MPI GT4202/Stock
HSP Coolant Tank
Tinted Windows
MBRP 5"
PCV Rerouted
EGR Blocker & Fingerstick
Nicktane 1 Micron Filter & Adapter
Banks Hot Side Intercooler Tube
ProFab Y-Bridge and 3" Cold Side Boost Tube
AutoMeter Phantom II Boost and EGT on A-Pillar
Hammerhead Armor Replacement Front Bumper
EFILive from IdahoRob
Fleece All On Mod



Reply With Quote
  #7  
Old 10-25-2015, 11:34 AM
countrycorey's Avatar
countrycorey countrycorey is offline
Trust Me I'm an Engineer
 
Join Date: Jan 2010
Location: LA
Posts: 1,333

Default

Quote:
Originally Posted by clrussell View Post
Let me know if that helps. I used normal ole Teflon tape for a few wraps and then installed and made the arrow point up.


Sent from my iPhone using Tapatalk
That's what I was wanting to know. I guess what I used the first time was bad as it's been in my toolbox forever.


Corey
__________________
2007 Chevy Classic CCSB LS 4x4 w/ LBZ & 6 Spd Ally
Graystone Metallic
295/70/17 Nitto Trail Grapplers on Chrome H2s w/ LMM Centers
Custom CamLocker Toolbox
Grizzly Nerf Bars
Pioneer 4100 Head Unit
JL Audio Components
Sportsman Max4 Seat Covers
MPI GT4202/Stock
HSP Coolant Tank
Tinted Windows
MBRP 5"
PCV Rerouted
EGR Blocker & Fingerstick
Nicktane 1 Micron Filter & Adapter
Banks Hot Side Intercooler Tube
ProFab Y-Bridge and 3" Cold Side Boost Tube
AutoMeter Phantom II Boost and EGT on A-Pillar
Hammerhead Armor Replacement Front Bumper
EFILive from IdahoRob
Fleece All On Mod



Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:57 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors