Duramax Diesels Forum Truck of the Week
  #76  
Old 01-15-2017, 03:37 PM
oscyjack's Avatar
oscyjack oscyjack is offline
Hotrodder
 
Join Date: May 2016
Location: Northeast
Posts: 591
Default

Yeah i think ill give it a try as well when I put the stainless lines in
__________________
'08 LMM CCSB
Limitless trans
EFIlive - PPEI
Built front end
All the bolt ons
33x11.5 on 17x9 -12
HB/brake upgrades
Reply With Quote
  #77  
Old 01-18-2017, 10:05 PM
minerigger's Avatar
minerigger minerigger is offline
Hotrodder
 
Join Date: Dec 2013
Location: Casper, WY
Posts: 2,492
Default

Quote:
Originally Posted by WVRigrat05 View Post
It was blue devil, got it at autozone. I only used half the bottle and my box quit leaking. I used the other half when I flushed it last month.
Picked up some of the blue devil last night. This morning sucked out about 4-6oz. And dumped half bottle in. Truck needs a bath something awful then I'll be able to tell if it stopped. I'll keep ya posted. Must be serious stuff as it come with a warranty. Thanks for the help Reger
__________________
Brock

06 LBZ ECLB

Gauges, Danville Tunes, 5" Dumped, Trans by Evan, DP Stg2r, Sleeved/Braced and some other odds and ends crap that we all have
Reply With Quote
  #78  
Old 05-16-2017, 02:17 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default

Update.
Still no leaks, but........flushed system with AW32 hyd oil, worked good, its 84 today and mother****er won't steer, I'm headed to work so I dumped a concoction of shit in it and am making tracks.

So we'll see what that ugly ass overpriced PSC pump does when I get back in.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)
Reply With Quote
  #79  
Old 05-16-2017, 03:36 PM
clrussell's Avatar
clrussell clrussell is online now
pro-procrastinator
 
Join Date: Sep 2013
Posts: 4,387
Default

I wonder if it's the fluid you're using.. I can't tell you the last time I put a ps pump on a dmax. Let alone had issues with it.. plenty of trucks with big wheels and tires..
__________________
01 ext cab, 480 over billet ihi, trans with g converter, sac 45s, tap shift, lots of black, everything built by myself with help from some of the best in the buisness.

Thanks to everyone on this forum who has helped me and those whom I bought parts from.

Special thanks to Evan, James, Russell, Mark and all the others I'm forgetting.
Reply With Quote
  #80  
Old 05-16-2017, 03:45 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default

Always ran valvoline up until the hydraulic oil.

Heat seems to be my issue. All these damn hills working that engine at lower speeds heat soaks it and kills them. I put a cooler on but it's not big enough, I have another cooler mounted (half ton trans cooler) but I haven't plumbed it up yet.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)

Last edited by WVRigrat05; 05-16-2017 at 03:57 PM.
Reply With Quote
  #81  
Old 05-16-2017, 04:27 PM
Dozerboy's Avatar
Dozerboy Dozerboy is offline
Hotrodder
 
Join Date: Jun 2009
Location: TX of course
Posts: 2,885

Default

I use Redline fluid and have 180k on my original pump. It's had 33's on it since I bought it pretty much.



Sent from my iPhone using Tapatalk
__________________

06 GMC 2500 CCSB SLT LBZ 4X4





These views expressed on this post are not my own, but rather randomly generated computer gibberish, and in no way should be used to judge the author's IQ or mental health.
Reply With Quote
  #82  
Old 05-16-2017, 06:14 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 12,906

Default Another pump bites the dust

Hydraulic fluid goes to shit after 115*. It really has to be kept cool. There are guys that run that same stuff as shock oil in the off road world, does good for an occasional off roader but it will not last in a truck that hammers through the desert. Proper size shocks play a role there too though.

I still really like the BG stuff. Got it got a few times and made no difference. Lots of guys swear by the redline oil for crawlers with full hydro steering too
__________________
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #83  
Old 05-16-2017, 06:30 PM
Dozerboy's Avatar
Dozerboy Dozerboy is offline
Hotrodder
 
Join Date: Jun 2009
Location: TX of course
Posts: 2,885

Default

Hydraulic oil does not go to shit 115*. 230* is about the max it should see. At 250* the oil still isn't really the issue. The seals and o rings get hard and will fail. A properly functioning and design hydraulic system should operate at about 100* above ambient temperature.

Sent from my SAMSUNG-SM-G900A using Tapatalk
__________________

06 GMC 2500 CCSB SLT LBZ 4X4





These views expressed on this post are not my own, but rather randomly generated computer gibberish, and in no way should be used to judge the author's IQ or mental health.
Reply With Quote
  #84  
Old 05-16-2017, 07:40 PM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 12,906

Default Another pump bites the dust

Quote:
Originally Posted by Dozerboy View Post
Hydraulic oil does not go to shit 115*. 230* is about the max it should see. At 250* the oil still isn't really the issue. The seals and o rings get hard and will fail. A properly functioning and design hydraulic system should operate at about 100* above ambient temperature.

Sent from my SAMSUNG-SM-G900A using Tapatalk


Yup your right, I misinterpreted what a buddy of mine was telling me. Ignore me lol
__________________
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
  #85  
Old 06-22-2017, 07:53 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default

Well I finally got almost two weeks off and got my 4 hours of mowing done and 6 of 8 hours of weed eating wiped out and some other chores caught up.

Trucks getting tore down tomorrow and getting the pump ripped out and doing the driver side manifold while I'm at it and pluming in my second P/S cooler. So I'll have a review of the pump hopefully Saturday, gotta do some spring cleaning while the trucks apart too.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)
Reply With Quote
  #86  
Old 06-22-2017, 08:01 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default




Says on label to use PSC's fluid or AC Delco factory fluid and never use any synthetic fluid.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)
Reply With Quote
  #87  
Old 06-22-2017, 08:08 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default

Quote:
Originally Posted by Chevy1925 View Post
Yup your right, I misinterpreted what a buddy of mine was telling me. Ignore me lol
I'm 90% sure it's coincidence since the pump was acting up off and on to start with but I flushed mine with AW32 and it howls non stop, brake pedal is firmer, still steers fine but man does it grind like granny's old 86' Buick.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)
Reply With Quote
  #88  
Old 06-22-2017, 09:13 PM
Tothemax's Avatar
Tothemax Tothemax is offline
xgmtech
 
Join Date: Oct 2014
Location: new york
Posts: 378

Default

I put that pump in my truck a month ago and feel it has less pressure than my GM one did. My steering got harder opposite of what I needed. Hope you have better luck.
__________________
2017 l5p cc/sb ltz z71 (stormtrooper edition)


06 lbz ec/sb. stock motor, Danville 4094s2r, built trans by me, limitless 1078 converter, 60% sticks, S&S 12mm pump. dyno tuned by mark @ Danville. 775hp 1383ftlb

best so far. 11.806 @ 112.80 1.682 60ft

06 lbz rc/fb dually work truck. Danville tuned
Reply With Quote
  #89  
Old 06-22-2017, 09:30 PM
WVRigrat05's Avatar
WVRigrat05 WVRigrat05 is offline
Wound for sound
 
Join Date: Jan 2011
Location: French Creek, West Virginia
Posts: 2,599

Default

If it doesn't work they will get their pump back, and I'll buy a brand new stock LML pump. I hope it works because I'll be mad as ****, I hate working on shit just to fix it, especially when I paid for something to do what it says.
__________________
Reger
05' Black Chevy CC/SB LT- Blackout Performance built motor/trans/tuning- Gone

The Blessed Hellride- 08' White GMC Sierra SLT CC/SB,
100k miles-FOR SALE

Wife's ride- 2016 Pearl white Legacy limited 3.6R 15k miles, garage ornament

Rig ride/patience tester-02' Black Eddie Bauer exploder 4.6, -180k, still sporting original trans (for now)
Reply With Quote
  #90  
Old 06-22-2017, 10:16 PM
Tothemax's Avatar
Tothemax Tothemax is offline
xgmtech
 
Join Date: Oct 2014
Location: new york
Posts: 378

Default

I hear you. far too often do I get to do the job twice and pay twice do to said better part. I didn't even bother calling them I'm sure ill get the same old (its not are parts fault)
__________________
2017 l5p cc/sb ltz z71 (stormtrooper edition)


06 lbz ec/sb. stock motor, Danville 4094s2r, built trans by me, limitless 1078 converter, 60% sticks, S&S 12mm pump. dyno tuned by mark @ Danville. 775hp 1383ftlb

best so far. 11.806 @ 112.80 1.682 60ft

06 lbz rc/fb dually work truck. Danville tuned
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors