Duramax Diesels Forum Truck of the Week
  #1  
Old 11-14-2017, 09:19 PM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default 09 Lmm recent upgrades and now white smoke.

Getting a lot of white smoke at startup with some light engine shaking until it warms up a bit. Sitting in my driveway it can smoke for quite a bit but if I start driving it, it clears up within a couple minutes. Recently added 100 over injectors, 68stg2r and an exergy 12mm pump. Once itís up around 130 degrees balance rates are all under 1 percent but at start up #2 is giving me a +7. Changed out the glow plug but still the same issue. Whatís my next step guys? I did notice after I shut the truck off rail pressure goes down to nothing within 20 seconds but it does start right up. Truck is a beast when warm and runs like it should after itís reached temp but man it can puff some smoke until then. Any help is appreciated, Thanks!
Reply With Quote
  #2  
Old 11-15-2017, 03:57 AM
ZeroGravity58's Avatar
ZeroGravity58 ZeroGravity58 is online now
Hotrodder
 
Join Date: Mar 2008
Location: Maryland
Posts: 811

Default

Sounds like you need to work on the tuning some. you can't drop in 100 over injectors and expect it to act like stock without alittle bit of leg work...
__________________
09 lmm ccsb ltz, ATP tuning, mpi s480 over stocker, big dipper trans, 60 overs, 10mm stroker pump, ppe up pipes and manifold, banks intercooler & exhaust, airdog165, isspro guages, traction bars, the list goes on
01 lb7 red RC/LB 11.58@119 MPH, SOLD
01 lb7 Black CC/LB, SOLD
Reply With Quote
  #3  
Old 11-15-2017, 04:07 AM
Yngdmax92's Avatar
Yngdmax92 Yngdmax92 is offline
Hotrodder
 
Join Date: Sep 2013
Posts: 553
Default

Compression check?
__________________
2003 2500 hd cc/sb (leftovers) MPS 63.5 ihi, built trans, airdog 150, 30 overs..... Sold


New and improved! 2007 classis lbz LS ec/sb

Egr delete, pcv re-route, PIPED, airdog 4g 165,

Danville performance tunes.
Reply With Quote
  #4  
Old 11-15-2017, 05:38 AM
Lmmbrad33's Avatar
Lmmbrad33 Lmmbrad33 is offline
IBEW 15
 
Join Date: May 2016
Location: Oregon, IL
Posts: 20
Default

Quote:
Originally Posted by ZeroGravity58 View Post
Sounds like you need to work on the tuning some. you can't drop in 100 over injectors and expect it to act like stock without alittle bit of leg work...
This^^ & make sure that power is getting from the glow plug control module to the glow plugs and that something wasn't left unhooked. You didn't mention any codes, but prior tuning may have had GP codes disabled?
__________________
'08 GMC CCSB
3794 II/60% INJ/2X CP3

'04.5 GMC RC
All Stock Rust Free
Reply With Quote
  #5  
Old 11-15-2017, 07:05 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Iím working on getting a compression tester to check #2 and what kind of tuning changes do you suggest so I can let Mark know?
Reply With Quote
  #6  
Old 11-15-2017, 07:06 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Quote:
Originally Posted by Lmmbrad33 View Post
This^^ & make sure that power is getting from the glow plug control module to the glow plugs and that something wasn't left unhooked. You didn't mention any codes, but prior tuning may have had GP codes disabled?
Should I just use a test light and have someone key it on?
Reply With Quote
  #7  
Old 11-15-2017, 11:12 AM
ZeroGravity58's Avatar
ZeroGravity58 ZeroGravity58 is online now
Hotrodder
 
Join Date: Mar 2008
Location: Maryland
Posts: 811

Default

When you changed the glow plugs did you use ac delco plugs? Call Mark and tell him what you have and see what he suggests. I'm sure he run into this kind of stuff before if it is the tuning
__________________
09 lmm ccsb ltz, ATP tuning, mpi s480 over stocker, big dipper trans, 60 overs, 10mm stroker pump, ppe up pipes and manifold, banks intercooler & exhaust, airdog165, isspro guages, traction bars, the list goes on
01 lb7 red RC/LB 11.58@119 MPH, SOLD
01 lb7 Black CC/LB, SOLD
Reply With Quote
  #8  
Old 11-15-2017, 11:37 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Yes I used an ac Delco glow plug in cylinder 2. Just talked with Danville and he mentioned I might need to reserialize the new injectors with a tech 2.

Last edited by Nickracer9; 11-15-2017 at 11:56 AM.
Reply With Quote
  #9  
Old 12-04-2017, 06:05 PM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Update, Mark noticed my map sensor isn’t reading properly in one of my logs, got a new one on order. Hope this is it!
Reply With Quote
  #10  
Old 06-10-2018, 08:21 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Anyone know what a normal reading is for the intake manifold absolute pressure?
Reply With Quote
  #11  
Old 06-10-2018, 09:45 AM
gmduramax's Avatar
gmduramax gmduramax is offline
Shits broke
 
Join Date: Jun 2008
Location: Nor cal
Posts: 2,851

Default

What brand injectors
__________________
2008 GMC duramax crew cab short bed 2500.
10.98@124mph

Thanks to Mike L, SoCal Diesel, and Abel Chevorlet.

Tailgate Crew Member #1
Reply With Quote
  #12  
Old 06-10-2018, 10:36 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

S&S, but that engine went boom! Bent rods and cracked piston for the win. Now I’m built engine, still a quick puff at start up but tolerable but just making sure everything is dialed. Noticed that map sensor sitting at 12ish psi.
Reply With Quote
  #13  
Old 06-10-2018, 10:58 AM
Ron Nielson Ron Nielson is offline
Gearhead
 
Join Date: Oct 2009
Location: Berryton, KS
Posts: 93
Default

Mine reads 27.8 in Hg or 13.6540867759163 psi at idle.
__________________
Ron Nielson

2008 Chevy Silverado LT, SRW, Crew Cab, LB, LMM/Allison, Rear lowered 2": otherwise, fully stock at this point. Edge Insight CTS
Reply With Quote
  #14  
Old 06-12-2018, 10:37 AM
Nickracer9 Nickracer9 is offline
Gearhead
 
Join Date: May 2012
Posts: 81
Default

Sent some logs to mark, hopefully he can figure it out. My map reading is 12.6 psi.
Reply With Quote
  #15  
Old 06-12-2018, 10:39 AM
Chevy1925's Avatar
Chevy1925 Chevy1925 is offline
don't know sh!t about IFS

 
Join Date: Oct 2009
Location: Phoenix Az
Posts: 14,219

Default

Quote:
Originally Posted by Nickracer9 View Post
Sent some logs to mark, hopefully he can figure it out. My map reading is 12.6 psi.
no matter what or at idle? whats Baro reading?
__________________
Quote:
Originally Posted by JoshH View Post
Mike L is my role model. I want to be like him when I grow up.
James

02 LL7 2500HD CC/LB dmax/alli "The Limo"

BIG THANKS TO: Mike L, Steve, Trent, Guy, Dan, Ruben, Josh H, Scott, Brian and everyone else who has put a hand in to help me.

best time to date: 12.39

motor died/bent rods = 3/11/11
back from the dead 7:04pm 4/9/2012

Limo is back in the garage, now driving a built chevy tracker
Tailgate Crew Member #4
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:26 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
vB.Sponsors