Duramax Diesels Forum Truck of the Week
Old 06-21-2017, 12:28 PM
smcdaniel smcdaniel is offline
Join Date: Jan 2017
Posts: 4
Default Serial Communications Issue

I recently removed my motor and transmission to replace the head gaskets and upgrade the transmission to an ATS Stage II with the Co-Pilot controller. When I got everything back in the truck, I attempted to load the tune file through an AutoCal and it was not able to pick up my ECM. Whenever I would perform the Auto-Detect function in passthrough mode using a laptop, it would pick up the TCM, but not the ECM. I attempted to used my code scanner to find it and even my Edge CTS monitor - no dice. The scanner only found the TCM and no other modules. I had the fuses for OnStar, ABS, Radio, and Radio Amp pulled and removed the aftermarket head unit and the harness. There is no alarm or remote start on the truck. The truck would crank, but it would not start. All of the windows rolled up and down as planned and the seat controls still worked fine.

So, after days of researching this forum and others I was able to locate the serial communications wire in the C1 plug. I cut it and ran it directly to the OBD II harness and was able to find the ECM, download the stock file and upload the tune. After the tune was loaded, I reconnected the wires and removed by bypass wire - I attempted to read the ECM again using all the stuff I had and couldn't. So next I decided to tee into the wire at the ECM and run it inside the cab to the OBD II. I was able to detect the ECM and the TCM, but no other modules using my scanner. The truck started and ran.

I'm thinking that I have a break in that wire somewhere in the system or that the BCM may be somehow blocking the signal from reaching the ECM, but not the TCM.... It doesn't make a lot of sense to me . I've found some wiring schematics for the truck, but there is not much detail on the routing of this particular wire. Is this something I should work on replacing? Is it safe to operate my truck with the bypass wire installed? Any help is greatly appreciated!
2005 ccsb
PPEI Tuning, ATS Stage II w/ CoPilot, Fleece Performance 60-overs, batmowheel, PPE manifolds and up pipes, MRBP 3" downpipe, 5" exhaust, ARP Head Studs, PPE race plug, Kennedy Diesel Lift Pumps, WCF Fab y-bridge and intake pipes, RCX 6" lift, 37x12.50 R20
Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -7. The time now is 02:52 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.