Duramax Diesels Forum Truck of the Week
  #1  
Old 08-12-2017, 08:31 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default P0088. Fuel rail pressure will hit 29,000 at times

So p0088 code. Replaced both fpr. Took it for a drive and it did it again 20 mile later. Cleared code drove home fine. Don't know what to do next.
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #2  
Old 08-12-2017, 08:32 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Lmm built engine, ppe duel fueler, Danville tunes about 20,000 miles on setup
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #3  
Old 08-12-2017, 09:00 AM
Dozerboy's Avatar
Dozerboy Dozerboy is offline
Hotrodder
 
Join Date: Jun 2009
Location: TX of course
Posts: 3,148

Default

Have you talked to your tuner to see how the tune setup?

Sent from my SAMSUNG-SM-G900A using Tapatalk
__________________

06 GMC 2500 CCSB SLT LBZ 4X4





These views expressed on this post are not my own, but rather randomly generated computer gibberish, and in no way should be used to judge the author's IQ or mental health.
Reply With Quote
  #4  
Old 08-12-2017, 09:14 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

No. But same tunes for 20,000 miles
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #5  
Old 08-12-2017, 10:27 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

I let my truck idle for 3 minutes it was fine then fuel rail pressure jumped to 29,000
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #6  
Old 08-12-2017, 10:31 AM
IOWA LLY's Avatar
IOWA LLY IOWA LLY is online now
Yes, its really me
 
Join Date: Feb 2007
Posts: 2,052
Default

Quote:
Originally Posted by Badheartbull View Post
I let my truck idle for 3 minutes it was fine then fuel rail pressure jumped to 29,000


Check your supply side pressure.

Also make sure your return isn't restricted.


Sent from my iPhone using Tapatalk Pro
__________________
2003 GMC CCSB LLY
Built by me, tuned by me.

2009 ECI Diesel Truck Points Champion
2010 ECI Diesel Truck Points Champion
2011 ECI Diesel Truck Points Champion
2012 ECI Diesel Truck Points Champion

Big thanks to everyone who helps me.

Best 1/8th, 7.29, 98.6MPH (Street tires, fuel only, single Journal bearing GT42 charger) (2010)

Best 1/8th, 6.93, 104.24MPH (Street tires, fuel only, single HX60 turbo) (2016)

Best 1/8th, 6.60, 106.6MPH (Street tires, fuel only, single HX60 turbo) (2017)
Reply With Quote
  #7  
Old 08-12-2017, 11:00 AM
2004LB7's Avatar
2004LB7 2004LB7 is offline
Hotrodder
 
Join Date: Dec 2010
Location: Norcal
Posts: 689

Default

Maybe a loose wire / bad connection at the regulator?

Can you hear the engine noise or knocking when it does it?
__________________
2008 Chevrolet 3500HD DRW LTZ
285/75/17 Nitto Dura Grapplers, 4.56 gears, Front and rear ARB lockers, Efi Live tuning by me, Raptor 160 LP, Cognito 4-6 NTB Lift, 4" Exhaust, Built Trans by Mike L.
Reply With Quote
  #8  
Old 08-12-2017, 11:09 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Quote:
Originally Posted by 2004LB7 View Post
Maybe a loose wire / bad connection at the regulator?

Can you hear the engine noise or knocking when it does it?
Yes sounds like a ford
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #9  
Old 08-12-2017, 11:11 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Quote:
Originally Posted by IOWA LLY View Post
Check your supply side pressure.

Also make sure your return isn't restricted.


Sent from my iPhone using Tapatalk Pro
Pressure at lift pump is at 8 psi
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #10  
Old 08-12-2017, 11:12 AM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Quote:
Originally Posted by Badheartbull View Post
Pressure at lift pump is at 8 psi
Was at 9psi before. I adjusted it
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #11  
Old 08-12-2017, 11:37 AM
ZeroGravity58's Avatar
ZeroGravity58 ZeroGravity58 is offline
Hotrodder
 
Join Date: Mar 2008
Location: Maryland
Posts: 736

Default

Could the dual fueler box be bad?
__________________
09 lmm ltz, mpi s480 over stocker, big dipper trans, 60 overs, 10mm stroker pump, ppe up pipes and manifold, banks intercooler & exhaust, airdog165, traction bars, the list goes on
01 lb7 red RC/LB 11.58@119 MPH, SOLD
01 lb7 Black CC/LB, SOLD
Reply With Quote
  #12  
Old 08-12-2017, 12:02 PM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Quote:
Originally Posted by ZeroGravity58 View Post
Could the dual fueler box be bad?
I'm going to try this next thanks
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #13  
Old 08-18-2017, 06:23 PM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

I just put the new controller on 25 miles so far so good.
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
  #14  
Old 08-18-2017, 06:33 PM
quinton's Avatar
quinton quinton is offline
Hotrodder
 
Join Date: Nov 2011
Location: Granbury Tx.
Posts: 1,824

Default

If it happens again check your ground and positive connections. I had my ground wire loose and it was maxing out every now and then.
__________________
EFIlive dsp5 by me, Built trans by me, 68 danville, stock fuel, lifted. died 6/20/2013 Cracked piston. Best time 12.75 on fuel

Alive 11/15/13: lowered, Built motor, s475, plenty of fuel, plenty of spray. Tune 3 fuel only 11.84 @114, Tune 5 little bit of spray 11.45 @ 121. Both times with melted turbine wheel, loose turbo from pedestal with blown out flange gasket. .
Reply With Quote
  #15  
Old 08-18-2017, 08:17 PM
Badheartbull Badheartbull is offline
Gearhead
 
Join Date: May 2012
Location: Sw MN
Posts: 85
Default

Quote:
Originally Posted by quinton View Post
If it happens again check your ground and positive connections. I had my ground wire loose and it was maxing out every now and then.
On the controller?
__________________
"Charlize the Goldigger"
05 ccsb lly
Mostly stock
Efi live thanks Rob
MA motor mounts


07.5 ccsb lmm
Not stock
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:11 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vB.Sponsors